Re: 0x887A0006 - DXGI_ERROR_Device_Hung

by revthejedi
Reply

Original Post

Accepted Solution

0x887A0006 - DXGI_ERROR_Device_Hung

★★★ Apprentice

Game crashes randomly.

Win 7 x64

AMD FX6300

Asus R9 270x

8Gb 1333ghz RAM

 

Drivers are all updated as of Yesterday (10/28/16)

 

Engine Error - 0x887A0006 - DXGI_ERROR_DEVICE_HUNG  The applications device failed due to badly formed commands send by the application. This is an Design-Time Issue that should be investigated and fixed.

 

Message 1 of 74 (68,805 Views)

Accepted Solution

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

★★★ Apprentice

Try turning all the settings to On and to Max/Ultra. I'm not able to confirm this yes as Orgin decided to not want to work last night (Thank you EA.) But alot of people have said that is a work around.

 

Also try Maxing the settings up to Ultra (everything turned on) Run the game, Save , Exit , Restart the game , then put your settings back.

View in thread

Message 9 of 74 (80,362 Views)

All Replies

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

EA DICE Team

@sirtenko

 

Hi,

 

First: where did you get that background? I love it..

 

I did notice on your dxdiag that you haven't installed the latest drivers for your GPU. Please completely uninstall all related drivers, and then download the latest ones from the AMD website:

 

http://support.amd.com/en-us/download/desktop?os=Windows%207%20-%2064 - select the release dated 10/27/2016.

 

Please let me know if that helps (and also where you got that desktop background..)

Message 2 of 74 (68,523 Views)
0

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

[ Edited ]
★★★ Apprentice

I never know where I get these background's other then saying Google so I left it in here for you its in 4k. ( Google: Autumn fall wallpaper rain forest ) (Or if you Right click the picture, and Click Save As it will download in 4500 x 2992 )

 

I updated(Uninstalled old, Reinstalled the new) to the beta drivers afterwards and I still get the issue, The game will start to stutter after afew rounds of MP (not in SP) and Have to restart the game. While It seemed to delay the issue it still happens. I'll keep poking around as I remember something odd like this happening before but I cannot put my fingure on what,where,when and how I fixed it.

Message 3 of 74 (68,516 Views)

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

EA DICE Team

@sirtenko

 

Thanks for adding the background!

 

Perhaps the stuttering is related to a background program on your system - I've seen reports before about MSI or ASUS motherboard apps causing stuttering for players in some of our games. If you have such apps, try disabling them.

 

You could also try running your system in a clean boot.

Message 4 of 74 (68,506 Views)
0

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

[ Edited ]
★★★ Apprentice

I've thought about that aswell, however I dont have any app's or programs (Unnecessary ones) running from my MB or any other program. I've also checked whats in the Processes and Services during the crashes to mayby see if that was it however it isnt (As far as I can tell.) Ive disabled all the ones so I get a barebones background and still nada.  My computer always boot's using the "Selective Startup" option in msconfig since I belive that things dont need to be open if i'm not going to be using it. I managed to play the SP for 3-4 hours (loving it) and I have no issues, Fps doesnt bog down or anything either. Its very strange,(Appearing to be a MP only issue)

Message 5 of 74 (68,492 Views)
0

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

EA DICE Team

@sirtenko

 

It could be happening because multiplayer is more intensive - could you try lowering your in-game settings to test if that still causes the crash?

Message 6 of 74 (68,484 Views)
0

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

★★★ Apprentice

Actually the SP is way more intensive at times but lowering the settings didnt resolve anything. However people online are saying with this error to turn All the settings to Ultra and On. Ill be trying this later as playing on lowest settings for 30+ minutes was a nightmare.

Message 7 of 74 (68,445 Views)

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

★ Novice

Exact same issue, its making the final mission of the campaign impossible for me to finish.

I have turned off all external programs, reduced my cpu and gpu to base speeds and run the game at minimal settings to try and fix

Message 8 of 74 (68,383 Views)

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

★★★ Apprentice

Try turning all the settings to On and to Max/Ultra. I'm not able to confirm this yes as Orgin decided to not want to work last night (Thank you EA.) But alot of people have said that is a work around.

 

Also try Maxing the settings up to Ultra (everything turned on) Run the game, Save , Exit , Restart the game , then put your settings back.

Message 9 of 74 (80,363 Views)
Highlighted

Re: 0x887A0006 - DXGI_ERROR_Device_Hung

[ Edited ]
★★ Novice

This does not work for me. The game crashes as soon as a match starts. 

Message 10 of 74 (67,884 Views)
Twitter Stream