Origin Web Helper Service causing slow windows startup

by StarStrike80
Reply

Original Post

Accepted Solution

Origin Web Helper Service causing slow windows startup

★★★ Novice

hi there

 

since the new update of origin windows is taking ages to startup properly. it takes about 1-2 mins before the start up is complete. the cause of this is   Origin Web Helper Service service failed to start. 

i have read on google that i am not the only person who is having this problem with  Origin Web Helper Service. i have turned off the  Origin Helper Service in origins but still that has made no difference and i still get the error about    Origin Web Helper Service service failed to start due to the following error.

 

please can you help and get this sorted as soon as possible.

Message 1 of 32 (89,110 Views)

Accepted Solution

Re: Origin Web Helper Service causing slow windows startup

★★★★★ Novice

Hi All,

I had this problem, also shows up in event viewer as event id 7000

The Origin Web Helper Service failed to start due to the following error:

The service did not respond to the start or control request in a timely fashion.

 

Quick fix is to change it's start from automatic to manual in windows services.

 

This solves the problems and still allows you access to chat and friends.

 

All the best.

 

View in thread

Message 2 of 32 (103,001 Views)

All Replies

Re: Origin Web Helper Service causing slow windows startup

★★★★★ Novice

Hi All,

I had this problem, also shows up in event viewer as event id 7000

The Origin Web Helper Service failed to start due to the following error:

The service did not respond to the start or control request in a timely fashion.

 

Quick fix is to change it's start from automatic to manual in windows services.

 

This solves the problems and still allows you access to chat and friends.

 

All the best.

 

Message 2 of 32 (103,002 Views)

Re: Origin Web Helper Service causing slow windows startup

★★★ Expert

The better option would be to open Origin, click on the word ORIGIN at the top of the screen, choose Application Settings, then turn Automatically start Origin OFF. That will keep it form starting at boot and, you will just have to start it manually after the computer boots up.

Message 3 of 32 (88,955 Views)

Re: Origin Web Helper Service causing slow windows startup

★★★★★ Novice

@DarkAmaranth1966 wrote:

The better option would be to open Origin, click on the word ORIGIN at the top of the screen, choose Application Settings, then turn Automatically start Origin OFF. That will keep it form starting at boot and, you will just have to start it manually after the computer boots up.


Sorry but how it that a better solution when the fact is it has nothing to do with the origin client loading at windows start.

The origin web helper service will still try to load even if the origin client software option "do not load at windows start" is ticked.

 

I stand by my fix as it works perfectly and still allows you access to friends and chat.

 

Disabling the service still allows the origin client to work but chat and friends are then unavailable.

 

If my fix works for you I'm glad I could help.

 

All the best.

Message 4 of 32 (88,936 Views)

Re: Origin Web Helper Service causing slow windows startup

★★★ Novice

excalibre2668 is right. i do not have  Automatically start Origin on anyway and still i get the slow starts.

what i have done is what excalibre2668 said to turn the service to manual and its worked great.

origin need to sort the problem themselves though.

 

thanks for the help Standard smile

 

 

Message 5 of 32 (88,864 Views)

Re: Origin Web Helper Service causing slow windows startup

★ Novice

Almost 2 months later and this still isn't fixed by EA

After every Origin update you have to change the service to manual again it seems, thanks EA :S

You would think setting your own service to manual as default as a quick fix wouldn't be so hard to program

Message 6 of 32 (87,467 Views)

Re: Origin Web Helper Service causing slow windows startup

★ Novice

Thanks excalibre, switching that Origin Web Helper Service from auto to manual solved my issue also. Running Win 7x64, latest origin.

Message 7 of 32 (87,375 Views)

Re: Origin Web Helper Service causing slow windows startup

★★★ Novice

Thanks Excalibre.

I just got this issue after updating Origin after a LOONG time not using it and got this error after the next start-up and your solution helped!

Message 8 of 32 (86,794 Views)

Re: Origin Web Helper Service causing slow windows startup

★★★ Apprentice

I was also wondering what this Web Helper service was and why it had to constantly be running in the background. I still don't really know what it does. I've noticed that if you disable it from within Origin it doesn't start at all anymore.

Message 9 of 32 (86,535 Views)

Re: Origin Web Helper Service causing slow windows startup

★★ Novice

Biggest problem is that each and every time Origin updates it changes that Origin webhelper Service back to Automatic. I have to remember to change it to Manual whenever it updates again.

Message 10 of 32 (86,455 Views)
Twitter Stream