[OPEN] Game Crashing when Placing Retails/Lots with mannequins

by generuler4
Reply

Original Post

[OPEN] Game Crashing when Placing Retails/Lots with mannequins

[ Edited ]
★ Guide

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? 1.77
What expansions, game packs, and stuff packs do you have installed? All of them except journey to batuu, realm of magic
Steps: How can we find the bug ourselves? Try to place a retail lot down. Maybe with mannequins not for for sure yet.
What happens when the bug occurs? The game will instantly crash and sometimes an error code.
What do you expect to see? For me to be able to place a retail lot and travel to it.
Have you installed any customization with the game, e.g. Custom Content or Mods? Yes
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. 1.77

I’ve done some testing on my own and other people said they had the same issues. With and without mods. So here’s the run down: 

 

it ONLY crashes when trying to place these lots on the galleries that are called bridal shops/wedding stuff. I placed different types of retail lots in there and no crashes. I also tried different builds of bridal shop from the gallery and it still crashes. I have no clue what’s causing those buildings to crash my game. I tried to place another bridal shop in a different world and my game still crash. It must be a certain object in those lots causing that crash. And the object probably has to deal with wedding stuff.So its retail. I built my own bridal shop using all base game stuff. I was able to build it, but once I tried to make a sim travel there I received an error code. The error code told me to relaunch my game. I didn't I just went back to that build, loaded it in build mode. Destroyed it and put another different lot a bowling alley up and my sims were able to travel to that lot. So something in retail is crashing and causing an error code. But maybe its the mannequins because I have more retail shops without mannequins that loads perfectly. I’ve tried placing those shops in a new save and other people have to. It’s still reoccurring. 

 

Edit By Crinrict: Adjusted title

Message 1 of 165 (18,872 Views)

Re: Game Crashing when Placing Retails

[ Edited ]
Hero

@generuler4 Do you have an example ? Creator/name of the lot ?

Did you delete the localthumbcache file after removing mods ?

 

 

This thread is for lots with mannequins. To find out if the lot uses Mannequins, do as follow. 

 

  1. Check if the GTW is a used pack and if it is, click on the icon
    Bild_2021-10-21_122938.png
  2. Click on the Show used Items button

    Bild_2021-10-21_123030.png
  3. Check if the lot has Mannequins
    Bild_2021-10-21_123128.png
  4. If the lot has mannequins, me too this thread. Examples are not needed
  5. If the lot doesn't have mannequins, please use this thread instead: https://answers.ea.com/t5/Bug-Reports/Sims-4-crashes-with-an-exit-whenever-trying-to-place-a-communi.... Please post name/creator for checking out for other things that could be the reason.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 2 of 165 (18,843 Views)

Re: Game Crashing when Placing Retails

[ Edited ]

I have also had the game crash on me with two lots, that I have placed several times before the pond patch, one is a residential, the other is a retail lot, both have mannequins. However the retail lot is a little shop which I build in anticipation of Cottage Living and when I first placed it, it worked fine (despite the mannequins). Only after I updated it with things from CoL (some preserves, wool and new wallpapers), it started to cause my game to crash, when placing it. The other lot is fairly old though and has no CoL content, so that can‘t be the reason either. Also in my case placing the lots is the issue. Loading or visiting versions that are already placed causes no issues.

Edit: I did some more testing with my little shop and the curious thing is that I had a photo my sim had taken in the original version of the shop. Which seemed to cause no problems when placing the lot the first time, but the version with CoL items causes the game to crash unless I remove the photo. Which is very odd. 

 

If you are looking for a lot that causes the crash, you can look into my gallery and try to place a lot named „Glimmerbrook Watch“ it‘s at the very bottom. 

Message 3 of 165 (18,838 Views)

Re: Game Crashing when Placing Retails

[ Edited ]
★ Guide

I haven’t deleted my localthumbcache but I’ll try that. For me it was all shops with the title of bridal shops. But I even made me own small “bridal shop” and it crash as soon as I tried to travel to with a sim. But loaded perfectly fine in just build mode. If I place it from the gallery it would crash as soon as I try to place it. 

Message 4 of 165 (18,823 Views)

Re: Game Crashing when Placing Retails

Hero

@Anska_Stormblade Thanks for the link.

 

Can duplicate the crashing. Attaching my crash log file for EA.

 

 

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 5 of 165 (18,811 Views)

Re: Game crashes when placing a lot from gallery

★★★★ Novice

I've been having this issue too. I've tried repairing my game multiple times, I've removed mods, I've tried it with a clean save file, I've cleaned out old saves that I no longer use, I delete the localthumbcache file and clear out the onlinethumbnailcache and cachestr files, I've tried deleting ALL cache files, I delete everything in temp and %temp% and empty my trash files, and I'm currently reinstalling my whole game (haven't tested if it works yet because I just started the installation and I have almost all the packs so it'll take a while) but so far, nothing has seemed to work.

 

It's so frustrating but seeing other people with this problem (and the fact that it started Thursday when Cottage Living was released) makes me feel a bit better about the situation and that it's not just my game but maybe a problem that EA needs to fix. 

Message 6 of 165 (15,613 Views)

Re: Game crashes when placing a lot from gallery

@giannatn29  Does this happen with all lots, or just one or a handful?  There's currently an issue with lots that include mannequins:

 

https://answers.ea.com/t5/Bug-Reports/Game-Crashing-when-Placing-Retails-Lots-with-mannequins/td-p/1...

 

If that's your issue, please use that thread.

 

@TheSpaark  Same question to you: does the lot include a mannequin?  If so, please use the above thread.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 7 of 165 (15,606 Views)

Re: Game crashes when placing a lot from gallery

★★★★ Novice
@puzzlezaddict I've only been trying retail lots because I'm trying to put in a boutique but I'll try other lots and see if that helps. Thank you! Standard smile
Message 8 of 165 (15,604 Views)

Re: Game crashes when placing a lot from gallery

[ Edited ]
★★★★ Novice

So I reinstalled my game and all my packs. Fresh clean game, all lots showed up, including lots with mannequins. Once I added all of my data back (tray, saves, and mods), all lots except the ones with mannequins loaded fine. Mannequin lots started crashing again. It seems like something about actually using the game is causing mannequins to no longer work. I could be wrong, though, since I obviously only tested my game. The mannequins are the issue, unfortunately, for me at least. Hope EA fixes this soon.

Message 9 of 165 (15,577 Views)

Re: Game Crashing when Placing Retails/Lots with mannequins

★★★★ Novice

I have this same issue too. I've done just about everything to try and fix it. Deleting localthumbcache, deleting all cache files, clearing temp and %temp%, repairing multiple times, removed mods, tried clean saves, and just reinstalled my game. What I discovered though is that deleting and reinstalling the game temporarily fixed the problem. I ran it clean and then ran it with my old saves. Clean run placed lots with mannequins just fine. Once I placed my saves in, the game crashes when placing mannequin lots again.

Message 10 of 165 (18,728 Views)