[OPEN] [ECO] Failing fabrication doesn't give bits and pieces back

by NanaMchrist
Reply

Original Post

[OPEN] [ECO] Failing fabrication doesn't give bits and pieces back

[ Edited ]
★★★ Novice

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? 1.65.70.1020
What expansions, game packs, and stuff packs do you have installed? Every single one besides nifty knitting
Steps: How can we find the bug ourselves? I wouldn't know. I can provide a video of the issue if that will help. Unfortunately, I can reproduce it every time.
What happens when the bug occurs? When I have a "saves" folder on my "sims4" folder and I fail a fabrication on the Store No More Fabricator I do not get bits and pieces back.
What do you expect to see? Being able to save a game and have bits and pieces returned to me when I fail a fabrication.
Have you installed any customization with the game, e.g. Custom Content or Mods? Never used.
Did this issue appear after a specific patch or change you made to your system? No

Hello there, I spent an extraordinary amount of time looking for a similar post but nothing. So here goes nothing... 

 

I downloaded the Eco Lifestyle 3 nights ago. Ever since, whenever I fail a project on the fabricator my bits and pieces do not get refunded.

 

I have no mods and I have all packs besides the knitting one. 

 

When I first make a character they would get the bits and pieces back but after saving, exiting and re-logging they stop being returned.

 

What have I done to check if that fixes:

1.Removed all mods.

2.Run a repair on the game. Twice. 

3.Removed all my documents folders to reset the game.

4.Removed all the saves.

5.Removed the game from my drive and registry.

6.Reinstalled and tried again. 

 

In all attempts, I can only get bits and pieces back when failing before saving and exiting the game. If I do save and exit, when back on next time I fail a project I do not get them back. What is more, if there is a save folder in the "C:\Users\xxx\Documents\Electronic Arts\The Sims 4" folder, regardless of whether it is empty or not, I do not get bits and pieces back when failing. I need to delete the whole folder to get bits and pieces back when failing a fabrication and that only lasts till I try to save again.

 

I am out of ideas. I would welcome any help or suggestions right now. I spend 3 days of my life on this already ^^

 

Edit By Crinrict: Added Tag to Title, Adjusted Title

Message 1 of 7 (1,302 Views)

Re: When I fail a fabrication I do not get bits and pieces back if I have any sa

[ Edited ]
★★★★ Expert

@NanaMchristSame thing happens to me all the time. The fabricator fails quite a lot and I lose B&P every single time.

I mentioned it several times and I'm always told I'm doing something wrong, It's not a bug, it's a mod problem, it's a CC problem, your game's corrupt, etc, etc. They don't want to admit it's a bug. I just gave up.

 

I'm just going to make a mod to fix it myself since noone else will.

Message 2 of 7 (1,251 Views)

Re: When I fail a fabrication I do not get bits and pieces back if I have any sa

Hero
@NanaMchrist Could you explain the saves folder bit a bit more ? If you have a save game, you have a saves folder there's no way around that, it even always gets created if you start a game even if you deleted it.

That's where your saves are stored.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 3 of 7 (1,214 Views)

Re: When I fail a fabrication I do not get bits and pieces back if I have any sa

[ Edited ]
★★★ Novice

Hey there, @crinrict o/


When I delete the saves folder and start a game it gets created but for all the time I am online I can get my bits and pieces back if I fail. If I save at any point that stops. If I delete the save and start again it still doesn't work. I need to delete the folder again and let it be created when I run the game it will only work all the time I don't save again. If I save again, the same thing happens. It took me hours of tries to figure out what was going on and honestly, I can't even tell what is the problem with it. I asked 3 programmers and they all think it is some clash with the save data or location. I was going to install the game on another computer to test it out there as well to completely rule out the hardware clash. Do let me know if it will help you cause for now I just gave up on crafting with the fabricator and am learning with the books and candle maker.

 

There are also 2 more things I noticed.
1.When I save during a project when I restart, sometimes the fabricators disappear or are not usable

2.When I save and relog, sometimes my burnt items from dumpster diving disappear from the housing inventory or (and that has happened only twice so far) they get fully restored.

Message 4 of 7 (1,197 Views)

Re: When I fail a fabrication I do not get bits and pieces back if I have any sa

★★★ Apprentice

I'm not sure if this helps, but I have had this issue with a newer save and I have all of the packs installed. Same thing also happens when I stop fabricating something halfway through, I can't resume fabricating and it doesn't refund me the dyes, or bits and pieces. It will still show the option to use those dyes but they no longer appear in my inventory and when I try to select a colored object to fabricate nothing happens, the sim acts as if I didn't give a command. 

Message 5 of 7 (1,108 Views)

Re: When I fail a fabrication I do not get bits and pieces back if I have any sa

★ Apprentice

I have the exact issue as silver doe! One year later and it's still there :^(

Message 6 of 7 (504 Views)

Re: When I fail a fabrication I do not get bits and pieces back if I have any sa

[ Edited ]
★★★★ Apprentice

Definitely still an issue.  Was having this happen every time on the save I've been playing so I removed all mods, made a new save to try it out on (along with trying another problem with the recycler where you get nothing back for some items that you can recycle & should get  bits & pieces back for) and then made a bunch of things at the fabricator.   When making an eco upgrade part it failed, and didn't refund the bits and pieces.     I tried voodoo dolls and and eventually failed one and it didn't return the bits and pieces with that fail either..

 

Was hoping it was mods causing the problem or maybe a bug with the save I've been playing but nope, it's happening on a brand new save with no mods at all too

 

Kind of a pricey bug if you are just getting started in fabricating and don't have many bits and pieces yet.    Even more of a nasty bug when trying to get more by dumpster diving only to find that there are a LOT of items you are allowed to recycle at the recycler that give nothing back to you (it just takes the item).     Whole lot of bugs in this Eco expansion that mess up important parts of it that would be neat if they weren't so buggy.

 

Message 7 of 7 (274 Views)