[OPEN] Assign bed not showing icon Picture

by LeiaMaria97
Reply

Original Post

[OPEN] Assign bed not showing icon Picture

[ Edited ]
★ Apprentice

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Occasionally (10% - 49%)
What is your current game version number? 1.96.365.1030
What expansions, game packs, and stuff packs do you have installed? all
Steps: How can we find the bug ourselves? I have no idea how
What happens when the bug occurs? Assigned bed Sim Icon is glitch out for no reason
What do you expect to see? To see Icon picture to who that is assigned
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. Newest update

Just seem visual glitch. just bottom beds not showing icon, I did figure out by replace the beds then reassign the bed to sim and it will show icon picture

 

Edit By Crinrict: Added Tag to Title

Screenshot 2023-03-16 203553.png

Message 1 of 12 (3,851 Views)

Re: Assign bed not showing icon Picture

★★ Guide

This is also happening for me (PS5). In fact, assigning beds in general is buggy for me at the moment, specifically single beds and lower bunk beds. The sims are autonomously napping on the couch instead of sleeping in their assigned bed, every time. Doesn’t seem to be a problem for double beds or top bunk beds.

Message 2 of 12 (3,382 Views)

Re: Assign bed not showing icon Picture

★★★ Novice

I'm having the same issue. All of my single beds and bottom bunk beds are unassigning themselves and I can't reassign them.

Message 3 of 12 (3,098 Views)

Re: Assign bed not showing icon Picture

[ Edited ]
★★ Guide

Same here. Seems like single bed ownership data got wiped with the last patch. 

Honestly, this game is on the struggle bus in a bad way when it comes to sims and their ownership of various items in general. The dots do not connect. At all. 

Instruments are affected by the "ownership" issue in my game, too. If a sim takes an instrument he/she owns out of his/her inventory and plays it, they won't return it to their inventory. They'll put it down on the ground instead, and you can't return it to their inventory ever again because they suddenly no longer own that item. The only solution is to keep replacing their belongings, over and over again.

I've had it happen with books, toys, coolers, jet skis, outrigger canoes, you name it. Basically anything a sim is supposed to own. . 

 

There's a major disconnect between sim IDs and object IDs as it relates to ownership that is, in many cases, completely game breaking. To say it's annoying and ridiculous would be an understatement. 

...but I digress. I will stop my rant here, because I could go on for literally DAYS. 

TLDR: 

The only thing that fixed the bed ownership issue in my game was to completely replace the beds. Resetting the object did not work. It allowed the bed assignment menu to load, but the action never registered in the sim's queue and therefore could not be completed.. 

Go into build mode, use the eye dropper to clone the bed, get rid of the original bed, and replace it with a new, identical copy. 

Once you do that, go back into live mode and you SHOULD be able to successfully assign the bed again. 

I just tested this in my game and it worked for me. Hopefully it will fix the problem for all of you, too. 

Happy Simming and hang in there. Standard smile 

Message 4 of 12 (2,820 Views)

Re: Assign bed not showing icon Picture

★★★ Guide

I don't think it's Assigned to anybody, hence why it is blank, because if you do auto-solve for low energy they instead go to the nearest sofa and nap instead because they don't own any bed, also if you full automony they will never sleep in that bed you think where the icon is just invisible.

 

I can fix those as stated above, like buying new ones, etc. but what's the point? they only return back to the assigned to <Blank> on the next load.

 

I can say it happens with all my lots, bunks and single beds, and it's seem it's only the kid's beds that are affected.

 

 

I definitely have no bed mods, cc beds, or any mod that alters your sleeping arrangements.

 

 

Message 5 of 12 (2,648 Views)

Re: Assign bed not showing icon Picture

★★ Guide
@Citysim9997 I agree, it’s quite annoying. I’m surprised there aren’t more comments about this.
Message 6 of 12 (2,518 Views)

Re: Assign bed not showing icon Picture

★★★ Guide

If you by getting chance your using the LittleMsSam's SendToBed mod, update it, i can't be too sure now, but after then I found all my beds were ok afterall..

Message 7 of 12 (2,444 Views)

Re: Assign bed not showing icon Picture

★ Guide

This happens occasionally to me too only for children/beds. Don't know why, but it's been like that way longer than just this patch unfortunately. I think more people don't mention it because there still assigned to the bed. It just doesn't show picture for me at least. I remember it doing that back as far as the werewolves patch. Did you try deleting the bed, and reassign or use diffrent bed?

Message 8 of 12 (2,424 Views)

Re: Assign bed not showing icon Picture

EA Sims Team

Hello All,

 

If anyone of you are still encountering this on the latest game version (without mods), would you be willing to share your save file(s)?

 

If so, please send me a private message with a link to the file.

Instructions here: http://x.ea.com/74420

 

 

Thanks!

Message 9 of 12 (2,226 Views)

Re: [OPEN] Assign bed not showing icon Picture

★★ Apprentice

Hmm, that's not happening to me. It's either the computer itself, or your Wi-Fi. I seem to only have those issues when I'm using a broken or slow or just a very old laptop, or if my wi-fi starts acting up. 

Message 10 of 12 (2,223 Views)