[FIXED] [ECO] Fizzing station gets stuck while fizzing

by Esmeria

Original Post

Accepted Solution

[FIXED] [ECO] Fizzing station gets stuck while fizzing

[ Edited ]
★★★ Apprentice

Product: The Sims 4
Which language are you playing the game in? Deutsch
How often does the bug occur? Often (50% - 99%)
What is your current game version number?
What expansions, game packs, and stuff packs do you have installed? all of them
Steps: How can we find the bug ourselves? Play eco lifestyle
What happens when the bug occurs? The juice fizzer gets stuck during the fizzing process. It says "not ready" and has a red light forever. Only when traveling and coming back to the lot does the fizzing eventually resume
What do you expect to see? I expect my juice to be fizzed in a timely manner
Have you installed any customization with the game, e.g. Custom Content or Mods? Never used.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. Since Patch and Eco Lifestyle

As I said above, the juice fizzer often gets stuck while fizzing. Leaving the lot will make it work again, but it is very inconvenient and should not be happening. Without travel the fizzing is stuck indefinetly. 


Edit By Crinrict: Adjusted Title, Added Tag to Title

Message 1 of 34 (7,304 Views)

Accepted Solution

Re: Fizzing Station Bug


The Juice Fizzer (juiceFizzer_EP09GEN_set1) will do what it's expected to do, fizz your juice and not get stuck on the fizzing part of the function.

Fixed in Patch 1.102.190/1.82

Please create a new thread if you're still experiencing this issue,


Good Luck


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

View in thread

Message 34 of 34 (2,484 Views)

All Replies

Re: [ECO] Fizzing station doesn't fizz

★ Guide

I am also having this problem, but travelling off the lot doesn't fix it.

I have to replace the machine entirely. I have fully upgraded the machine, but I don't know if this plays any part.

Message 2 of 34 (7,193 Views)

Re: [ECO] Fizzing station doesn't fizz

★★★★ Expert
@Esmeria I was able to "unstick" mine by having a different household member use it. But it's kindof a problem when there's only one household member.
Message 3 of 34 (7,165 Views)

Re: [ECO] Fizzing station doesn't fizz

★★★★★ Apprentice

Happening for me as well. Makes using the fizzing station super inconvenient.

Message 4 of 34 (7,115 Views)

Re: [ECO] Fizzing station doesn't fizz

★★ Apprentice

I also have this issue. However, leaving the lot and coming back doesn't fix the issue. I have to sell the fizzer and buy a new one. Which isn't good considering it happens to the new one after about 5-8 batches. This means upgrading would be a bad idea as it'd just be a waste of upgrade parts.

Message 5 of 34 (7,057 Views)

Re: [ECO] Fizzing station doesn't fizz

★★★★★ Apprentice
@aiichi382 Same here, leaving the lot doesn’t fix it for me either
Message 6 of 34 (6,908 Views)

Re: [ECO] Fizzing station doesn't fizz

★★★ Apprentice

Maybe you are not patient enough. When I return to my lot the juice fizzer still shows the red light and black screen, but after letting a few ingame hours pass (depending on how long was left before it got stuck, i expect), it is ready. This has worked for me so far everytime I tried it. 

Message 7 of 34 (6,877 Views)

Re: [ECO] Fizzing station doesn't fizz

★★★ Apprentice
@Psychotps That did not help for me, debugging it doesn't either. Only solution I found was leaving the lot or getting a new machine.
Message 8 of 34 (6,875 Views)

Re: [ECO] Fizzing station doesn't fizz

★★★★ Expert
@Esmeria It worked for me once. The next time it broke, it didn't. I let it sit broken overnight and by the next morning it was working again. I think the break eventually times out and ends up working after a long while.
Message 9 of 34 (6,779 Views)

Re: [NEEDS INPUT] [ECO] Fizzing station gets stuck while fizzing

★★★★ Novice

I'm having this issue as well; leaving the lot does seem to fix it for me.  Thanks for that time.  Annoying, but at least it's a work around till they can update.

Message 10 of 34 (6,565 Views)