Re: Unable to light fireworks at Humor and Hijinks Festival

by simvasion

Original Post

[FIXED] [CL] Unable to light fireworks

[ Edited ]

Product: The Sims 4
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number?
What expansions, game packs, and stuff packs do you have installed? All
Steps: How can we find the bug ourselves? Travel to the Humor and Hijinks Festival and either watch NPCs attempt to light fireworks or buy fireworks and attempt to light some for yourself.
What happens when the bug occurs? The sim attempting to light the fireworks will T-pose for a split second and reset. The firework remains unlit.
What do you expect to see? The sims should be able to light the fuse of the firework successfully.
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Yes
Please describe the patch or change you made. Since patch I believe.

Fortunately this doesn't seem to prevent completion of the "Light fireworks at the Humor and Hijinks Festival" phone call event NPCs can give you when the festival is in town. You're given credit for lighting a firework even though you T-pose.


The exception errors mention the Finchwick Fair and look something like this:



<report><version>2</version><sessionid>eb60aaccbdd9288c610ff291</sessionid><type>desync</type><sku>ea.maxis.sims4_64.15.pc</sku><createtime>2021-08-08 20:56:24</createtime><buildsignature>Local.Unknown.Unknown.</buildsignature><categoryid></categoryid><desyncid>eb60aaccbdd9288c610ff291</desyncid><systemconfig/><screenshot/><desyncdata>Exception in Sim Timeline: Exception running Element (AttributeError: 'festivalContestSubDramaNode_VillageFair_Wool' object has no attribute 'is_on_festival_street')&#13;&#10;Traceback (most recent call last):&#13;&#10; File "T:\InGame\Gameplay\Scripts\Core\", line 294, in wrapper&#13;&#10;KeyError: (FestivalRunningTest(check_if_on_festival_street=True, drama_node=None, festivals_to_check=None, negate=True, tooltip=None, valid_time_blocks=ImmutableSlots({'pre_festival': True, 'running': True})), frozenset())&#13;&#10;&#13;&#10;During handling of the above exception, another exception occurred:&#13;&#10;&#13;&#10;Traceback (most recent call last):&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\", line 212, in simulate&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\", line 335, in _run&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 173, in _behavior_element&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 51, in _do_behavior&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 133, in apply_operations&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 521, in apply_to_resolver&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 518, in apply_to_resolver&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 272, in apply_to_resolver&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\interactions\utils\", line 191, in test_resolver&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\event_testing\", line 499, in run_tests&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\event_testing\", line 129, in __call__&#13;&#10; File "T:\InGame\Gameplay\Scripts\Core\", line 296, in wrapper&#13;&#10; File "T:\InGame\Gameplay\Scripts\Server\drama_scheduler\", line 124, in __call__AttributeError: 'festivalContestSubDramaNode_VillageFair_Wool' object has no attribute 'is_on_festival_street'rtim=0&#13;&#10;Client Session Time: 28.97&#13; &#10;Num Save Errors: 0&#13; &#10;Num Load Errors: 0&#13; &#10;Current Game State: 0x96d01090&#13; &#10;Origin Version: 10,5,102,48654&#13; &#10;Modded: True&#13; &#10;SystemInfo: Windows 10 10.0.19043 GPU: NVIDIA GeForce GTX 970 nvldumdx.dll, GUID: D7B71E3E-5082-11CF-2160-75161BC2D635&#13; &#10;</desyncdata></report>

EDIT: I've also tested this with fireworks my sim purchased on the computer and tried lighting at home in their yard. Same failure to complete the action


Edit By Crinrict: Added Tag to Title, Adjusted Title 

Message 1 of 88 (27,193 Views)

Re: Unable to light fireworks at Humor and Hijinks Festival

★★ Apprentice

I have the same problem but in my house lot


Message 2 of 88 (27,163 Views)

Re: Unable to light fireworks at Humor and Hijinks Festival


I think I figured out what the issue is from the exception files, and I've uploaded a mod to fix this on my site. If anyone on PC/Mac who is OK with using mods wants to check it out, you can find a link to my website in the Hero approved mods thread.

Message 3 of 88 (27,116 Views)


★★★ Novice

I’m trying to burn my house down and when I try light my fireworks they would place it down then walk up to up then glitch out and then t-pose for a spilt second then they would just stand still I’ve tried to do it outside and the same thing happened is this just happening for me?

Message 4 of 88 (26,925 Views)

Re: Fireworks

Champion (Retired)



Yes there is currently a bug with lighting Firework. Any way it will not burn down your house. In fact nothing will.

Please only PM me when asked to do so. Questions and answers belong here so everyone can benefit from them.
Message 5 of 88 (26,900 Views)

Re: [OPEN] [CL] Unable to light fireworks

★★★★★ Guide

I noticed this too, I thought that it was my mods first but I have no mods that changes the fireworks so it seems indeed like this is a bug.

Message 6 of 88 (26,919 Views)

Re: Fireworks

★★★ Novice

@jpkarlsen wrote:



Yes there is currently a bug with lighting Firework. Any way it will not burn down your house. In fact nothing will.

Ok thank you very much.

Message 7 of 88 (26,898 Views)

Re: Fireworks

@Williamg312 I merged your thread with the bug report.

Please click me too on the first post.

Good Luck


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.

Important Threads

Message 8 of 88 (26,870 Views)

Re: [OPEN] [CL] Unable to light fireworks

★ Expert

This sounds like it might be the same root cause as the rocket bug? The sub activities at the Cottage Living fairs are missing this festival street attribute, so if you have the pack and try to do an activity that checks to see whether or not you’re performing that activity at a festival, it’s getting stuck when looping through possible locations. The rocket checks if you’re at the geek festival so you can pay or not, and isn’t there some specific purpose for the fireworks at the hijinks festival?


It’s the same LE anyway. Are there any other festival related activities we could check - things that perform differently depending on where they are, or have additional significance?

Message 9 of 88 (26,737 Views)

Re: [OPEN] [CL] Unable to light fireworks


I've got this on console too since adding cottage living and the accompanying base game updates. Exactly as described here. I created a new calendar event for a fireworks night and tried to light them at the spice festival and at the festival of light, no joy, damp squib.

I don't work for EA. I'm a Volunteer.
Message 10 of 88 (26,644 Views)