[Possible solutions/INFO REQUEST] NP Pool Memoryleak [PC only] updated: Apr. 13

by Carbonic

Original Post

Accepted Solution

[Possible solutions/INFO REQUEST] NP Pool Memoryleak [PC only] updated: Apr. 13

[ Edited ]

The infamous "NP Pool Memoryleak" problem.

I've decided to gather information about it so it can hopefully get some attention.

  • Click the "Me too" button if you have this problem.
  • Write here if you have information to contribute.

Posts about other problems and other non-helpfull posts will be removed at my discretion.

Also, please note I do not work for EA so no need to complain about things, this is a constructive thread.



  • Non paged pool (NPP) memory gets filled up with garbage. Normally it's only filled up with around 200-300mb of data but after the memory leak happens it takes of the remainding memory causing BF4 and the system to grind to a hault. Due to the nature of NPP this garbage cannot be removed from occupying space in the memory until you reboot the system.
  • BF4.exe is not using more memory than normal, not the private working set or the paged pool
  • Example: Ive got 8GB of memory, during play 250MB of NPP memory is used, then the memory leak happens and suddenly 5.2GB of my memory is lost and being used for nothing due to this bug.

When does it happen:

  • The memory leak happens after mapchange, but otherwise somewhat random. The main trend is that mapchange causes the memoryleak and it then takes some time to fill up the memory depending on the speed and amount of memory.

Systems affected:

  • Win 8 (mostly 8.1)
  • Radeon HD 5xxx, HD6xxx, HD7xxx and R series
  • Very few Nvidia has said it affected them as well but is deemed unlikely as none would provide a screenshot showing it's the non paged pool

Things people have mentioned helped:

  • Running BF4 in Win7 compability (not working for the majority and causing other problems)
  • Exiting the game before mapchange (working, but not a solution)
  • Alt+tab during load of new map (not working)
  • Running Catalyst Control Center(CCC) in Win7 compability (not working for the majority )
  • Using the standard default windows 8.1 driver or Cataclyst 13.9 with all the other errors etc. that follows (not working for the majority )
  • Updating Realtek network driver from Realtek's website as the win8 standard driver could cause this (reported to solve similar problem)
  • Disabling NDU using: "sc config NDU start= disabled" in a commandprompt (reported to solve similar problem)

Possible causes:

  • The game just don't like those graphics cards even though it has the AMD logo on it. (most likely)
  • Some use of DirectX 11.1 in Win8
  • NDU memory leak with certain network adapters in Win8
  • Built-in Win8 network adapter driver for some Realtek network cards
  • AMD driver issue
  • Poolmon indicated the culprit wears the MINI tag associated with atikmdag.sys which is a part of the AMD driver package


Can be identified using:

(when the problem is occouring)

Look at the taskmanager memory usage and notice a huge chunk of memory being used but not by any program




To check that it is the non paged pool area of your memory being filled.

This is a picture of how it could look normally. During the bug you will see Nonpaged Pool take up 4 000 000+ K of your memory



Windows 8 taskmanager detail view

Detail-->right click column-->select columns-->enable NP pool.

Then check that it's not BF4.exe that takes up the NP pool.


Update 19

New driver out that might fix the issue: http://support.amd.com/en-us/kb-articles/Pages/latest-catalyst-windows-beta.aspx?hootPostID=b3a8c349...



Update 18

There's hope:

"Windows 8.1 memory leak (AMD) - AMD has found the issue & fixed, and I'll let you guys know as soon as their beta driver is updated!"

link: https://twitter.com/tiggr_/status/555825926190415872


Update 17:

The new about the problem is that there's nothing to report about the problem. Sorry to dissapoint, if I could catch the programmers at AMD and DICE  + their bosses and put them in a room and have an uncomftable staring contest until someone explains to me how an AMD Gaming Evolved title can have such an issue for more than a year I would (with lots of cake in the room ofc. as I do have a lot of respect of programmers and they tend to like cake).


As we have a new year and I'm getting tired of poking poor EA people who is not rightfully to blame for the error I will now let it be up to DICE/EA/AMD to contact me if they want to give feedback on this topic.


Update 16:

After some time in the wombeta, today it is 1 year ago the game came out and thus 1 year since the this bug appeared in the released game, happy birthday memoryleak!



Update 15:

Personal note: my old graphics card burned out so had to get a new and thus don't have this problem anymore. If there's a patch and the problem still persists or similar, then please send me a private message in here and I will update this thread.



Update 14:
June 3. patch and 14.6 beta both fixed nothing related to the memoryleak.


Update 13:

Remember to join and give feedback about this problem on the CTE forum. Read more on how here:



Update 12:

31. March - Naval Strike is out. With new game patch.

If you have this problem after this patch please write it here and add the following like this:

  • I have tested with RamMap that my non-paged pool iks being filled: Yes
  • It have happened after Naval Strike: Yes
  • CPU: AMD Phenom II X4 955 Black 3.2GHz
  • GPU: Club 3D Radeon PCI-E HD6870 OC 1GB DDR5
  • Motherboard: Gigabyte GA-MA790GPT-UD3H 790GX CFireX
  • RAM: Mushkin DDR3 PC3-1333 4GB CL9 kit Stiletto x 2
  • Soundcard: Creative Recon3d PCI-E soundcard - onboard card disabled in bios
  • GPU Driver: Catalyst 14.3 beta

Colorscheme not required Wink


Update 11:

18. March - New AMD driver did nothing. Problem still persists. Nothing else to report except it's sad.


Update 10:

6. March Patch brought back the Non Paged Pool Memory Leak for me and some others. It had been gone (for some) since between patches a while (for some odd reason). I have no idea what Dice is doing..


Update 9:

The new patch feb. 13th has done nothing to help the problem, patch. 14.1 also nothing. Have also heard nothing about the problem.

Place to report the error with AMD:

Driver feedback form: http://www.amdsurveys.com/se.ashx?s=5A1E27D25AD12B21

Raise Ticket : http://support.amd.com/en-us/kb-articles/Pages/ticketprocess.aspx


Update 8:
A new patch is out. (30. January). Problem still persists = it's not fixed.

Since AMD thinks each game patch fixes their driver problem report the problem here: http://www.amdsurveys.com/se.ashx?s=5A1E27D25AD12B4F - you can also raise a ticket with AMD at http://support.amd.com/en-us/kb-articles/Pages/ticketprocess.aspx

Since EA has not acknowledged the error on their top issues post on Battlelog, you could also request so on Battlelog and to your friendly neighborhood EA Advisor.


Update 7:
A new patch is out that might fix this problem allthough the patchnotes are a bit unclear, so please report if you still get the problem after the patch


Update 6:
Now use http://www.amdsurveys.com/se.ashx?s=5A1E27D25AD12B4F to report that this current driver update does not fix the problem as well. How fast AMD fixes things directly corresponds to how many reports and complaints they get according to their "technical support".


Update 5:
AMD technical support responded to a ticket I made a while ago.

This was their response:

  • Thanks for your mail. Yes, our driver team had already received some reports related to this issue before, and after some investigates, they thought that this issue seems to have been resolved, possibly via a patch released by DICE. And they didn’t receive much reports related to this issues recently. So please try to find some game patches form EA to solve your issue, thank you.

So, apparently they think the error has magicly solved itself because we don't complain enough. So I would urge all in here with the problem to go to: http://emailcustomercare.amd.com/ and http://www.amdsurveys.com/se.ashx?s=5A1E27D25AD12B4F and fill out a support request with all your relevant information. You can also write them at https://twitter.com/AMDRadeonhttps://twitter.com/AMDGaminghttps://www.facebook.com/AMDGaming and the other places AMD hangs out.


Update 4:
Ok, so I'm in contact with someone at AMD, if people could add what browser (name and version) they are using that would be great.

  • Myself: Chrome 31.0.1650.63 m

Update 3:
AMD posted on their forum that: "Just a short update. We continue to work closely with DICE to find a solution to this problem."

Update 2:
seems like this is not a top issue for Dice

Update 1
 I've just been informed that Dice has been told about the issue. Now only AMD left.

  • Source: AnswersHQ moderator

carbonic signature

Message 1 of 477 (53,359 Views)

Accepted Solution

Re: [Possible solutions/INFO REQUEST] NP Pool Memoryleak [PC only] updated: Apr.


As this issue seems to have been resolved with new drivers I'll mark this thread as solved now.

carbonic signature

View in thread

Message 477 of 477 (11,126 Views)

All Replies

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

[ Edited ]
★★★ Apprentice

Here is some info from a thread I posted earlier:


I am getting beyond frustrated at this point. Its been a month and neither AMD or DICE will acknowledge the major issue that a large number of users are experiencing. For those unaware here is the rundown on the issue:


- After playing for a while the game will start stuttering/looping in short intervals making it unplayable. For me it was most likely to happen shortly after a map change and some maps seemed worse than others, (i.e. Rogue Transmission). Others have reported that it seems to happen when there is lots of destruction on a map. If you exit the game (which takes a long time due to the freezing) and then check your memory usage in Windows it will be at 90%+ but with no process showing that its using that memory. Further investigation will show that its in the "Non-paged Pool" of memory. More detailed info here: http://forums.guru3d.com/showthread.php?p=4689663


- The common factors for this issue appear to be people with Windows 8.1 and an AMD 5xxx, 6xxx or 7xxx series video card (not 100% sure on the 7xxx series but the other 2 for sure). So far for me the workaround has been to set the game to run in Windows 7 Compatibility mode. The main change here being that Windows 7 only uses DirectX 11 and Windows 8.1 will use DirectX 11.1. This is likely why Windows 7 users do not experience this issue


NOTE: For those who have the same issue but without the common factors above try this thread: http://www.reddit.com/r/battlefield_4/comments/1r7hd6/windows_8_bf4_memory_leak_the_cause_and_the_fi...


I have issued a bug report to AMD as well but neither side (DICE or AMD) have mentioned even a single word regarding this issue. Keep in mind that just because an AMD driver is affected it does not mean that their driver is the issue and in either case this game was co-marketed between these 2 companies so you'd think both sides would be willing to coordinate and find a fix as fast as possible. It has now been a month with this issue (only recently found the workaround for Windows 7 mode) and I'm just about at my wits end. More so regarding the complete lack of communication/acknowledgement from either DICE/AMD.


On top of that I would be more than willing to do any diagnostics/logging, etc. requested by DICE/AMD to resolve this.


EDIT: I have a second monitor on its way. I'm hoping that using that I can have Task Manager open in another window and try to monitor what/when it happens

Message 2 of 477 (52,881 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

[ Edited ]
★★ Apprentice

I wanted to add this valid piece of info to the thread.  Just prior to the release of BF4 (about a month) I was having the exact same issues in BF3.  Mind you, the EXACT same behavior (memory totally pegged out, NP Pool referenced as the contributor to RAM usage, game stutters, frame rates drop, game will eventually crash).  I could watch (using Task Manager) when maps would load (in between rounds) whether or not the bug was going to effect my next round of play.  This has carried over to BF4, where I experience very similar issues.  The only difference I've noticed is the memory leak in BF4 will happen in the middle of game play.  I have yet to visually watch the leak occur when the map changes as I could in BF3.  Another difference I noticed is I could get in a few rounds of BF3 after the leak had begun.  My memory would slowly fill up after a few rounds until all of my RAM was in use.  In BF4 it seems to happen all at once durring a single round for me.  The only way to free the memory up is to reboot the system entirely (as you have already pointed out).


I have found some relief recently by running the BF4 x86 client in Win 7 compatibility mode.  Though my play sessions haven't stretched beyond 1.5 hours of consecutive play.


My onboard NIC, which I don't make use of, is Intel.  I use a Cisco usb wireless dongle for network connectivity.  There aren't any drivers available from Intel for Windows 8.1, or 8 for that matter.  So the report of Realtek NIC drivers being the underlying cause doesn't apply to me.


I hope my insight is helpful in some way.


My config is:

i7 920

128 Curcial M4


Radeon HD 6870 - Beta 13.11 drivers

Win 8.1 x64

Message 3 of 477 (52,830 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

★ Novice

I have this issue exactly as described in the OP and would really like to see it acknowledged and fixed.  My specs:


Intel i7 4770

Asus Z87-Pro board


AMD 6950 2GB card

W8.1 Pro 64 bit

Message 4 of 477 (52,796 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

★★★★★ Novice

I can also confirm that the problem still persits after upgrading to the latest AMD drivers: 13.11_betav9.5 (12/3/2013).


But alt+tab usually works for me, much better with China Rising but yeah, also memory leaks there.

Running AMD HD6850.



Message 5 of 477 (52,746 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

★★★★ Novice

I have been frequently suffering from this issue. Sometimes I can play no more than a map or two following a full restart without encountering it. 

Won't be a problem much longer as I have a new non-AMD card on the way. Tired of waiting for a fix. That said, I used Poolmon.exe to find the tag for the item that was taking up all of the space in my NP virtual memory. The culprit was the MINI tag which traces back to atikmdag.sys file, which is a file associated with the AMD driver package. This corroborates what another user found here using the same tools: http://forums.guru3d.com/showthread.php?p=4689663


My specs are as follows: 


AMD Phenom II X6 1090T 3.20 Ghz CPU


Windows 8.1 64

Radeon 5770 CPU (for a couple more days)

1 TB available HDD Space

Windows Managed Virtual Memory (still occurs even if I set VM to a fixed size)


Also, I just for the second time today had this occur within a map and a half of play after a fresh reboot. Not sure if it is related to the maps specifically, the server (was same server both times), or number of players on the server. I typically play on 30-32 player servers but both instances today were on a 64 player server (full), and in both cases the first map was Gullen Peaks followed by Silk Road. 

Message 6 of 477 (52,721 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

★★★★ Novice

Just happened again to me for the third time today. Again after a fresh reboot, was able to finish the round of Obliteration on Operation Locker that was in progress when I joined, got all the way through a round of Siege of Shanghai, but then about 10 minutes into Lancing Dam I started experiencing the tell tale signs that the leak was back.


I opened up Task Manager and my Non-paged pool was at 5.3 GB. Hard Disk usage was at 100% as Windows was pounding my virtual memory. I managed to get BF4 to exit (took a long time as my PC was mostly unresponsive at this point) and was able to run PoolMon.exe again. Again the culprit is the MINI tag with 5,501.351.840 Bytes allocated (non paging).


As I type this, task manager shows 7.6 GB "In Use" with only Origin and Google Chrome running 

Message 7 of 477 (52,694 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

★★★ Novice

I'm also experiencing this. It's extremely annoying.


PC spec is:


i5 2500k

P8P67 Pro motherboard


Asus 5850 with latest 13.11 beta 9.5 drivers.

Windows 8.1


There doesn't seem to be any pattern to when it occurs, only that after I play a few maps, RAM fills up and it starts swapping to disk like crazy. 

Message 8 of 477 (52,652 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only]

★★★★★ Novice

I haven't been playing because of this issue, I look to my left at my original Battlefield box and am really quite frustrated at the lack of acknowledgement from anyone that this is a problem.


I am on Windows 8.1

All drivers are up-to-date

I have an i7 with 8Gb of ram


If I am lucky I can play two maps, most of the time I barely get through one map - my disconnect profile says it all.


How can an expansion be released for a game that doesn't work properly?

Message 9 of 477 (52,589 Views)

Re: [INFO REQUEST] NP Pool Memoryleak [PC only] (updated Dec. 5)


I've been told the issue was escalated to Dice some time ago. Updated the main post to reflect additional info added as well.

carbonic signature

Message 10 of 477 (52,537 Views)