Help us improve Answers HQ! Take Survey No, Thanks

Who Me Too'd this topic

Poor graphics/low-resolution/graphics glitches (TS3 64-bit)
[ Edited ]

This is a collection thread for questions and complaints about poor graphics performance and related glitches in the 64-bit version of Sims 3 for macOS.

 

Please make sure your Mac can properly cool itself.

 

Your graphics card or chip may be overheating and thermal throttling, thereby reducing in-game performance.  To help a laptop cool down, elevate it while you play, use a cooling pad, or even point a fan at it.  Or shut down the computer for a bit and come back later.

 

If you are experiencing graphics glitches, please try the following, in order:

 

  • Reduce your in-game resolution to 1920x1080 or lower
  • Try both fullscreen and windowed modes
  • In graphics settings, turn down high-detail lots to 2, and waters to "mirrors only, or lower; be sure to restart before loading a save
  • Delete options.ini from Documents > Electronic Arts > The Sims 3 (the game will spawn a new one with default settings)

If anything helps you, please post letting us know what you did and what improvements you saw.

 

If none of this helps, please provide more information about your game and Mac:

 

  • The full specs of your Mac, including operating system
  • Your in-game graphics settings
  • The first 40 lines of deviceconfig.log, found in Documents > Electronic Arts > The Sims 3

If you aren't sure what this information entails or how to get it, please follow these instructions:

 

 

Spoiler

To take a screenshot

Click cmd-shift-4 and drag your cursor over the section of screen you want to capture.  The screenshot will land on your desktop, and you can embed it within or attach it to a post.

 

To see the specs of your Mac, click the Apple icon in the upper left corner of your screen, select About This Mac, and take a screenshot of the window.  Crop out or black out your serial number.

 

specs.png

 

When in-game, click cmd-enter to switch to windowed mode.  Click the three dots in the lower left corner of the game window, select Options, and take a screenshot of the settings in the first tab:

 

graphics settings.png

 

In Documents > Electronic Arts > The Sims 3, open deviceconfig.log and copy the first 40 lines, up to where "Options" starts, and paste them into a reply (please use a spoiler), or attach the file to your post.  Your user and computer names are about 25 lines down, so feel free to delete those, but please leave the other information intact.

 

=== Application info ===
Name: Sims3
Version:
Build: Release
=== Rating info ===
GPU: 5 GPU Memory: 5 CPU: 5 RAM: 5 CPU Speed: 2900 Threading: 3
Adjusted CPU: 4930 RAM: 16384 Adjusted RAM: 15872 Cores: 4
Card Found in DB: 1
=== Machine info ===
OS version: Mac OS X Version 10.14.6 (Build 18G103)
OS prod type: 0
OS major ver: 10
OS minor ver: 14
OS SP major ver: 0
OS SP minor ver: 0
OS is 64Bit: 1
CPU: MacBookPro14,3
Brand: Intel(R) Core(TM) i7-7820HQ CPU @ 2.90GHz
Family: 8
Model: 7
Cores: 4
HT: 1
x64: 1
Memory: 16384MB
Free memory: 3470MB
User: X
Computer: X
=== Graphics device info ===
Number: 0
Name (driver): Radeon Pro 560
Name (database): Radeon Pro 560 [Found: 1, Matched: 1]
Vendor: ATI
Chipset: Vendor: 1002, Device: 67ef, Board: 00000179, Chipset: 00c0
Driver: macOS Metal driver, Version: 0.0.0.0
Driver version: 0
Monitor: 00000000
Texture memory: 4096MB
Vertex program: 3.0
Pixel program: 3.0
Hardware TnL: 0
=== Options ===

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
(1,658 Views)
Who Me Too'd this topic