Help us improve Answers HQ! Take Survey No, Thanks

Who Me Too'd this topic

[NEEDS SAVES] [SV] Strangerville Scanner constantly low
[ Edited ]
★★★★ Novice

Product: The Sims 4
Platform:PC
Which language are you playing the game in? English
How often does the bug occur? Every time (100%)
What is your current game version number? 1.64.84.1020
What expansions, game packs, and stuff packs do you have installed? Expansions: All Game Packs: All Stuff Packs: Kitchen Stuff, Kids Room Stuff, Moschino Stuff, Movie Hangout Stuff, My First Pet Stuff, Perfect Patio Stuff, Spooky Stuff, Vintage Glamour Stuff,
Steps: How can we find the bug ourselves? Play through the Strangerville Mystery. Receive an Infection Scanner by ANY means. Attempt to use infection scanner.
What happens when the bug occurs? Click the ground. Infection scanner (unused) will not allow you to scan, claiming battery is low. Option is greyed out.
What do you expect to see? I click the ground and see an option to scan the area for spores.
Have you installed any customization with the game, e.g. Custom Content or Mods? Not now. I've removed them.
Did this issue appear after a specific patch or change you made to your system? Neutral/Not Sure 

https://answers.ea.com/t5/General-Discussion-Feedback/Strangerville-scanner-constantly-low/td-p/9263...

Copy pasting info from the original thread to show steps I took: 

 

Trying to play Strangerville. I've played it before on a different save file, back when the GP came out. 

 

Playing on my legacy game, haven't had any issues. When my sim gets a scanner, he immediately tried to use it but it didn't really do anything. I try and send him down to get spores at the lab, and I get "Cannot use Infection Scanner as its battery is low, please give it time to charge". Ok. So I forgot about it. Today I went back to try again, and again, infection scanner battery is low. I haven't used it. There's absolutely no way it's low. I tried debugging the scanner, getting a new scanner from a sim, getting new scanners from debug, everything. The last one, I tried both before and after removing all mods and CC, removing localthumbcache.package (and another one very similarly named to see if that one was the issue), and repairing the game multiple times. 

I *did* have issues regarding other aspiration goals not working previously, but they were all for non-strangerville related packs and appear to be ongoing issues that have not yet been completely resolved. 

 

I'm playing on: 
Samsung PC

Processor - AMD Ryzen 5 2500U w/ Radeon Vega Mobile Gfx 2.00 GHz
Installed RAM - 8.00 GB (6.95 usable)
System type - 64-bit operating system, x64-based processer

 

Second fix attempt: 

Ok, so. I did the above (saving as The Sims 4.old, repairing game, making a new save), and it didn't work. I JUST got the infection scanner, went to the lab, it won't let me scan and says it's low battery. 

I may do this all again and try it without the Sim being in the military, to see if maybe that is triggering a glitch for some reason (last Sim I had do the Mystery, when the GP first came out, they weren't Military). But if that doesn't work then I'm not sure what to do. I may check debug to see if there are spores just so I can do the challenge. 

Third fix attempt:

Ok, final update:

 

I made a new save and played a Sim who wasn't military. Got the infection scanner, went to the lab, scanner doesn't work. 

 

I sent him home, input testingCheats true and then bb.showhiddenobjects, went into buy mode, and you can search "spore cluster". I bought a few and the DO fulfill the aspiration requirement, so I guess I'm going to just do that in my Legacy game. (You have to specifically click on the spore cluster you have placed and click "put in inventory" for it to work. Dragging to sim's inventory will not register for the aspiration)

 So I'll just do that. I'm not sure if Eco Living update is interfering with the StrangerVille Mystery or what's going on, but it looks like this is the only way around the glitch right now. 

 

Other notes:
It was suggested to try going to the Library and asking Scientists about spores (this was a fix for the GameChanger helping me). This did not work. Another player said for them, they just had to wait a couple in-game hours and they would get the option for the scanner to work. This did not work for me. However, after initially attempting to fight The Mother, I did get the option to scan ONCE. Later I saw it again - I believe this was after I completed the mystery.

 

Edit By Crinrict: Added Tag to Title, Adjusted some formatting for readablitly

(4,454 Views)
Who Me Too'd this topic