Help us improve Answers HQ! Take Survey No, Thanks

Who Me Too'd this topic

Households not able to be played
★ Novice

I'm at a loss of what to do.

 

After the most recent update, my Sims 4 game has been glitching out badly. When I hover over a house, the residents aren't visible and it flashes blue where they should be (see image below). If I click the house and then the play button, nothing happens. It makes the noise and the button pulses but it just stays on the world screen. When I go to the manage households, the loading circle shows but then it's just blank slots that I can't do anything with.

 

I've done a bunch of searches and tried everything.

I've tried

- repairing the game from origin

- checking for any more updates that I may have missed

- tried it with CC and mods and without (deleting all of it)

- turned off mods altogether

I've even reset my laptop and had to re-download everything in hopes that it would help but I'm getting nowhere.

 

This has been going on for about two days and I had zero issues until the most recent update so any help would be appreciated.

(189 Views)
Who Me Too'd this topic