Help us improve Answers HQ! Take Survey No, Thanks

Re: UnravelTwo crashes after first cutscene

by icedieler

Original Post


Re: UnravelTwo crashes after first cutscene

★★★★ Novice

it doesn't seem to be just a phenom II problem. might be an amd problem in general. i have an amd a10 7850k and the game crashes to the desktop even before arriving at a cutscene. black screen whileloading and suddenly i'm back at the desktop.


which somehow speaks against your "minimum requirements" since the 7850k is on par with the fx 4350, including support for sse4.x.

Message 11 of 12 (619 Views)

Re: UnravelTwo crashes after first cutscene

[ Edited ]
★★★★ Novice

Hey guys, I was able to find a workaround fix for this, for those of us with the AMD Phenom II/SSE 4.2 Issue.  Despite what some have said, your hardware is most likely more than good enough to play this game!  Here's the workaround and how it came to be:



I figured since Valentine's Day is coming up, there isn't a much sweeter game to couch co-op on than a game like Unravel.  When we first found out about it last fall, it was like a little yarn fist clenching a stone punched me in the gut when the game failed to load fully.  We were about to give up our hope of playing, when I remembered a similar issue when we tried to play 'Little Nightmares" a few months prior. While I  found the LN solution at the time, it was too late to try and we pretty much forgot about it, so this was still new territory.
I got the idea to see if, just maybe, it might work here on Unravel 2.  I was expecting failure, but lo and behold, we were playing! 
It might look like a lot of hoop-jumping at first, but once you do it, you'll find it's very simple. (You can even make a batch file if you're feeling adventurous).



To get this working, you'll need to use Intel's SSE4.2 Instruction set, which you can get directly from Intel (below). (Even though you have an AMD chip, it will still run.  It can be summed up as an SSE4.2 emulator.)
1) Download the newest version for Windows here:
(some people report AV complaining about this, but ours didn't have an issue. Either way, it's from Intel direct)  (around 17.5MB)
2) Create a folder in your C drive.
    Name it something short so it's easy to navigate to in the command prompt in the next step.  I'll use "UV2fix" as my example folder.
3) Unzip the file you just downloaded ("sde-external-8.16.0-2018-01-30-win.tar.bz2") to the folder you just created. 
    (It might look unfamiliar, but WinRAR will recognize that extension)
4) Open up your command prompt with administrator privileges (via right click context menu on cmd.exe shortcut)
5) In your command prompt console, navigate to the folder you just created:
    Enter "cd C:\UV2fix(no quotes, of course)
6) Do not close your command prompt console window, navigate back to your desktop and start Unravel 2
    Wait for the start screen. (alt+tab)
7) Go back to your command prompt window(alt+tab)
8) Enter "tasklist" (no quotes). Look for your 'Unravel2.exe' and make note of it's PID (the number right next to it, which will be different every time)
9) Enter "sde -attach-pid ####"  
 (replace ####'s with the number that you made note of in the previous step) (no quotes). If you entered it correctly, you won't get a message and it  might look like nothing happened. *Leave this window open.*
10) Go back to Unravel 2.  
You will probably experience some temporary loading lag either during the title screen or intro, so don't panic!).  Once you get to the gameplay it clears up where it is fully playable.  We were able to enjoy the entire game without issue other than the initial hiccup and maybe a minor hiccup near another load scene (It's been awhile since we played, I can't remember for sure). 
As far as we know, there is still no fix for this issue on Unravel 2 or Little Nightmares.  This isn't a matter of the CPU or GPU not being able to handle the game itself!  Even with this SSE4.2 stuff having to be emulated, the gameplay itself performed as flawless as Unravel 1 did on this machine. You'd think these studios could patch this without a whole lot of effort.
Credit goes to Steam user Jezze for posting the original workaround for Little Nightmares, which they themselves adapted from Steam user Disky's Resident Evil 7 workaround

Let me know if you've had any success or issues. Enjoy the game!



(Edit: Thank you to whoever approved this and let the post go through)

Message 12 of 12 (184 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help