Help us improve Answers HQ! Take Survey No, Thanks

[Guide] Game failing to launch on Clicking Play

by proxos666
Reply

Original Post

Highlighted

[Guide] Game failing to launch on Clicking Play

[ Edited ]

So you have pressed play and the game isn't starting correctly. Here are some common symptoms and solutions:

 

  • Game appears in taskbar, or appears as a sliver on screen, or alters windows resolution

First thing to try is simply pressing ALT + Enter keys (twice can be needed) , if this brings the game back, go into preferences and set the resolution settings again. 

 

  • Game flashes black screen and closes

Press the [Windows] Key + [R] at the same time 

Copy the following in to the text box and press ok 

%localappdata%\swtor\swtor\settings

Open the client_settings.ini file in notepad and ensure the following are displayed within 

Fullscreen = false
D3DFullScreen = false
RefreshRate = 60

Check NativeHeight, NativeWidth, Height and Width ( all 4 ) match your monitor resolution.

Save and close the file.
Start the game as normal.
Change graphic settings within the game as desired.

 

  • If it is file related then a repair will usually sort it, details to repair are
Non-Streaming launcher - Log into the launcher but don't click Play. Check for small letters "ST" in the bottom left corner.
If this is NOT present, With the new launcher after login , select the username pulldown on the top right and select settings, then press repair.
Streaming launcher (Default) - If the letters "ST" is present, close the launcher, right mouse click on the game shortcut,
select open file location and delete the BitRaider folder. Then start the launcher

  • Screen is displaying a solid color before or at the character select screen

                  Go to C:\Program Files (x86)\Electronic Arts\BioWare\Star Wars-The Old Republic\swtor  and delete just the file called discachearena then start the launcher and login.

 

 

  • Recently Upgraded or Installed Windows and never played before on this computer
Install this particular Direct X Redist and ensure the video drivers are up to date.
 
  • If the above doesn't help
If that doesn't help you can try a Clean Boot
If that works re-enable one thing at a time to find the conflict. 
(If using the Streaming Launcher (Bitraider) you will need to leave the Bitraider Stub Loader Service running on the clean boot or the launcher will stop at 100% and not allow play to be pressed ).
Next, you will of course want to remove and re-add both launcher.exe and swtor.exe to the AV and Firewall exception lists as sometimes after a patch the exceptions fail due to the file change. So be sure the AV hasn't also quarantined swtor.exe
 
  • Some Launcher login Issues or No Server List
ESET - disable "protocol filtering"
Kaperskey - disable "scan secure/encrypted connections"
Norton (Firewall) - set exceptions to "Allow" not "Auto"

____________________________________________________________


SWTOR Forum Username = OwenBrooks
Australian (Fellow SWTOR Player) volunteer moderator. I do not work for EA.
Photo of my New Speeder Use My Referral Link Here, more details here
More information about: Becoming a Champion 

Message 1 of 1 (74,082 Views)
promo

Connection Troubleshooting

Issues with connecting to the game or the launcher? Getting lag spikes, high latency, or disconnections?

Check troubleshooting!

Maintaining Account Security

Keeping your account security up to date is very important if you want to keep your characters, items, and personal information safe!

View More
promo

Attach & Remove Security Key

Lost your Security Key? Got a new phone and need to set up a new Security Key? Check out this guide for detailed instructions!

View More