Help us improve Answers HQ! Take Survey No, Thanks

Sims 3 doesn't run properly on my GeForce GTX 970 video card

by Kireto1991
Reply

Original Post

Sims 3 doesn't run properly on my GeForce GTX 970 video card

[ Edited ]
★★★★ Newbie

Hello!

 

The Sims 3 doesn't run properly on my new high end gaming PC. The game runs very laggy.

 

Before I decided to post this thread, I tried several popular solutions, but they didn't solve the issue completely.

 

First and foremost here is my DxDiag report:

 

https://www.dropbox.com/s/seoqgw9ilqngj7w/DxDiag.txt?dl=0

 

When I first installed the game, it told me that it didn't recognize my video card.

 

Then I searched for a solution, and I did this:

 

http://simswiki.info/wiki.php?title=Game_Help:Getting_new_graphics_cards_recognized_by_the_game

 

I did all the steps and the game recognized my card, but the issue persisted - the game was laggy and choppy.

 

After that when I checked the DeviceConfig file, I noticed that my GPU Memory rating was 1. Then I tried making this change in the GraphicsRules.sgr file:


seti gpumemLevelUber 4
seti gpumemLevelHigh 4
seti gpumemLevelMedium 4
seti gpumemLevelLow 4

 

The GPU Memory rating changed to 4, but the issue persisted again.

 

Then in the DeviceConfig file I noticed this line:

 

"Texture memory: 32MB <<OVERRIDE>>"

 

This is ridicules, since my video card has 4 GB of memory. I compared the DeviceConfig file on my laptop (that has a vastly inferior graphics card), where the game works just fine, and on that line the memory was 1696 MB.

 

Here is the current status of my DeviceConfig file:

 

https://www.dropbox.com/s/cynf7ypiyuilv1k/DeviceConfig.log?dl=0

 

I also have 2 graphics cards:

 

1) NVIDIA GeForce GTX 970
2) Intel(R) HD Graphics 4600

 

I think that maybe the game tries to use the Intel card? I tried tinkering with the Nvidia Control Panel, but that didn't do anything


I kept googling my issue and I'm now stuck. So I decided to post here.

Can you guys help me to get the game working properly?

 

Thanks in advance!

Message 1 of 3 (4,698 Views)

Re: Sims 3 doesn't run properly on my GeForce GTX 970 video card

★★★★ Newbie

I have the exact same issue. Somebody please help..

Message 2 of 3 (4,554 Views)

Re: Sims 3 doesn't run properly on my GeForce GTX 970 video card

[ Edited ]
★★★★ Novice

Hello! If you are using the GTX 970. First go to the NVIDIA Control Panel and try to find the TS3.exe and the TS3W.exe. If you only have one out of the two. That is fine. Now, you will want to scroll down to the Vertical Sync option, once you have clicked on one of the two applications. Once you do that you want to change it to Adaptive, and there you go! Your FPS should now be lower. Also, you will want to edit the second application if it is there. Change it to Adaptive and so forth, and that is all! I hope this has helped your problem!

 

-TheSnipingRifle

Message 3 of 3 (3,721 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-19-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help