Help us improve Answers HQ! Take Survey No, Thanks

Game won't load after I click play in the launcher

by znelson710
Reply

Original Post

Game won't load after I click play in the launcher

★★★ Newbie

My sims 3 game stopped working. It worked a while ago and recently I tried to play and nothing happened. I clicked play on the launcher and got the loading in backround cursor and then it stopped. I tried starting the game by bypassing the launcher and still nothing. I have uninstalled all of my games and have only re installed the base game and then updated it.

Message 1 of 2 (5,772 Views)

Re: Game won't load after I click play in the launcher

★★★★ Pro

Please post your issue here: http://answers.ea.com/t5/The-Sims-3/Error-Analysis-Pressing-PLAY-does-nothing-Game-won-t-start-at/m-...

 

Welcome to the Answer HQ!

------------------------------------------------
If your problem wasn't solved and no one has gotten back to you - please either post again (or bump up your problem) or contact EA.

I cannot guarantee that my suggestions will help or solve your problem.

I don't work for EA or have any association with them. I also help in my own free time - so please be considerate.

If your problem was solved - please accept a solution! XP is also appreciated.

Happy Gaming!!
Message 2 of 2 (5,635 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-18-promo-circle

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

all-ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help