Help us improve Answers HQ! Take Survey No, Thanks

Can't download cc on Mac

by tcr1991
Reply

Original Post

Can't download cc on Mac

★★★★ Novice

So I recently installed The Sims 3 on my MacBook Pro, after I installed the base game I went to the Sims 3 Store and Exchange and installed some CC items and store items, they downloaded fine in the downloads tab and then I clicked the boxes and hit install and they installed and show up in the game and in the installed content tab. But now since I've installed all of my expansion packs and stuff packs and have them up and running I'm not able to download and install any CC. I click on add to game in the Sims 3 Exchange and the Sims icon pops up in my dashboard but then nothing happens. The item doesn't show up in the downloads tab and closing the game and trying again doesn't help. The CC I installed when I only had the base game installed is still there in the game and in the Installed Content tab but I'm not able to add anything since. Please help! 

Message 1 of 6 (259 Views)

Re: Can't download cc on Mac

[ Edited ]

@tcr1991  Try clearing your browser caches, or using a different browser.  On my mac, Firefox has always worked well, but Safari and the store don't always get along.  Also be sure to only download and install a few items at a time; the launcher can't handle a lot of data at once.

 

If this doesn't help, you may have a corrupted file somewhere in your TS3 game folder.  The most likely culprit, though not the only potential one, is a .dbc file in DCCache.  These files are bundled custom content (as opposed to the .ebc files in DCCache, which are bundled store content).  The easiest way to narrow things down is to remove all of your .dbc files temporarily and then try installing one Exchange file.  If it works, the launcher will have generated a new .dbc file, and you can install the rest of the items you want.

 

It's best practice to trash the corrupt .dbc file and rebuild its content; you may still have your original downloads in your game folder (specifically in Documents\EA\TS3\Downloads).  But if everything that's already installed works in-game, you can just put it back with the rest of your cc bundles, and the launcher probably won't try to install anything else into it now that you have at least one newer .dbc for it to work with.  Be sure to rename the newer file(s) so that they're all numbered consecutively:  If your older ones are dcdb0, dcdb1, and dcdb2.dbc, your newest would also be dcdb0 (because you pulled the others), so rename it dcdb3.dbc.

 

If you can't install an Exchange file after removing all of your .dbc files, try pulling your entire TS3 game folder out of Documents.  When you launch the game again, a clean folder will spawn with no content.  Then the same principle applies—install one Exchange item into the new folder, make sure it works, install a few more, make sure they work, etc.  Once you've added the new files you want, you can move your saves and other content into the new game folder from the old one.  (Again, be sure to renumber the .dbc files.)  Here's an explanation of the contents of your game folder, in case it's helpful:

 

https://sims3.crinrict.com/en/2011/01/faq-user-files.html

 

P.S.  I don't know if you saw, but I moved your other threads to the mac section, since they had to do with mac OS rather than game bugs.  (You can find them here and here.)  But this one can stay, since issues downloading from the store and Exchange are pretty universal.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 6 (248 Views)

Re: Can't download cc on Mac

★★★★ Novice

Thank you for replying to my question! I found some step by step instructions on the forums from someone else having this same/similar problem. I found this thread..https://answers.ea.com/t5/The-Sims-3/The-sims-3-store-content-not-showing-up-in-game/td-p/167574 This sounds similar to the files you were referring to. Should I follow these steps? if not, do you know where I could find step by step directions to the solution you're referring to? I'm not totally computer illiterate but I'm not confident enough to go start deleting files without some type of instructions. I also took a screenshot to show what it does when I try to download a Sims3Pack from the exchange. It does this same thing whether I click "add to game" or "save file" In the screenshot you can see on the left side of the screen that I have saved a Sims3Pack from the exchange on my desktop, this is my favorite house in all of the exchange. In the bottom right side of my dock you can see the round blue Island Paradise icon, this is the icon that pops up when I launch the game, I keep this icon in my dock. Next to the Island Paradise icon is the plain green Sims 3 icon. Whenever I double click the Sims3Pack or hit "add to game" in the exchange this second plain Sims 3 icon pops up in the dock but never actually does anything. You can also You can also see in the screenshot the greyed out items in my downloads tab, these items were downloaded just a few days ago and worked fine! They still show up in my downloads tab and in game! They do however randomly uninstall but when that happens they still show up in the downloads tab just not greyed out like installed content looks and I have to click select all and then install and they reinstall. I downloaded and installed these items just a few days ago when I only had the base game installed. But since I've installed the rest of the EPs and SPs it's not working at all. Years back when I played Sims 3 regularly and downloaded CC no second icon would pop up when I double clicked Sims3Packs or clicked add to game in exchange, the item would simply show up in the downloads tab of the launcher and then when it was downloaded I would click the box next to it in downloads tab and select install, then a pop up would come up and install the item. Any help would be greatly appreciated! 

 

Screenshot..

Screen Shot 2018-12-09 at 10.30.07 PM.png

Message 3 of 6 (230 Views)

Re: Can't download cc on Mac

@tcr1991  Alright, given the difficulties you're having with so many of your Exchange items, it's probably best to rebuild the content from scratch.  The instructions you found are mostly okay, but they're a bit out of date and won't address any other potential game folder corruption you might have.  So here's what you need to do:

 

  • Move your entire TS3 game folder (in Documents\EA) to your desktop.  You're not deleting anything yet, just getting it out of the way.
  • Launch the game again; you can quit when you hit the Main Menu.  This will generate a clean game folder, into which you'll be installing your store content.
  • Right-click on the sims3pack on your desktop (your favorite house), select "copy," open Documents\EA\TS3\Downloads, right-click inside, and select "paste."
  • Open the launcher and hit the Downloads tab.  You should see the sims3pack listed; install it.
  • Load a new save, go to Edit Town (you'll have to exit the tutorial again), and try to place the house.  If it's missing some store items it's supposed to have, that's fine—you can install those items or edit the house later.
  • Delete the five cache files (CASPartCache, compositorCache, scriptCache, simCompositorCache, and socialCache) inside your game folder each time you install new content.  These files should be deleted regularly even in the absence of trouble; many of us do so after every play session.
  • Go into your old TS3 game folder (now on your desktop), open Downloads, and copy a few of the sims3packs there, no more than six.  Paste them in Downloads inside your new game folder, where you pasted the house you just installed.  Open the launcher again, and install those new packs.  Load a new save and make sure the content shows up.
  • As long as the items keep installing and working properly in-game, you can keep working your way through the batches until you've rebuilt your content.
  • If you want to download new Exchange content, you can just use "save file" instead of "open with" and manually move each one into your game folder.  What I think is causing you trouble is that your browser has saved TS3—the base game instead of the IP icon—as the default app to open these files, and that's not working properly.  But "save file" will bypass the issue.

One important consideration:  A single .dbc bundle (in Documents\EA\TS3\DCCache) should not get larger than about 200 MB.  A bit over is fine, but excessively large files may not be read properly, potentially causing the issues you're seeing.  You can right-click on a .dbc file and select "get info" to see its size.  When it gets to 200 MB, drag it out of DCCache and onto your desktop.  The next time you install a sims3pack, the launcher will create a new one.  When the second one is full, renumber it (dcdb1.dbc instead of dcdb0.dbc) and move it to your desktop as well.  When you're done adding custom content, renumber the last .dbc file and move the others back into DCCache.

 

This same principle applies to store content; the only difference is that it gets bundled into .ebc files instead of .dbc files.  If all of your store content has been working, you can just move it from your old game folder to your new one.  Venues will each have an entry in Library, along with any households or lots you've saved yourself.  If you own any premium content, you'll also need the ccmerged.package inside DCBackup.  Or, if it hasn't been working (or you're not sure), you can reinstall it applying the same technique as above.

 

Once you're sure that all of your store and custom content is in place, you can move your saves and anything else you want to keep into your new game folder as well.  Again, here's Crinrict's guide to those files:

 

https://sims3.crinrict.com/en/2011/01/faq-user-files.html

 

Finally, the launcher no longer downloads the store content patches, which would go in ContentPatch.  (They're incorporated into the game's program files for Windows installs on patch 1.69, but macs can only go to patch 1.67.)  For more information on what to do about it, please see this thread:

 

https://forums.thesims.com/en_US/discussion/comment/16341942/#Comment_16341942

 

I know this is seems like a long process, but given the extent of the trouble you're having with your custom content, I don't think there's a way to fix it other than reinstalling from scratch.  This time, once you're done, you may want to copy your new game folder somewhere safe after you're done installing.  That way you'll have a backup in case something else goes wrong, and you won't have to redo all the work yet again.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 4 of 6 (221 Views)

Re: Can't download cc on Mac

★★★★ Novice

Thank you SO MUCH for taking the time to write all that out for me! After reading through your instructions I placed the Sims 3 Folder in Documents/EA onto my desktop and launched the game which created a new folder. I then copied the Sims3Pack and pasted it in the Documents/EA/TS3/Downloads folder. I launched the game and in my downloads tab was a item without a picture and was 0.0 MB. I deleted the Sims3Pack from the downloads folder, opened Mozilla and went to the house's page in the exchange and clicked save file. After it was downloaded I copied it and pasted it into the downloads folder and launched the game. It was there!!! It showed up in the downloads folder with the picture and correct size, etc.. I almost jumped out of my chair with excitement! Lol. So I checked the box and clicked install, the installer pop up launched and completed the download but instead of a success message it said "Installation Failed: Please make sure your game has the latest software updates and try again.". I know your last reply included a section about updates at the bottom, is this something I could do to fix the installation failed? I was also wondering if since I made a new game folder if I need to re download the super patcher for Mac? I did this when I was initially installing the game using the download and instructions here..https://help.ea.com/en-us/help/the-sims/the-sims-3/the-sims-3-super-patcher/#mac

 

Another question I had was I've read some Mac Simmers were having problems with their newer Macs not being compatible with the graphics or something. My Mac is a mid 2012 model but I am running MacOS Mojave, and years earlier when I would play TS3 on this same MacBook Pro I didn't have near as many problems as I'm having now. So I'm wondering if the TS3 update for Macs at this link is something I should try to fix the issue I'm having with the installation failed message. https://bluebellflora.com/2016/02/19/new-sims-3-update-for-mac-users/#comment-15054 I'm sorry for all the trouble but I really do appreciate your help! You've gotten me closer than I ever would have to playing TS3 with my favorite house. Lol. Thanks!!

 

P.S. I'm attaching a screenshot of the installation failed message in the installer.

Screen Shot 2018-12-10 at 6.13.49 AM.png

Message 5 of 6 (211 Views)

Re: Can't download cc on Mac

@tcr1991  The Super Patch only affects program files, which are independent of your game folder.  So if you ran it once and haven't uninstalled since, you're good.  You could address the store content patch issue now, which might help.  But the message you're seeing doesn't necessarily mean your game is out of date—the exchange file itself could be broken in some way.  It could also use a pack that you don't own; check the tab in the Exchange for which packs it uses.

 

The second link you listed is for an old Origin update, back when mac users were having some problems with the game.  It's definitely out of date by now; either it won't do anything, or it will break Origin, forcing you to do a clean uninstall and reinstall (of Origin, not TS3).  But it won't help with Exchange stuff.  You also don't have to worry about incompatibility between your computer and the game.  If you can load to the Main Menu, you've solved all the potential issues.  (The graphics issue specifically only affects computers from 2013 and later; the other issues were addressed by the two unknown error workarounds you applied.)

 

Anyway, I'd still suggest using a different browser to download the Exchange item that's giving you trouble.  It's also a good idea to clear your browser caches.  Be sure to delete anything in your computer's Downloads folder (not the game's Downloads but the one that shows up in the Finder) that's Sims-related.  Since this is your first attempt at installing in this clean folder, you should delete everything in DCCache and DCBackup as well.

 

If you still can't get this one file to download, try a few others.  If it's not a problem with your game folder or your browser(s), that particular download might be corrupted.  You can also PM me the link for the item, and I can test it myself, if you want.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 6 of 6 (164 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help