Help us improve Answers HQ! Take Survey No, Thanks

I'm missing rewards can anyone help

by BTBxAssassin

Original Post


I'm missing rewards can anyone help

★★ Newbie
I have contacted EA directly a couple of days ago with this problem and they are still working on it.

I got given the different depots for the monorail quest and it gave me the option to store so I did and now they are nowhere to be seen not in my inventory or in the world. There is no timer and it doesn't reset so I can't do the quest again, tried deleting and redownloading and that didn't help, tried restarting my iPhone 6 running iOS 9.3.3
Message 1 of 3 (126 Views)

Re: I'm missing rewards can anyone help

Hero (Retired)

Have you checked every sub category of your inventory?  The SHOULD be under Buildings.  That's where they go when I store mine to stop an error.


Otherwise you'll just have to wait for Tech Support to help you.  It may take a few days (or weeks) before they can get it straightened out.  I had the "Homer can't work at the City Dump" issue in one of my games and it seemed like forever before they got it fixed.

I am not a Customer Service Rep
I don't work for EA - they couldn't afford my brilliance
Neighbor lists currently full with waiting lists in all 3 of my towns.
Message 2 of 3 (112 Views)

Re: I'm missing rewards can anyone help

Champion (Retired)

We are not employees of EA so there is nothing that we can do to help you any faster.  Especially since you have already done the main thing we would have recommended that you do, which is to contact EA directly.  Aside from that all we would recommend is double checking your entire inventory, visiting Krustyland or Other Springfield, force closing all apps on your device, restarting your device and uninstalling / reinstalling the game.


TL:DR If EA are working on it... wait for them to finish working on it.

Message 3 of 3 (111 Views)
Twitter Stream