Help us improve Answers HQ! Take Survey No, Thanks

Re: untrusted system file aticfx64.dll

by onlyabutterfly

Original Post

untrusted system file aticfx64.dll

★★★★ Newbie

So I just decided to download Apex Legends today to see how it was but after I downloaded and pressed play easy anti cheat loaded up then it disappeared and then at the bottom right there was a error message saying untrusted system file aticfx64.dll Please Help!!!!

Message 1 of 6 (646 Views)

Re: untrusted system file aticfx64.dll


Hey there


Can you try to delete the "Certificates" map at this file location (C:\Program Files (x86)\Origin Games\Apex\EasyAntiCheat) <- for me was it there

This should solve the problem.


Let me know if this worked.

I am a volunteered Champion, not an EA employee.
Found a cool post ? Give it +XP, they will appricate it.
Was it the sollution to the question ? Mark it as sollution 
Useful links: AHQ Rules - User guidelines - Report A cheater - Apex Legends FAQ

Message 2 of 6 (630 Views)

Re: untrusted system file aticfx64.dll

★★★★ Novice
I tried this but then it says that some files missing or something like that. I don't remember the error code. It did open the game, but it showed the error in the loading screen.
Message 3 of 6 (294 Views)

Re: untrusted system file aticfx64.dll

Community Manager

Hey @zenonray  try doing a repair in Origin for Apex and then start the game up and see if that works. Should download the missing file. 




* Tag me with @EA_Atic if you are responding to me. Thumbs up

* If you like the comments of other players please give them XP. High five 

* If someone has helped and solved your issue please accept it as a solution. Standard smile


Message 4 of 6 (279 Views)

Re: untrusted system file aticfx64.dll

★★★ Guide
If above advice doesnt work:
1. Update windows fully
2. Run msdos as administrator and enter sfc /scannow
3. DDU your current driver (remove it) with ddu uinstall
4. Install the latest amd driver
Message 5 of 6 (277 Views)

Re: untrusted system file aticfx64.dll

★★★★ Newbie

Hi, I also have this problem. And when I delete the file it causes that other problem. I have tried repairing it in Origin, but then it just triggers the previous error. Please help me if you have a solution.


Message 6 of 6 (178 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help