Help us improve Answers HQ! Take Survey No, Thanks

Re: swtor.exe won't launch

by ItzKooo

Original Post


swtor.exe won't launch

★★★ Novice

When I try to launch the .exe for SWTOR it won't even open the launch.

I tried to run as admin, and I ran the compatibility tester, I even tried stuff on this link in hopes that it would maybe work even though it wasn't exactly the same problem. Nothing.  

Please help me Frown

Message 1 of 3 (139 Views)

Re: swtor.exe won't launch

★★ Apprentice
Hello there, @eeedg3ydaddies

So if you try to open swtor via the shortcut icon on your desktop it doesn’t do anything?
When you try to open the game does it appear in task manager?
As for now I would suggest reinstalling the game.

Good luck and have a great day!

Message 2 of 3 (116 Views)

Re: swtor.exe won't launch



first see if the launcher appears under a clean boot per this link


SWTOR Forum Username = OwenBrooks
Australian (Fellow SWTOR Player) volunteer moderator. I do not work for EA.
Photo of my New Speeder Use My Referral Link Here, more details here
More information about: Becoming a Champion 
SWTOR FAN Community Website Click Here

Message 3 of 3 (97 Views)