Help us improve Answers HQ! Take Survey No, Thanks

Re: star wars not working

by EA_Atic
Reply

Original Post

star wars not working

★★★ Newbie

I downloaded the trail of star wars squadrons and have used over half an hour just trying to load it it. It just opens to a black screen and wont go any further.

Message 1 of 3 (145 Views)

Re: star wars not working

Champion

There are other posts on this already. If you do a search on "black screen" you will see them.

If a post helps, please click the XP button, so the poster learns what is helping.
If a post answered your question, please click the "Accept as Solution" button, so others can quickly find what worked.

I am not an EA employee. Just a fellow gamer trying to lend a helping hand.
Message 2 of 3 (103 Views)

Re: star wars not working

Community Manager
@markpriest10 what platform are you playing on and have you tried any troubleshooting?

/Atic

---------------------------------------------------------------------------------------------------

* Tag me with @EA_Atic if you are responding to me. Thumbs up

* If you like the comments of other players please give them XP.  

* If someone has helped and solved your issue please accept it as a solution. Standard smile

---------------------------------------------------------------------------------------------------

Message 3 of 3 (67 Views)

ea-play-promo-splash

What's EA Play?

New name, new look, same great benefits: EA Access and Origin Access are now EA Play.

Get more info on the change here.

ea-help-promo-3

Forget your EA Account ID or password?

Reset, update, or link your account information.

View more on EA Help