Help us improve Answers HQ! Take Survey No, Thanks

squadrons update failure

by UrBob1
Reply

Original Post

Re: squadrons update failure

★★★ Novice

The performance monitor showed so many files being accessed it was hard to follow. The Origin.exe on it's own had more rows in there than fit on my screen.

 

Anyway, based on what I saw I set quite a lot of exclusions in both \AppData and \Program files (x86) but they all didn't help much.

So I just tried excluding c:\ which also didn't help.

 

Only after turining off "General", "Exploits" and "ransomware" in Sophos Home under the protection tab did the update work.

 

Didn't get to play the game though, too much other stuff to do this weekend :-)

Message 21 of 28 (305 Views)

Re: squadrons update failure

★★★★ Apprentice
@Salvolin Quick reply to prove that I can reply.
Message 22 of 28 (266 Views)

Re: squadrons update failure

★★★★ Apprentice
@Salvolin I have had further response from Sophos and they are escalating their investigation. I also told them about this thread so they know it is not just me having a problem.
They also had me run an additional test excluding particular .exe files from detection, which did not seem to have any effect.
My previous attempt at giving this information had a link to their support pages, but I don't think EA want me to post links as they said I needed to log in or some such rubbish and blocked the post.
Message 23 of 28 (265 Views)

Re: squadrons update failure

★ Novice

I have a workaround that works for me.  Hopefully someone else will benefit too.

I have Sophos Home too and cannot see any logs or events that would indicate that there are issues with it and the writing of the updates into the executables etc.

 

What I can see is when I leave the Star Wars Sqaudrons folder open, I see the DIP_STAGED files and other files that appear to be the actual patches before they are integrated into the DIP_STAGED file.  Once I receive the first retry error in Origin, I go into the folder and delete any original file that now has a DIP_STAGED equivilent file.  I then rename that file and remove the DIP_STAGED.  I do this for the entire folder structure where the game is installed (not the program files etc).

 

Once I do this, I click the retry and it will resume the patching and probably stop at around 98% with yet another retry error.  I go through the folder structure again looking for DIP_STAGED and delete originals and rename the files.

 

I often find that the touchup.dat and cleanup.dat originals are not present but their DIP_STAGED files are, I think this is part of the problem but who knows.

 

Anyway, after multiple retries, and lots of renaming, I get the update to finalise.  Once this is done, I run a repair and can run the game again.

Message 24 of 28 (207 Views)

Re: squadrons update failure

★★★★ Apprentice
@Beleidat Looks like the updated files are named DIP_STAGED, probably supposed to be renamed when completely downloaded.
As for running a repair, I have had a message telling me to run repair lots of times, but only seen the option once after I manually moved the installation. (Repair didn't work on that occasion, had to do a fresh install).
Looks like Sophos blocks some activity but doesn't show an alert, which is not good. Disabling general protection and also Exploit Mitigation while performing the update seems to work reliably. Waiting for Sophos 2nd level support to come back to me with further updates.
Message 25 of 28 (184 Views)

Re: squadrons update failure

★★ Novice

running sophos home

same issue

 

fix, see picture

Message 26 of 28 (132 Views)

Re: squadrons update failure

[ Edited ]
★★★★ Apprentice

@zoufrInteresting. I didn't do anything with the AMSI scanning option, because I didn't think that the Origin Installation System would be using integrated scanning. One more thing I'll pass on to Sophos. 2nd Level are still investigating, but there is a problem because once you succeed in updating you can't update again until the next update becomes available. Waiting for the next patch now.

Update: Just opened Origin and it started downloading an update. Looks to be the same size as the last one. We will have to see what happens.

Message 27 of 28 (116 Views)

Re: squadrons update failure

★★ Novice
@zoufr dec 12th. new patch, same error, same fix.
Message 28 of 28 (76 Views)

ea-play-promo-splash

What's EA Play?

New name, new look, same great benefits: EA Access and Origin Access are now EA Play.

Get more info on the change here.

ea-help-promo-3

Forget your EA Account ID or password?

Reset, update, or link your account information.

View more on EA Help