Help us improve Answers HQ! Take Survey No, Thanks

squadrons update failure

by UrBob1
Reply

Original Post

Highlighted

squadrons update failure

[ Edited ]
★★★★ Apprentice

I have installed Star Wars Squadrons through Origin twice now.

 

The first time I installed I managed to launch the game once. I had to perform an update before I could launch the game a second time, and the update failed with a vague comment about a possibly in use file, reboot and try again if the problem persisted. (I had managed to get less than 45 minutes of play).

After attempting to repeat the update several times, and restarting my PC twice, I gave up and reinstalled onto the C: drive instead of the E: drive.

 

I have now managed about 10 hours total play, but today when I tried to launch the game it again did an update, with the same outcome of being unable to update properly, possibly because a file is in use.

 

Since the only error message that says anything useful is the one from Easy Anti-Cheat, saying 'Unknown file version (starwarssquadrons.exe)' and 'Unrecognized game client. Cannot continue.'  I am unable to diagnose the problem further.

 

Also, there was a message saying to 'Repair the Installation' but no way to do so.

 

Can we get some support information please. I will not be re-installing to fix problems caused by updates every week.

 

Windows 10 Pro, 64GB memory, 100GB free disk space, Intel i7 4GHZ processor, nVidia GeForce GTX 960 - driver version 456.71 updated yesterday, Direct X 12.

The only events in the Windows Event Log relate to Easy Anti-Cheat. Most recent:

Application pop-up: Easy Anti-Cheat : Unknown file version (starwarssquadrons.exe)

File System Filter 'EasyAntiCheatSys' (6.1, ‎2020‎-‎04‎-‎24T08:25:57.000000000Z) has successfully loaded and registered with Filter Manager.

And of course the preceding log entries as Easy Anti-Cheat starts.

I am logged on with an Administrator account.

 

Additional information - I found the installer log. Here is the content from today's update.

****************************************
Install Date: 10/09/2020
01:00:07 Started logging
****************************************

01:00:07 Install Location: C:\Program Files (x86)\Origin Games\STAR WARS Squadrons\
01:00:07 Install Locale: en_US
01:00:07 Performing update install!
01:00:07 Initialized installation config.
01:00:07 CommandLine: install -update -locale en_US -installPath "C:\Program Files (x86)\Origin Games\STAR WARS Squadrons\" -autologging -startmenuIcon=1 -desktopIcon=0
01:00:07 EAInstaller version: 5.05.05.00
01:00:07 Original System Version (10.0.18363)
01:00:07 Launching System Version (6.2)
01:00:07 Touchup running under compatibility mode
01:00:07 OS: Microsoft Windows 8 Professional
01:00:07 Data reader initialized.
01:00:07 Data reader config: LOCALE = en_US
01:00:07 Data reader config: INSTALL_LOCATION = C:\Program Files (x86)\Origin Games\STAR WARS Squadrons\
01:00:07 Data reader config: INSTALL_LOCATION_DOUBLE_BACKSLASH = C:\Program Files (x86)\Origin Games\STAR WARS Squadrons
01:00:07 Data reader config: DOING_UPDATE_INSTALL = 1
01:00:07 Data reader config: CREATE_DESKTOP_ICON = 0
01:00:07 Data reader config: CREATE_STARTMENU_ICON = 1
01:00:07 Data reader config: 32BIT = 0
01:00:07 Data reader config: 64BIT = 1
01:00:07 Unable to open file 'C:\PROGRA~2\ORIGIN~1\STARWA~1\__INST~1\Touchup.dat'. Error code Football.
01:00:07 ERROR: Unable to properly load data: C:\PROGRA~2\ORIGIN~1\STARWA~1\__INST~1\Touchup.dat

****************************************
01:00:16 Stopping install logging
****************************************

 

Message 1 of 26 (1,037 Views)
Highlighted

Re: squadrons update failure

★★★ Newbie
@UrBob1 I am also experiencing this problem.
Message 2 of 26 (971 Views)
Highlighted

Re: squadrons update failure

★★★ Newbie
@UrBob1 I have the exact same issue. However, I tried updating on another machine and it updated and ran the game without problems. It may be a driver issue, but I'm hoping Origin support can help us.
Message 3 of 26 (958 Views)
Highlighted

Re: squadrons update failure

★★★★ Apprentice

Update

I have Squadrons working again, I think this is either the 4th or 5th re-installation.

Steps:

I created a folder off the root of C: drive and set the default install folder in Origin to point to that folder.

Uninstalled Squadrons, then checked all to possible locations to see that it was really gone (previous installations in default folder path on C and E, and installation to another path on C).

Launch game, note it didn't try to update the new installation.

 

For the first time since I originally installed, an option to repair the installation is available by right-clicking on the Squadrons launcher in Origin. Don't know if it will fix this issue since it appeared after I reinstalled for at least the fourth time. Guess I will have to wait for the next update to see if it is really fixed. I do not consider reinstalling the entire game a fix for breaking it by performing an update.

 

Next point, I see two other people had the problem in this thread, but this thread says One person had the problem. There is no 'Me Too' button.

Message 4 of 26 (949 Views)
Highlighted

Re: squadrons update failure

★★★ Novice
@UrBob1 I had the mee too button and just pressed it.

So far I have had two updates resulting in two re-installs due to exactly what is described here.

Since I don't have a lot of time to play it would be nice if a update just worked..
Message 5 of 26 (883 Views)
Highlighted

Re: squadrons update failure

★★★★ Apprentice
@Salvolin It would be nice. Takes me at least two hours to download if I have to actually install again.
I finally found that the 'Me too' button seems to be on the first post in the thread, and not if you are the person that started the thread.
Message 6 of 26 (865 Views)
Highlighted

Re: squadrons update failure

[ Edited ]
★★★ Novice

Edit 30 minutes later
Forget what I say below. That probably just started my game without the update. Resulting in being kicked for not having the anti cheat running. Will just start the full download again and hope there are no updates tomorrow so I can play than

 

 

Another day - Another update  - Another failure.

 

But I might have found a workaround.

Not sure if all the steps are required, but here is what I did today

 

1. Got the message there is an update

2. Tried to cancel it

3. Update downloaded anyway and failed

4. Renamed the game folder

   from C:\Program Files (x86)\Origin Games\STAR WARS Squadrons

   to C:\Program Files (x86)\Origin Games\STAR WARS Squadrons2

5. Tried to start the game

6. Got a message game can't be found

7. Renamed the game folder back to the original name

8. Started the game. Game started to verify all files

9. After verification game tried to update

10. Update faile dwith that second message (something about corrupted files and repair)

11. Game started repairing itself

12. Game started

 

All in all took me around 5 minutes. Thats better than a 2 hour download I guess!! (and better that a 45 minute download too, hey I got fast internet :-)

Message 7 of 26 (835 Views)
Highlighted

Re: squadrons update failure

[ Edited ]
★★★★ Apprentice

New update, can't at the moment find which, but guessing it is 1.2 or 1.02 depending who you read.

Anyway, part way through installing the update it says:

 

Game Update Error

There was a problem while updating your game. One or more files that requires an update may be in use. If the issue persists please restart your computer and resume the update.

 

Since I have just rebooted the PC, this is worrying. What file is 'in use' and how can it be in use if I have not run the game, just loaded Origin? If it is part of Origin, the installer should know how to do the installation from within Origin.

 

Retry is resuming installation from 43%.

 

Game Update Error.

Same as before.

 

Retry resuming from 90% this time.

 

100%, Finalizing.

Pop-up modal dialogue:

One of the game files is corrupted. Please repair install.

One of the game files is corrupted. Please repair install.

 

Game attempts to launch, then gives Launch Error. Unrecognised Game Client.

Modal Dialogue again, Easy Anti-Cheat. Unknown file version (starwarssquadrons.exe).

Also got a Windows notification to the effect that the game is ready to play, after the above dialogue appears.

Dismiss failed launch window.

Tried launching again, repeats Launch Error. Unrecognised Game Client. and so on.

Get the Easy Anti-Cheat modal dialogue twice this time, and it turns out also; Launch Error. Unrecognised Game Client.

 

Return to Origin game manager.

No 'Repair Game' option, just Update.

 

 

Completely exit Origin.

Restart Origin. Ensure that 'Share system interaction data' is enabled.

Check that the Repair option is still not available, although the Update option is.

Attempt to launch game.

Easy Anti-Cheat game launch does not appear. After a while the system returns to Origin.

 

Try to update game again.

(Getting 5-5.5MB/sec downloads, which is upto 25% better than when I originally installed and updated).

Again failed update, at 47% this time.

And again failed with the 'One of the game files is corrupted. Please repair install' dialogue.

Attempt to launch and just return to Origin.

Attached the install log.

Unable to find any events in Windows Event Viewer.

 

I can sent an Origin Error Report, but how to I attach it to this thread? Or is it just the InstallLog.txt i already attached?

 

Edit: I sent in an Origin Error Report, it does supply other information like DxDiag. Not very clever since I have to manually record the error report ID. An email confirming receipt and the ID would be good.

Report ID is 126b22db0014c7b7

 

Message 8 of 26 (803 Views)
Highlighted

Re: squadrons update failure

★★★★ Apprentice

Further update. Still can not complete installing an update.

It looks as if the problem is related to downloading files.

I see Cleanup.dat_DiP_STAGED, installerdata.xml_DiP_STAGED, Touchup.dat_DiP_STAGED in the __Installer folder while update is in progress, but at the point where the install log indicates that there is a problem accessing Touchup.dat only the download staged version of the file exists in the __Installer folder, which is apparently where the update is looking for the downloaded file.

I ensured that ALL users have full access to the folder, but that didn't make any difference.

The report that the file might be in use is apparently not correct, one or more files is not available because the download failed to complete for some reason.

 

I have tried this with my Internet security disabled completely, no difference.

 

I am puzzled why Touchup.exe should be running in Windows 8 compatibility mode.

 

Message 9 of 26 (764 Views)
Highlighted

Re: squadrons update failure

[ Edited ]
★★★★ Apprentice

Got it to work, but not a clear solution yet.

On my system I use Sophos Home Premium Internet Security, and I also have Acronis True Image 2020 backup. Acronis includes an anti-ransomware component.

My previous attempts to get the updates to work by turning off Sophos did not work. Similar attempts with Acronis turned off also failed. Since neither of them was reporting any issues anyway, I didn't keep trying.

Today I turned off every option I could find in both Sophos and Acronis, and the update completed.

I still don't know exactly what the problem was, but both systems have complained in the past about updates that work in certain ways, mostly changing the contents of executable files in a suspicious manor.

If/when I get a more detailed explanation of the solution, I will update here.

 

PS If you do turn of security to update, remember to turn it back on afterwards Standard smile

 

Message 10 of 26 (730 Views)

ea-play-promo-splash

What's EA Play?

New name, new look, same great benefits: EA Access and Origin Access are now EA Play.

Get more info on the change here.

ea-help-promo-3

Forget your EA Account ID or password?

Reset, update, or link your account information.

View more on EA Help