Help us improve Answers HQ! Take Survey No, Thanks

"Your device isn't compatible with this version"

by redcardinalis
Reply

Original Post

Highlighted

"Your device isn't compatible with this version"

★★ Novice

Hi folks,

 

I've just bought a new LENOVO S340 Chromebook running Chrome OS Version 81.0.4044.127.

I was expecting (looking forward!) to install SW GoH but when I look for the game on Google Play Store the listing says "Your device isn't compatible with this version".

Really? Is this correct? If it is, what's the reason and is there anything I can do to solve the problem?

 

Cheers!

Message 1 of 9 (317 Views)
Highlighted

Re: "Your device isn't compatible with this version"

@redcardinalis is your OS completely updated?
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 2 of 9 (281 Views)
Highlighted

Re: "Your device isn't compatible with this version"

★★ Novice

Hi there!

 

Many thanks for your quick reply Standard smile

 

Yes, I've checked and 1.0.4044.127 appears to be the most up-tod-ate version of Chrome.

 

I'm now wondering whether this might be a problem with the Play Store wrongly reporting this rather than specifically SW GoH? I have successfully installed other games from the Play Store so I'm not really sure.

 

I've raised a query at the Play Store.

Message 3 of 9 (258 Views)
Highlighted

Re: "Your device isn't compatible with this version"

★★ Novice

Well, I've now been in contact with Google support. They gave a number of steps to try and resolve the issue. I've completed these but unfortunately, I'm still getting the same message in the Play Store.

 

I have however, successfully installed other Android games and Google have suggested therefore that the problem lies with SW GoH rather than with the Play Store. I'm not sure what the problem is.

Message 4 of 9 (238 Views)
Highlighted

Re: "Your device isn't compatible with this version"

@redcardinalis The QA support that works these boards is out today, but should return tomorrow. You could try to contact customer support and see if they have any information today.
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 5 of 9 (226 Views)
Highlighted

Re: "Your device isn't compatible with this version"

★★ Novice

Good advice thanks! I'll do as you suggest and see if I can get my installation problem resolved.

 

Many thanks for your help.

Message 6 of 9 (185 Views)
Highlighted

Re: "Your device isn't compatible with this version"

@redcardinalis I checked with the QA team and it looks like the problem is with the Play Store flagging your device as incompatible (like not a full Android device).

Unfortunately this problem lies with Google. You may need to contact Play Store or Lenovo support to get it resolved.
_____________________________________________________________
I am a volunteer on this forum, and not an employee of EA or CG. Please let me know how I can help you!
Message 7 of 9 (154 Views)
Highlighted

Re: "Your device isn't compatible with this version"

★★ Newbie

Hi. I have new phone Xiaomi redmi 8 Android 9! It's not in the play store!is there any possibility in the future to get it? 

Message 8 of 9 (139 Views)
Highlighted

Re: "Your device isn't compatible with this version"

★★ Newbie

I have encountered this problem too Frown

Message 9 of 9 (93 Views)