Help us improve Answers HQ! Take Survey No, Thanks

Re: constant 80-100% cpu usage on apex

by killcount01
Reply

Original Post

Highlighted

Re: constant 80-100% cpu usage on apex

[ Edited ]
★★ Apprentice

@killcount01Intel I5-65003.2GHz, 16GB RAM, Geforce 1060 6GB, installed on a SSD. Even downloaded latest BIOS patch for my motherboard and it did nothing.

Message 11 of 24 (330 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

★★★ Novice
@killcount01 Important question did you play the game before you installed the latest update for windows on the result file you provided it says that windows was installed on 6/16/2020 to there might have been an implication while installing them or more micro updates are happening in the back round that are overwhelming your CPU when you play.
I would recommend installing a fresh windows 10 download with the latest updates as well a reinstalling your drivers to see if this resolves anything.
Message 12 of 24 (306 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

[ Edited ]
★★ Apprentice

I found out recently, that setting ingame V-sync to adaptive 1/2 rate helps, it's not like 50% better, but from constant 100% I am at 70-90% and sometimes getting up to 100% but without huge and annoying lags, just fps drops (which is also not fun, but playable). Nonetheless, would be REALLY nice if respawn/EA would at least look into this, and with upcoming update  imply some small patch. Not sure if this is relevant, but when I was near Gib ult or even near Gib at all I've noticed increase of CPU use and fps dropped slightly. 

 

EDIT: I have downloaded latest windows update (which made me blue screen once for no reason), then set fps_max 65 in apex settings, disabled V-sync in game and I've noticed HUGE upgrade, CPU is sometimes jumping to 80% but in most cases it oscilates between 65-90%, no FPS drops at all, no lags, cpu and gpu temperatures don't go higher then 65-70° (not even close to maximum anyways). I really recommend to do win updates, driver updates and I've also added apex as exception for my antivir so it doesn't lag it in the background at all. Let me know if it helped any of you.

Message 13 of 24 (279 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

★★★ Apprentice
@EA_Kent @EA_Kent as i notice the usage is 100% only in lobby ,, and in drop if you change the menu (ex ; store ) the usage go to normal ,, only in lobby in characters ,, and i try somthing if i see 100% and quit the game and start it again the problem solved ,, its happens after every time i close origin ... or start it 1st time
Message 14 of 24 (259 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

★★★ Novice
@miltoid19 i played the game even after doing all this and i stilkl had the problem
Message 15 of 24 (246 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

[ Edited ]
★★ Apprentice

@The-NazguulThis I've noticed too, also legends in lobbywere  loading incredibly long for the first time, not sure what is that about. But like I previously said, installed latest Win update, and all the issues are gone just like that.

Message 16 of 24 (221 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

★★ Apprentice
@killcount01 Have you tried updating windows? It helped me and a few others already, give it a try!
Message 17 of 24 (184 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

Community Manager

@Shoookkz 

 

Interesting, thanks for the update. What version number of Windows are you currently on? 

 

 

/Kent

Stay and Play.png
Message 18 of 24 (154 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

★★ Apprentice
@EA_Kent Not sure if that's what you need (I am not an expert) but: update version 2004, quality update .NET Framework 3.5 and 4.8.

If this isn't any of the information you needed, you'll have to lead me to where I can find it, sorry Disappointed
Message 19 of 24 (138 Views)
Highlighted

Re: constant 80-100% cpu usage on apex

★★★ Novice
@Shoookkz i have the updated version of windows but i thin i solved the problem for myself. i just ijnstallled the second stick of ram and it works wonderfully now. although ive anly played a few games so far. if iot comes back ill make sure to post on the thread
Message 20 of 24 (117 Views)
Twitter Stream