Help us improve Answers HQ! Take Survey No, Thanks

Re: You have lost connection to the host - I can not play a single match online!

by OutaController
Reply

Original Post

Re: You have lost connection to the host - I can not play a single match online!

★★★★ Novice

Awesome work around!

Ill test this later tonight when i get home.

 

I really hope i can get MP to work.

Thanks for sharing this. Standard smile

Message 71 of 92 (483 Views)

Re: You have lost connection to the host - I can not play a single match online!

★★★★ Novice

I have done some testing on @Gordelox workaround. 

 

First, the workaround does work. Great job man!!

 

Second, while disabling IPv4 will render the internet on your computer useless you CAN reenable it after and everything will still work on the Xbox and your PC internet will be back to normal using IPv4 without issues. 

 

Lastly, restarting your Xbox One will break the fix but it's not as hard to reenable as it was the first time. I took notice of what IP settings changed on my Xbox after the restart and surprisingly it was only one number. All I had to do was go back offline on my Xbox, head over to my computer and change the one number in the manual IPv6 settings and presto!! fixed again. 

 

The number that changes is the last digit in the first line of the IPv6 address on your Xbox One. It's the number that follows two colons(Like this "::" without the quotes.) In my case it was a 7 and changed to an 8 when I restarted my Xbox. Changed the manual IPv6 setting to the 8 on my PC and the fix was working again.

 

So it only requires about 30 seconds to re-enable the fix if you restart.

 

AMAZING JOB @Gordelox

 

I will make a YouTube Tutorial on this later for anyone who is confused.  

Message 72 of 92 (473 Views)

Re: You have lost connection to the host - I can not play a single match online!

★★ Novice

It's not just the PC that's having this problem!!!

 

XBOX ONE:

On Xbox we are getting constant disconnects.  When match is starting, when match is already underway.  Can always form group in Custom Match but can never start one at all.

 

 

Message 73 of 92 (461 Views)

Re: You have lost connection to the host - I can not play a single match online!

★ Apprentice

I'm glad it worked for you as well, @J04DAN and thanks for testing it further, it's good to know you can re-enable IPv4 on your PC, and it's even better to know that setting this back up after you're xbox restarts is as simple as it is.

 

If your going to make a youtube video, if I may offer a suggestion, I would start by explaining the symptoms. The main one being not able to see your character model when loading into lobbies, it will save people dealing with regular NAT or connection issues time and confusion.

 

Also I would link  where people can vote for the option to disable IPv6 at will on the xbox itself. 

 

Beyond that go nuts, just toss my handle in the description or something if you would, I don't wanna come across as too full of myself, but I was really pleased with myself when I figured this out.

 

Overall, I'm glad I could be a part of such a great group of people working together to figure this out, I ran across a few EA games that people have this issue with, and maybe this will work for them as well.

 

 

 

P.S. @DaevinCmdr if you haven't seen this and tried it yet, now you're gonna get an email, cause I used your name ;P

 

 

 

P.P.S. @Feral411 I looked into it and here's what I found, copied from superusers.com creditided to a user named "Spiff"

 

"System Preferences > Network (henceforth "Net Prefs") allows you to have more than one of what they confusingly call "services" for each interface. For each additional manual IPv6 address you want to define, you need to add an additional Net Prefs "service" for the relevant network interface.

 

When you first go to Net Prefs, the prominent list of interfaces is technically, by Net Prefs' terminology, a list of "services". Hit the "+" button at the bottom of the list to add a new "service" for an interface. You'll be asked which interface the new "service" applies to, and you'll be asked for a name for that "service". So if you want to add a second IPv6 address to your built-in Ethernet, select "Ethernet" and name it "Ethernet 2nd IPv6 addr" or something. Then go to the IPv6 settings for this newly-created "service" and configure it for your secondary IPv6 address. Repeat until you've made a separate Ethernet "service" for each IPv6 address you wanted to manually assign."

Message 74 of 92 (444 Views)

Re: You have lost connection to the host - I can not play a single match online!

★★★★ Novice

Yeah, I'm on an XB1 also with Midco services. Still have yet to get a working MP match.

Message 75 of 92 (425 Views)

Re: You have lost connection to the host - I can not play a single match online!

★★ Apprentice

@Gordelox you ARE a mother * genius! I'm at work right now, but I WILL be trying that later.

 

Great stuff, I voted for everything IPv6 on the Xbox site, too xD.

 

Cheers!

Message 76 of 92 (403 Views)

Re: You have lost connection to the host - I can not play a single match online!

★★ Apprentice
@EA_David so it's been seemingly determined that this is absolutely IPv6-related, and though it may be out of your direct line of help, you can still read this and help us.

Please get in contact with Microsoft, the Xbox One development team, and help convince them into developing the ability to turn off IPv6. This affects more than just one game, and you can prove that you're on the side of games by helping us when we need it.
Message 77 of 92 (389 Views)
Highlighted

Re: You have lost connection to the host - I can not play a single match online!

★★★★ Novice

have they found a way to fix this yet?

Message 78 of 92 (383 Views)

Re: You have lost connection to the host - I can not play a single match online!

[ Edited ]
★★★★ Novice

@J04DAN Have you made the video showing this yet? I get how to do it more or less. Just not sure how to enter all 3 IP strings..

 

EDIT: haha I feel dumb. Figured it out. Hoping it works here

 

Message 79 of 92 (343 Views)

Re: You have lost connection to the host - I can not play a single match online!

★★★★ Novice

@Gordelox Thanks for the amazing work! I got it working and am currently playing my first MP match!!! Still hoping that EA gets a fix out so I don't have to do this. That or your suggestion about there being an option to turn off IPv6 on the xbox would be cool too.

 

@malakim2099 I am on Midco with the Xbox 1 as well. This fix does work if you are able to do it.

Message 80 of 92 (330 Views)

me-andromeda-fem

Keep your account safe

We'll make sure it's you by sending you a code for your trusted devices.

Learn more about Login Verification on EA Help

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help