Help us improve Answers HQ! Take Survey No, Thanks

Re: Teensy cursor makes game unplayable.

by EA_Kipling
Reply

Original Post

Highlighted

Teensy cursor makes game unplayable.

[ Edited ]
★ Novice

The cursor's ridiculously small size and its yellow color make it extremely easy to lose track of. I want to play at 4k, but even at 1080p the cursor is just too tiny.

 

It is roughly a quarter of the size of the default Windows cursor, roughly 4 pixels long. I've played this game at launch and I don't recall ever having trouble with the cursor size. So this is probably a bug.

 

Please fix and/or advise on workarounds.

 

Windows 10, 4k screen, no desktop scaling, Nvidia 1080 Ti with latest drivers.

 

https://www.dropbox.com/s/te5duuvo3uwzjyg/cursor.png?dl=0

Image for reference.

 

https://www.dropbox.com/s/4ds9brb8gsbovd5/DxDiag.txt?dl=0

Dxdiag

Message 1 of 7 (318 Views)
Highlighted

Re: Teensy cursor makes game unplayable.

@MadMinstrel

 

See if this helps

 

Now if you do 
•Press the [Windows] Key + [R] at the same time. 
•Copy the following in to the text box and press ok: %localappdata%\swtor\swtor\settings

Go to the folder called GUIProfiles , these are your UI settings for each character .

Now in these you will find a section like below, now this says global scale is set to 1.1 , see if setting to 1.5 helps.

-<Global>

<GlobalScale Value="1.100000" Type="3"/>

<EnableMovableWindows Value="0" Type="2"/>

</Global> 

____________________________________________________________


SWTOR Forum Username = OwenBrooks
Australian (Fellow SWTOR Player) volunteer moderator. I do not work for EA.
Photo of my New Speeder Use My Referral Link Here, more details here
More information about: Becoming a Champion 
SWTOR FAN Community Website Click Here

Message 2 of 7 (295 Views)
Highlighted

Re: Teensy cursor makes game unplayable.

★ Novice

This only affects the scale of all the other UI elements. The cursor remains unaffected.

 

I believe the cursor size issue has something to do with Windows DPI scaling. I've discovered that If I set the scaling to a ridiculous 300%, the cursor works ok, but that's not a workable solution for me since it makes all my other apps entirely unusable and I need to alt-tab away from the game often throughout the day.

Message 3 of 7 (258 Views)
Highlighted

Re: Teensy cursor makes game unplayable.

[ Edited ]

@MadMinstrel

 

I thought it may be tied to the DPI have you tried all the options for DPI scaling ?

 

Application / system / system enhanced ? etc

 

and disabled fullscreen optimisations 

 

dpi.JPG

 

 

____________________________________________________________


SWTOR Forum Username = OwenBrooks
Australian (Fellow SWTOR Player) volunteer moderator. I do not work for EA.
Photo of my New Speeder Use My Referral Link Here, more details here
More information about: Becoming a Champion 
SWTOR FAN Community Website Click Here

Message 4 of 7 (254 Views)
Highlighted

Re: Teensy cursor makes game unplayable.

★ Novice

Yes, I have, none of them seem to make a difference.

Message 5 of 7 (242 Views)
Highlighted

Re: Teensy cursor makes game unplayable.

@MadMinstrel

 

It appears this is a common problem, I did come across this thread link for League of Legends and 4K monitors.

 

Obviously this is not something that bioware/swtor can or will endorse or recommend but so saying that, it does not change swtor game files so it isn't altering the game itself.

 

if you feel this is something you want to test to see if it works with swtor is entirely up to you 

Just be sure it is running as administrator. (I would ignore the custom cursor pack download mentioned in the link as that is for lol).

____________________________________________________________


SWTOR Forum Username = OwenBrooks
Australian (Fellow SWTOR Player) volunteer moderator. I do not work for EA.
Photo of my New Speeder Use My Referral Link Here, more details here
More information about: Becoming a Champion 
SWTOR FAN Community Website Click Here

Message 6 of 7 (234 Views)
Highlighted

Re: Teensy cursor makes game unplayable.

EA Live QV Team

@MadMinstrel Not sure if you've tried this as well, but this is my 4K set up when I have Windows set to 200% DPI scaling:

 

1. Open the Start menu and type 'Mouse'
2. Select the 'Mouse Settings' option from the Control Panel section.
3. In the 'Pointers' tab, set the Scheme to 'Windows Default (extra-large) (system scheme)'
4. In the 'Pointer Options' tab, disable 'Display pointer trails' and 'Hide pointer while typing'. Press OK.

 

The mouse cursor might look weird and messed up at first, but after I restarted my PC the scaling was all normal again.

Message 7 of 7 (221 Views)