Help us improve Answers HQ! Take Survey No, Thanks

Re: Still problems launching

by Sugarfix72
Reply

Original Post

Highlighted

Still problems launching

★★ Novice

I know the games runs as I'm already about 6 ours in (though I thing 2 of those hours are from repeatedly trying to get it to run!)

 

I'm running the origin launcher as admin, Virus protection is turned off and I'm running NeedForSpeedHeat.exe as admin as well.

 

What's happening right now is that when I launch the game (right clicking the exe and selecting "run as administrator" I get the NFSHeat window open up, the screen eventually goes black, my monitor show I drop into HDR mode then it drops back to the desktop, the play button changes from grayed out to orange again.

 

My system is more than capable of handling this game.  I'm running an i9 with 64Gb Ram, a GTX 2080Ti and the game is installed on a SSD drive.

 

I've had similar issues with games running from the Origin launcher in the past (most notably SW battlefront) but games running from Steam, GOG, Epic, Uplay and Battle.net all work first time every time without me having to jump through the hoops of disabling Antivirus (which I'm particularly unhappy about) and having to right click to run as administrator.  So my only conclusion is that it's the Origin launcher and platform which is the common denominator.

Message 1 of 4 (212 Views)
Highlighted

Re: Still problems launching

★★ Novice

A quick update on this After banging my head against the brick wall of trying to get this game to run tonight, I happened to click the Play button and this time the game launched but it stuttered massively and was unplayable.  I exited out and tried to run it again and surprise surprise, it won't run again.

 

This has been 2 hours tonight trying to get this to run so I'm beginning to wonder what I'm paying my subscription for.  I spend all day solving peoples computer problems, doing the same in the evening for fun is not entertaining and instead it's a bus man's holiday.

Message 2 of 4 (194 Views)
Highlighted

Re: Still problems launching

★★ Novice

Having tried to run the game a few more times and it appears the game will run EVENTUALLY if I just keep hammering at it. I need AV turned off, Oigin app run as admin and launch the game as Admin. I do do the same thing over and over again, eventually it will run.

 

that’s not a solution though and it doesn’t explain why it won’t run first time.

Message 3 of 4 (134 Views)
Highlighted

Re: Still problems launching

★★ Novice

No reply from EA in a week?

Message 4 of 4 (82 Views)
Twitter Stream