Help us improve Answers HQ! Take Survey No, Thanks

Server selection doesn't work, it's not broken.

by rebuiltHK47
Reply

Original Post

Server selection doesn't work, it's not broken.

★★★★★ Novice

So... I'm being connected to an IP in California, despite the game set to connect to a server in Ohio. The Ohio server is 67ms. Guess what my ping to the Calif server is. It's not 67. It's much much much higher. It's anywhere from 200ms to 1,000ms. That's right! Sure it drops down to 160 at minimum. But most of the time it's above that.

I cannot play like this. This is the only IP I'm connecting to. Whether it's the game server, which I am confident it's not, being routed there is really really really bad.

I'm not the only one being routed there. Many others are being routed to 159.153.38.49. This can be found with Windows Resource Monitor. Everyone being routed to this IP, is experiencing the intense amount of lag. Unplayable lag.

 

The sever selection in the game isn't broken because this is happening. Ports don't matter either. This affects anyone whether using a router or not.

 

This MUST be changed.

Message 1 of 36 (825 Views)

Re: Server selection doesn't work, it's not broken.

★★★★★ Novice

It just went up to 8,930ms. I shouldn't have anywhere close to that when connected to the one closest to me.

Message 2 of 36 (817 Views)

Re: Server selection doesn't work, it's not broken.

[ Edited ]
★★★★★ Novice

Today it's been lots of 5k and 10k ms. The last week has been mostly the same. It's only in this game.

One thing that doesn't make sense, is that the lag usually goes away when you die. So whatever is causing this lag, it's also not resetting things right. This **** has to stop. STOP using that IP. STOP routing people through that.

I've been in lag stunlock (what I call it) while typing this out. I was just booted from the server while typing the previous sentence for being idle for too long. I was also on a great team against another great team. It was nice and balanced. I don't care if I die in the game. I care if I die because the bad network setup is getting me killed, not because I wasn't paying attention and someone got me, or I was defeated by someone doing better than me. I care that when I get a hero, if I pop my head out, I will most definitely lag up and be unable to move, and then die. All that effort and teamwork, down the drain. A huge waste of time.


I have no issues with any other game. Only this one. Why? because I am being sent to an IP in CALIFORNIA at a massive 200 - 9000ms, instead of the selected IP in OHIO at a minimum of 60ms!

Anyone else reading this: Open the game, sit in the main menu, open Windows Resource Monitor, go to the Network tab, select "starwarsbattlefrontii.exe" in the "Processes with Network Activity" section, then under "TCP Connections" the top item in the list will show what IP you are connected to under "Remote Address". If you are connecting to 159.153.38.49 and your game is set to a server somewhere not in Calif, that is why you are lagging.

Message 3 of 36 (797 Views)

Re: Server selection doesn't work, it's not broken.

★★★★ Apprentice

Hey Mate.

 

It sounds a bit weird.

 

What kind and how fast is the connection you have from your provider?

 

Have you tried to set it to Auto or tried any of the other Servers?

 

Kind regards

 

MLB

 

Message 4 of 36 (785 Views)

Re: Server selection doesn't work, it's not broken.

Message 5 of 36 (774 Views)

Re: Server selection doesn't work, it's not broken.

★★★★★ Novice

Phone tether. That stuff has nothing to do with it. It doesn't matter what connection type used. This is where we're routed to. This is the source of all the lag.

Message 6 of 36 (770 Views)

Re: Server selection doesn't work, it's not broken.

★★★★ Apprentice
There are also another guy that are having problems with the exact same thing, I added the Link.
Message 7 of 36 (767 Views)

Re: Server selection doesn't work, it's not broken.

★★★★★ Novice

Yeah I saw that. I don't know how to run a Uo-trace, or what it is. I posted there. Nice find.

Message 8 of 36 (758 Views)

Re: Server selection doesn't work, it's not broken.

★★★★★ Novice

I found it. It's not a command. It's a program.

Message 9 of 36 (757 Views)

Re: Server selection doesn't work, it's not broken.

★★★★★ Novice

So today is a lag fest. Nothing but lag. 5Kms, 7% packet loss over 5 min.

Message 10 of 36 (719 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help