Help us improve Answers HQ! Take Survey No, Thanks

Re: Potential Random Crashes to Desktop Fix

by SpitzEasy

Original Post

Potential Random Crashes to Desktop Fix

[ Edited ]
★★★★ Novice

Have a potential fix for everyone having issues. Like most, could run 2-8 games without a crash, and then an hour later experience 33-66% crash rate. Not gonna go deep into specs, but I am running a 144hz monitor and an RX 480.

Regardless of specs, after the changes I made, I literally am completely crash free in probably 75-100+ games, along with a friend who has literally the exact same PC, and had the same exact issues, and did this config fix and alleviated their crashes as well.




Follow the directions in this link if you are running 144hz, if you are 60hz or whatever your monitor limit is, just change it accordingly. My video config file that I was running is copy pasted below, if you want to just copy paste it in for ease of testing. make it read only after, otherwise it can get rewritten in game if you even glance at the in-game video settings




{ "setting.cl_gib_allow" "0" "setting.cl_particle_fallback_base" "3" "setting.cl_particle_fallback_multiplier" "2" "setting.cl_ragdoll_maxcount" "0" "setting.cl_ragdoll_self_collision" "1" "setting.mat_depthfeather_enable" "1" "setting.mat_forceaniso" "2" "setting.mat_mip_linear" "1" "setting.stream_memory" "83886" "setting.mat_picmip" "1" "setting.particle_cpu_level" "0" "setting.r_createmodeldecals" "0" "setting.r_decals" "0" "setting.r_lod_switch_scale" "0.6" "setting.shadow_enable" "0" "setting.shadow_depth_dimen_min" "0" "setting.shadow_depth_upres_factor_max" "0" "setting.shadow_maxdynamic" "0" "setting.ssao_enabled" "0" "setting.ssao_downsample" "3" "setting.modeldecals_forceAllowed" "-1" "setting.dvs_enable" "1" "setting.dvs_gpuframetime_min" "6736" "setting.dvs_gpuframetime_max" "6944" "setting.defaultres" "1600" "setting.defaultresheight" "900" "setting.fullscreen" "1" "setting.nowindowborder" "0" "setting.volumetric_lighting" "0" "setting.mat_vsync_mode" "0" "setting.mat_backbuffer_count" "1" "setting.mat_antialias_mode" "12" "setting.csm_enabled" "0" "setting.csm_coverage" "0" "setting.csm_cascade_res" "512" "setting.fadeDistScale" "1.000000" "setting.dvs_supersample_enable" "0" "setting.gamma" "1.000000" "setting.configversion" "7" }


end video config, 1600x900 not required, just current resolution i am running


Game Properties / Advanced Options Line


"+fps_max 0 -novid -freq 144 +cl_showfps 4 -forcenovsync"


That video config change along with these command line options for 144hz setup completely fixed the crashes for me. It turns on adaptive resolution I believe, so things you aren't straight looking at kinda get toned down / blurred out, but it also helps the game and your frames just run smoother.


So, with that being said, after being crash free for about 50ish games, the adaptive resolution was getting a bit... annoying, or harsh on my eyes, so I decided to play around with settings again. I defaulted the video config file, fired the game up, crashed instantly upon landing. I then set my max frames in the command line options to 110, this fixed the crashing, after every 10 games or so I upped it in 10 frame increments, ending with 135, and still am completely crash free, with a "default" video config.

I'm not too computer savvy but I think it just has something to do with unlocked frames or some kind of frame rate overload that causes the crash.


was also told from someone who just tried " . . . it should be included that people go into their direct video card settings and disable any framerate lock/limiter they may have."

Message 1 of 15 (998 Views)

Re: Potential Random Crashes to Desktop Fix

Community Manager

Thank you for the post, @SpitzEasy !

I'm sure there are others in the post below willing to take a look at this if you're able to pass this along over there as well.


Hey that was a great reply. Good stuff. What now? Give them +XP to help level them up!
Did their response fix it? Mark it as a solution so it helps others!
Want to learn more on how to level up and becoming a Hero for the AHQ? Learn more about it here:
Message 2 of 15 (979 Views)

Re: Potential Random Crashes to Desktop Fix

★★★ Guide
Hope this helps some amd radeon users.. Seem to be having it worse then nvidia users ^^
Message 3 of 15 (971 Views)

Re: Potential Random Crashes to Desktop Fix

★★★★ Novice

Thanks for giving your precious time to try to fix the game instead of developers, but i have no intention to get thru all of that just to TRY to fix this game, hell there is a lot other games to play, and i m sick of doing those fixes with all those broken EA games for you, thanks man and cheers..P.S. After this latest patch game is crashing like crazy, much more than before.

Message 4 of 15 (958 Views)

Re: Potential Random Crashes to Desktop Fix

★★★ Guide
It's not just EA games.. Before I fixed Apex couldnt run fortnite, ring of elysium and was limited to window mode in Warface (which i play now for almost two years).. Now i fixed Apex and all those other games work too.. It's reassuring now to know i dont have to worry that much any more about these weird issues and i can try out games because i spent a few hours fixing apex and now everything works..
Message 5 of 15 (949 Views)

Re: Potential Random Crashes to Desktop Fix

★★★★ Novice

"+fps_max 0 -novid -freq 144 +cl_showfps 4 -forcenovsync"


This is work for 60hz to?

Message 6 of 15 (912 Views)

Re: Potential Random Crashes to Desktop Fix

★★★★ Novice
So you can try just adjusting the +max_fps, set it to 100 or 110 if you are on 144hz, this alone fixed the crashes for me. Otherwise the video config file change only takes ~1 minute to do, it's just locating the video config file in your saved games file, and then changing 2-3 values around. BUT, just capping fps at 100-135 has worked for me, which is an easy fix to try.
Message 7 of 15 (895 Views)

Re: Potential Random Crashes to Desktop Fix

★★★★ Novice

For 60hz I am not sure, I am running 144hz so with my limited PC knowledge I think the "max fps" you can get is 144hz, the limit of the monitor. So for 60hz I would think / assume the max frames you can get are 60, the limit of the hz of the monitor, and the frequency is just your monitor hz, so -freq 144 would not work for you, but 60 would. You can try just a fps cap fix, if I had your setup I would just try capping fps at say 40, 50, 55, or 60 and seeing if that alone helps the crashes. Otherwise you can try the video config changes I posted to enable adaptive resolution, but with 60hz settings which is just going to the .dvs max and min and finding the value for 60hz, the max would be 1,000,000 (one million) divided by 60. That gives you your maximum value, then the minimum would be that value multiplied by 0.97.

Message 8 of 15 (892 Views)

Re: Potential Random Crashes to Desktop Fix

★★★★ Novice

Your instructions are confusing to me but they seemed to help enough. I have fixed my game by changing 3 lines in the video config file


.on 60hz


only edited lines below


"setting.dvs_gpuframetime_max" "60"

"setting.dvs_gpuframetime_min" "31"

"setting.mat_vsync_mode" "3"


also made sure to set videoconfig to read only.

Message 9 of 15 (809 Views)

Re: Potential Random Crashes to Desktop Fix

★★★★★ Novice

I can confirm it 

"setting.dvs_gpuframetime_max" "60"

"setting.dvs_gpuframetime_min" "31"


worked for me as well

Message 10 of 15 (730 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help