Help us improve Answers HQ! Take Survey No, Thanks

Re: Party not ready...?

by Longshotmagoo

Original Post

Party not ready...?

★★★ Newbie

I'd like to be able to queue solo and maybe fill a party, but... when I click ready, it says party not ready. What gives?

Message 1 of 73 (3,689 Views)

Re: Party not ready...?

[ Edited ]
★★★★ Novice

I played few games then I got the same problem, says party not ready. I tried to reboot the game, and now i'm stuck at the loading screen.


Edit: Probably servers are down.

Message 2 of 73 (3,668 Views)

Re: Party not ready...?

★★★★ Novice
This is exactly what happened to me except i only played one game and now my loading screen lasts for ever
Message 3 of 73 (3,650 Views)

Can't play with public teams

★★★★ Newbie

Hi, I'm not being able to play the game by myself with public teams it only shows 'party not ready' 

Message 4 of 73 (1,532 Views)

Re: Party not ready...?

Community Manager
Hey @Longshotmagoo  @hexsigns @SaltySamu, we had some issue last night, do you still experience the same issue that you can queue solo? 


* Tag me with @EA_Atic if you are responding to me. Thumbs up

* If you like the comments of other players please give them XP. :eahigh_file: 

* If someone has helped and solved your issue please accept it as a solution. Standard smile


Message 5 of 73 (3,592 Views)

Re: Party not ready...?

★★★★★ Newbie

Im still having the same issue since yesterday. After every game i played it would just say party not ready and will not queu up unless you close and restart the game.

Message 6 of 73 (3,581 Views)

Re: Party not ready...?

[ Edited ]
★★★★ Novice

Same problem here, the only way to play another game is to restart the game

Message 7 of 73 (3,574 Views)

Re: Party not ready...?

★★★★ Novice

Same here very annoying great game would be nice to not have to reset after every match. 

Message 8 of 73 (3,561 Views)

Game won't go into Matchmaking after a game

★★★★ Novice

Hi, playing on PS4

After I click Matchmaking, the game is stuck saying "Party not ready" and I'm the only one in the party. After 10 minutes I get an error saying unable to connect to servers. This happens everytime I launch the game from the PS menu, play 1 game then get back into the main menu. 

Message 9 of 73 (1,006 Views)

Re: Game won't go into Matchmaking after a game

★★ Novice

I keep thinking, party not ready? I AM THE PARTY!

Message 10 of 73 (982 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help