Help us improve Answers HQ! Take Survey No, Thanks

[PC] Apex Legends S3 Update, Frametime / Frame skipping / Framerate FPS Issue

by rammonon
Reply

Original Post

Highlighted

[PC] Apex Legends S3 Update, Frametime / Frame skipping / Framerate FPS Issue

[ Edited ]
★★★★ Novice
* This is beyond User Repair until a fix is implemented:

* No doubt about it. I encourage anyone to Utilize the MSI afterburner Log History to file while they have the polling rate set to 100ms in order to review your frame times.

It has come to my knowledge that my friend is less susceptible to frametime drops and stutters. But, I had him do this same thing with logging his history and sending it to me after two games since he uses an i7 8700k and GTX 1080ti we have a similar setup.

* With MY file here: https://gofile.io/?c=vU3gBH you can see some games I play once in a blue moon may have no issue. However, most are a problem. Every single one is without any background processes done and switching between different fixes.

* With His file: https://gofile.io/?c=k3uwVO you can see the exact same pattern (although his CPU is pinned at 100C for some reason. I even delidded this and put on Liquid metal so I have some Voltage and Vcore loadline Tuning to do for him).

* It comes to fruition that It seems somehow they messed up with optimizations with this update, CPU utilization spikes as the GPU Utilization Drops, while the FPS drops and the Framtimes spike.

* With our PC setups, this shouldn't happen when we play at the lowest settin
gs at low Resolutions. Even switching to higher settings fixes nothing.
 
MAY HAVE FOUND THE CAUSE!:

*I've noticed every single time I have a Stutter you can see my CPU utilization shoots up randomly; Now, typically this happens in general with OBS on since it uses the CPU to encode while recording. But, the issue did occur previously without OBS on (so I should only be partially crazy). But, it seems whatever may be causing an issue with CPU / RAM utilization could be the culprit.

I'm going to run a program and only that program from reddit.com/r/Tronscript called "Process Killer" and leave OBS and any other recording software off and see if the issue happens anymore. I also plan on leaving my CPU on the base clock at @4.7Ghz but on all Cores. CPU OCs can sometimes hate XMP profiles for RAM and cause weird 'allocation?' problems if I recall at least.

 


Video of the issue: https://youtu.be/KZvziSnEfc8
 
EDITS ARE *'ed

Since Season 3 has released a lot has been going on I wanted about 100+ games to judge the map (I don't like it other than the Cities and the Sorting Factory, sorry! Hopefully, KC comes back into circulation). Tried out maining a different Legend for some spice in gameplay.
 
BUT, one thing is driving me * insane more than any new Meta, my feelings about the map, etc. it is that my game is constantly having an issue either we sudden spikes in Frametime, frame skipping, and occasionally obvious FPS dips. I thought maybe I was going crazy; but, video evidence shows this happening way too often.
 
I'm honestly at a relative loss on how to fix the issue. It's only gotten me killed very few times. But, playing like this makes everything just feel jerky when you are in control. Watching it back doesn't 'feel' as bad since I'm just reviewing it. But during live gameplay, it's agitating and sometimes disorienting / headache-inducing when bad enough (usually doesn't get that bad).
I'm not even sure what else to try anymore; But, I am open to suggestions.
 
My Computer Hardware: *'s added
  • CPU: i7 8700k @4.8 GHz / @4.7GHz
  • GPU: GTX 1080 FTW GAMING 08G-P4-6286-KR With or Without +50MHz Core Clock, +300 MHz Memory Clock, Power Limit 120 %, Temp Limit 92 C *(My Temps are okay this is just the temp limit)
  • RAM: 16 Gb Corsair Vengeance LPX, XMP @ 3000 MHz
  • Motherboard: Z370 AORUS Gaming 7 (All chipsets, Drivers, and BIOS up-to-date)
  • Monitor: Acer Predator XB271HU
Game Settings:
  • Display Mode: Full Screen
  • Aspect Ratio: Native 16:9
  • Resolution 1280x720p
  • Field of View: 94
 
  • V-sync Preferred off (tried different for testing purposes)
  • Anti-aliasing: None
  • Texture Streaming budget: Preferred 6GB, (tried all options already)
  • Texture Filtering: Preferred 16x (tried different options)
  • Ambient Occlusion: Disabled
  • Sun Shadow Coverage: Low
  • Sun Shadow Detail: Low
  • Spot Shadow Detail: Disabled
  • Volumetric lighting: Disabled
  • Dynamic Spot Shadows: Disabled
  • Model Detail: High
  • Effects Detail: Low
  • Impact Marks: Low
  • Ragdolls: Low
 Things I've tried Already: *'s added
  • Disabled Overlay in Origin.
  • Disabled Overlay in Apex Properties.
  • Disabled G-sync on my Acer Predator XB271HU
  • Ensured my XB271HU wasn't using ULMB. (Nvidia Control Panel & Acer OSD)
  • Turned down the 165Hz/Fps OC to the base 144Hz/Fps on my monitor.
  • Turned on and off V-Sync (in-Game and Nvidia Control Panel)
  • Turned on and off Tripple Buffering. (in-Game and Nvidia Control Panel)
  • Set a FPS cap to 60fps, 120fps, 144fps, 165fps. (In Nvidia Control Panel and Rivatuner)
  • Turned Off MSI AfterBurner and RivaTurner
  • Reverted CPU and GPU OCs
  • Used a guide about correcting EAC for Apex just in case that was messed up somehow hindering performance
  • Display Driver Uninstaller Each Display Driver Reinstall, in Safe Mode.
  • Reinstalled Nvidia Game Ready Driver (436.48 | 436.30 | 436.02 | and 419.35 )
  • Windows Game Mode (off and on)
  • In Nvidia Control Panel set to let 3D Application Decide everything / Managed the 3D application Settings myself in depth with multiple configurations with and without different option on / off such as Low latency, Gsync, ULMB, Vsync, Tripple Buffering, Threaded Optimization, Preferred Refresh Rate, Power management Mode, and Open GL renderer.
  • Ensured my Windows Power management settings.
  • Tried different 'Compatibility' options for the Apex .exe like DPI scaling, run as admin, and disable fullscreen optimizations
  • Played around with Apex Video Settings
  • Game bar has and will always stay off.
  • Repaired Apex on three different occasions.

    1. When the issue started.

    2. After reinstalling Apex and the stutters kept occurring.

    3. Lastly, when I deleted all EAC files from my computer and from the Apex folders

  • OBS is in the background when I want to record for the hell of it and for the proof. However, even when OBS is not active this still occurs.
  • Stutters occur with and without the ApexOvertrack Application
  • Nvidia Shadowplay is not active, Not even turned on and not recording.-
  • * My Game has and always will be on an SSD, but it is NOT my OS SSD. The path I've set for Apex has always been (F:\Program Files (x86)\Origin Games\Apex)
  • * My operating System is also installed on it's on SSD, my C:\ Drive of course
  • * SSD's firmware is up to date.
Message 1 of 4 (1,623 Views)
Highlighted

Re: [PC] Apex Legends S3 Update, Frametime / Frame skipping / Framerate FPS Issu

[ Edited ]
★★ Novice

I have almost the same config. At Kings Canyon, I was able to play with 144 frames from the release. With each subsequent patch I noticed that there are small drops and this step I had to play with additional settings to get full smoothness and it worked out until the Voidwalker patch ... The day before NVidia released a new driver that gave a huge boost to performance, however, Voidwalker Event caused that we returned to the state "from before the patch", and it was even a little worse.

I did all the things you wrote and probably more - nothing helped. In places on the map where the game gives 144 frames and the set limit of 120 FPS @ 120 Hz frames are still lost and stutter is visible with vsync enabled ...

 

When I saw what the new map looks like, I was sure that there would be problems with the number of FPS and ... I was not wrong, the game will manage to keep 144 frames, however, being on the ship 80 frames appear on RivaTuner graph. It was 130 on average at Kings Canyon and I was very happy with it. At the moment, to play comfortably at 1080p I had to set the cap at 120Hz and the same number of frames in the game. The graph in RivaTuner still shows that the frames are lost and the image is often not smooth - I am a fan of VSync and turn it on as much as I can, Unfortunately, the comfort is no longer the same, yesterday for the first time I saw a drop to 60 frames in the building where were 3 teams(lots of grenades, Bangalore smoke & ultimate) and I felt like I was playing on much worse computer...

 

... back to "worse" computer. My friend has Sandy Bridge and GTX1060 and just like at Kings Canyon he could play with stable 80 to 100 frames. Now he's struggling with 60 FPS with drops to 40 using 1600x900 resolution. As a result, he loses the will to play Frown

 

I think that a free game focused on a large number of players and micro-transactions can not afford to let players with a weaker (?) computer could not enjoy the game. Especially since it was shown that it can be done without a problem

Message 2 of 4 (1,534 Views)
Highlighted

Re: [PC] Apex Legends S3 Update, Frametime / Frame skipping / Framerate FPS Issu

[ Edited ]
★★★★ Novice

I plan on trying to set my MSI Afterburner to log my files for tonight but it can be finicky sometimes.

Even with the Polling set to 100ms it somehow still doesn't show the frame times spiking But does seem to capture the FPS dips somewhat accurately. I'll see if it lets me set it lower to like 50ms or so and see what type of graph I get and I'll see about posting it along with the videos if I upload them to show it skipping, slowed down quite clearly so it's visible.

EDIT: Of course the night I try to plot a graph if it manages to pick anything up I have no issues that night - 10/07/19 PM - 10/08/19 AM

Message 3 of 4 (1,512 Views)
Highlighted

Re: [PC] Apex Legends S3 Update, Frametime / Frame skipping / Framerate FPS Issu

★★★ Novice

I had the same issue, resolved by lowering my screen refresh rate to 100Hz, sad but the game became smooth af.

 

Was looking about a fix to get back to 144Hz until I saw your post...

 

Config: Config : I5-7600 / RTX 2070 Super / 16go RAM

Message 4 of 4 (1,015 Views)
Twitter Stream