Help us improve Answers HQ! Take Survey No, Thanks

Need for speed: You'll need to upgrade to -- (10.0) or newer to play.

by DeZauberius
Reply

Original Post

Highlighted

Need for speed: You'll need to upgrade to -- (10.0) or newer to play.

★★ Newbie

HI

 

 

I'm getting the following message whenever i try to install need for speed heat:

 

PLEASE CHECK YOUR OPERATING SYSTEM
We're sorry, Need for Speed™ Heat Deluxe Edition will not run on your current operating system. You'll need to upgrade to -- (10.0) or newer to play.

Help us improve Origin by submitting an error report.

 

I have checked, that i'm not running compability mode and my OS is win 10 with all updates  installed. same with nvidia.

 

any ideas?

Message 1 of 3 (243 Views)
Highlighted

Re: Need for speed: You'll need to upgrade to -- (10.0) or newer to play.

Community Manager

@DeZauberius 

 

That is odd, can you please generate a Dxdiag report and then post that here?

 

https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/

 

Thanks.

 

 

Stay and Play.png
Message 2 of 3 (218 Views)
Highlighted

Re: Need for speed: You'll need to upgrade to -- (10.0) or newer to play.

[ Edited ]
★ Guide

you could check

C:\Users\[yourwindowsusernamehere]\AppData\Local\Origin\Logs\Bootstrapper_Log.txt

or 

C:\ProgramData\Origin\Logs\Bootstrapper_Log.txt

if your origin is older

scroll down and if the latest 
event url line is something like this

12: [Jan 18 05:13:22] Event URL: https://api1.origin.com/autopatch/2/upgradeFrom/10.5.59.36848/en_US/PROD?platform=PCWIN&osVersion=10.0.####&servicePackVersion=#.#

Origin should let you download and play the game as long as you have a 64bit system from windows 7 and up


If it's reporting 6.1, origin is thinking you're on windows 7, 6.0 is vista, 6.2 is Win 8, 6.3 is Win 8.1, 6.4 is pre-release windows 10
 

you could also open start menu and type winver (search) to run winver.exe  which should tell you what your specific build of windows is

Message 3 of 3 (191 Views)
Twitter Stream