Help us improve Answers HQ! Take Survey No, Thanks

Re: Mission loading screen freezes at 90-95%

by Zarelious
Reply

Original Post

Re: Stuck on loading screen for expedition

★★★★ Novice

@SofaJockeyUK wrote:

@Malumumbra wrote:

So I finnaly was able to get the game loaded up and ran through the main area, but when I tried to load an expedition it brought me to a loading screen and hasn't changed for 10 minutes. At one point it loaded, I went to move and it popped me on another load g screen to which it stayed. Is anyone else having this issue, I'm on an xbox one. 


Yes, it's being referred to as the '95% load bug', you get 95% of the way through loading (the bar at the top) and then it stops.

 

The bug is known about and is being worked on and there is a workaround that solves it most of the time.

 

Quit the game with the Xbox button and reload it.

 

The game asks if you want to rejoin the mission, say you do and you should complete loading,

(apparently, you have up to 2 minutes to reload for the 'load save' to be retained)


@SofaJockeyUK 

 

And what about those who don't even get this option to pop up? When I exit the application and restart, it just pops me back into Tarsis Hub and I have to meander my way back to my suit, just to get stuck at the loading screen again.

Message 351 of 760 (208 Views)

Re: Not Loading Into Missions or Freeplay

★★ Novice

Yeah, that fix does not work for xbone.  I am totally aware that issues arise when a "live service" game launches a beta or demo for the first time to a very large number of people....but maybe more devs and publishers should have MORE tests and offer them to MORE real people from all over the world at the same time rather than a limited amount of selected people and/or internal testing.  Almost all games launch nowadays with issues for some reason, but it has been 24+ hours and I still cant do *.  I know they will fix it, but I have limited time to play the demo.  I sure hope the real launch later this month isn't flubbed up like this or they will get super backlash right off the bat.  That is not a good thing to start with for a new IP.  EA is f'ing up everything these days with certain decisions they are making and it seems due to money.  

Message 352 of 760 (153 Views)

Re: Stuck at Loading Screen - Anthem (PC)

★★★★ Novice
I was able to load in without no problem after reinstalling origins! 
Message 353 of 760 (1,119 Views)

Re: Not Loading Into Missions or Freeplay

★★★★ Novice

My copy finally asked me if I wanted to reload into an expedition. Something it had not done the uncounted times before. ....

 

Oh and now it says "Connection Problem: Error retrieving Anthem live service data"

 

Welp, thought I was going gto be able to play but it looks like a firm "No" now.

Message 354 of 760 (144 Views)

Re: Stuck on loading screen for expedition

★ Apprentice

After SEVERAL HOURS of trying to do the first mission, I managed to do it, and then got stuck all over again.  The issue on all platforms seems to be a bug with Matchmaking - every time you launch, it wants to put you in a squad, and then ILS kicks in almost constantly...

 

EA should try setting Matchmaking to "opt-in" instead of default for all activities.

Message 355 of 760 (150 Views)
Highlighted

Re: Mission loading screen freezes at 90-95%

★★★★ Novice
Verifying did absolutely nothing, guess i just have wait till they fix it.
Message 356 of 760 (295 Views)

Re: 95% loading screen attacks again.

★★★★ Novice
What worked for me just to get in and get a feeling of the game was to go on the mission, press quickplay, load it, get stuck, kill the process on task manager and start it right away and it would send you to a mission.

Difference is, if you start a regular mission you might start it alone while quickplay you fill the spot missing on a team, so the method listed there might no give any result. Try quickplay, it worked every time but I didn't want to play that way.
Message 357 of 760 (157 Views)

Re: Anthem demo Stuck on loading screen (PC)

★★★★★ Newbie

So I can maybe help out a few people here, I had a similar issue for a couple hours trying to restart and go back though only to be stuck again. I even tried changing my dns from the free prim:1.1.1.1/sec:1.0.0.1 back to my original because I read somewhere that it had to do with the servers connection. I'm not sure if it helped or not, but after once trying to rejoin the same session (didn't work) then the very next try when it asked if I wanted to rejoin the old session, I hit no instead and have had success actually going into expeditions. Just to put the info out here. Wish you all the best of luck. (Xbox one user)

Message 358 of 760 (1,064 Views)

Re: Stuck on loading screen for expedition

★ Apprentice

The close game, restart does work, BUT there is a but. If you are in a party, and lets say two ppl, and that other also has to, your no longer in a party. It's a big pain in my view, and I wouuld rather have 20+ more GBs placed into my PC to greatly help the load process.

Message 359 of 760 (126 Views)

Re: Stuck on loading screen for expedition

★★★ Apprentice

Same here. The supposed fix doesn’t work for me.

Message 360 of 760 (126 Views)

fifa-18-promo-circle

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

all-ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help