Help us improve Answers HQ! Take Survey No, Thanks

Massive fps drop season 7

by MrTux
Reply

Original Post

Massive fps drop season 7

★ Guide

Hello, here is my problem:

 

My apex always runs in full 60 FPS on all maps, but when I go to Olympus, there are areas that are filled with grass which make me go to 40 FPS and it's very annoying ... I drop ONLY when going to grassy areas.See screenshot

Apex Legends Screenshot 2020.11.05 - 18.27.40.jpg

I hope you can help me...

Thank you

 

My config: GTX 1060 6gb

I5 4460

8gb of ram DDR3

Message 1 of 219 (13,667 Views)

Re: Massive fps drop season 7

Community Manager

Hey @MrTux 

 

Thanks for reporting this, we can pass what you're experiencing along to our team. In order to help us now, we can recommend trying a few things to help see if we can keep your FPS at 60. 

 

  • Check for Windows and GPU updates
  • Try adjusting in-game settings
  • Run Origin and Apex as an administrator (by right-clicking desktop icons and selecting 'run as admin")
  • Disable Origin in-game overlay 
  • Trying closing other applications or overlays running
  • Allowing Origin and Apex through your anti-virus or firewall
  • Clear Origin Cache 
  • Clean Boot 
  • Origin - Repair the game | Steam - Verify game files
Illium.png

*Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
*Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
*XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.
Message 2 of 219 (13,627 Views)

Re: Massive fps drop season 7

[ Edited ]
★ Guide

Hello, thank you for your reply!


I have already tried most of the solutions you offer me but nothing helps, even if I lower my graphics settings to the bottom, my fps also drop ...
I think there must be optimization issues on olympus because fps drops are not present on all grass areas but in some places ...

Message 3 of 219 (13,622 Views)

Re: Massive fps drop season 7

Community Manager
@MrTux Thank you for going through the steps, If I have anything to update about what's going on I will. To check since this started has any error been generated or is it just the dip happening?
Illium.png

*Accept as Solution button- If a post answers your question please let us and other players know by hitting this button.
*Me Too button - 'Me Too' helps us track how many players are also experiencing that issue. Definitely make use of this button.
*XP button - Say Kudos and help players 'Level Up' by giving them XP for helpful posts.
Message 4 of 219 (13,605 Views)

Re: Massive fps drop season 7

[ Edited ]
★ Guide

@EA_Illium the problem started in season 7 since that's where the new map arrived , this problem is only on the olympus map.

I think the problem must come from the map because I have never had such a problem in other seasons

(I may have answered your question incorrectly, I use Google translate.) :

Message 5 of 219 (13,566 Views)

Re: Massive fps drop season 7

★★★ Novice
This also happens on the ps4, even up to 30 fps
Message 6 of 219 (13,542 Views)

Re: Massive fps drop season 7

★★★ Newbie
@MrTux @EA_Illium Me too, I have the exact same issue.Its really annoying especially in combat
Message 7 of 219 (13,514 Views)

Re: Massive fps drop season 7

★ Guide

@cornfileyks @GSkill_TridentZ 

ok so I see that the problem is not just mine, it is rather reassuring

Message 8 of 219 (13,503 Views)

Re: Massive fps drop season 7

★★ Novice

i have the same issue, exactly the same, fps drops in areas with grass in the new map.

 

all drivers updated.

 

gtx 1060 6gb

Amd ryzen 7 3700x

16gb ram

windows 10 pro

Message 9 of 219 (13,450 Views)

Re: Massive fps drop season 7

★★★ Apprentice

I am having same issue it is driving me mad! I am losing so many fights due to these FPS drops.

 

Running Win 10, Nvidia driver 457.09

i9 9900K & RTX 2080

 

Game running at 1440p normally it stays between 143 FPS and 120 FPS with dips down to 100 FPS in bottom 1% but now I am averaging closer to 100 FPS on the new map and dips down to 40-50 FPS especially in grassy areas but also in other areas on the new map as well.

 

I already tried turning ALL the settings down to lowest just leaving the resolution at 1440p and it still gives the same performance as it does with all settings maxed out on the new map (wtf?) with dips down to 40-50 FPS in the same areas.

 

I already tried the Steam version as well just to see if the Origin one was corrupted, downloaded it fresh from Steam and tried it, same identical issue. All drivers are up to date and it can't be the hardware (i9 + RTX 2080 lol!)

 

Never had this issue before on the old maps.

Message 10 of 219 (13,444 Views)
Twitter Stream