Help us improve Answers HQ! Take Survey No, Thanks

Logitech keyboard lights turn off when i load the game.

by 1losse
Reply

Original Post

Highlighted
Accepted Solution

Logitech keyboard lights turn off when i load the game.

★★★★ Novice

Any fix?

Message 1 of 8 (12,563 Views)

Accepted Solution

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Novice

-+

 

I have to G14 KB and had same annoying problem

Easy fix!

Go into the Logitech gaming software.  In settings under general tab,  go down to "game Integration"   uncheck the box that says "Allow games to control illumination"

 

 

 

 

View in thread

Message 6 of 8 (3,927 Views)

All Replies

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Novice

Same here. Running the G910 Orion Spectrum. Some keys remain lit for whatever reason on mine, however. S, E, Z, B, G, T, 4, 5, J, M, 7. No idea.

Message 2 of 8 (12,545 Views)

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Novice

Open Logitech Gaming Software. In the device section, where it shows your keyboard and other Logitech devices, scroll over until you get to the applets. Click MassEffectAndromeda. The panel on the right will give you all the lighting options it does while playing. The keys you're talking about is the Andromeda Initiative Logo ( Ai ).

Message 3 of 8 (12,529 Views)

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Novice

I have uninstalled LGS and Mass Effect but still nothing.

Once my G19s switches to the Mass Effect profile it goes black.

I even messed with the applet in LGS.

Funny thing is that the first time I played this game my keyboard did all the effects and worked perfectly. 

 

 

Please look into this EA.

Message 4 of 8 (12,493 Views)

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Newbie

Doesn't that spell ea?

 

Message 5 of 8 (4,103 Views)

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Novice

-+

 

I have to G14 KB and had same annoying problem

Easy fix!

Go into the Logitech gaming software.  In settings under general tab,  go down to "game Integration"   uncheck the box that says "Allow games to control illumination"

 

 

 

 

Message 6 of 8 (3,928 Views)

Re: Logitech keyboard lights turn off when i load the game.

★★★★ Novice

Confirmed, if the proper gaming fx aren't working for you, tihs method works in using your already setup profiles. 

Message 7 of 8 (3,916 Views)

Re: Logitech keyboard lights turn off when i load the game.

★★★ Newbie

How do you do this in 2019.7? I am having the same issue since I updated G Hub. 

Message 8 of 8 (326 Views)

me-andromeda-fem

Keep your account safe

We'll make sure it's you by sending you a code for your trusted devices.

Learn more about Login Verification on EA Help

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help