Help us improve Answers HQ! Take Survey No, Thanks

In game Ping Setting doesn't work, unplayable until I can find a fix

by RenegadeNC
Reply

Original Post

Highlighted

In game Ping Setting doesn't work, unplayable until I can find a fix

★★★★ Novice

So I posted the same thing on reddit but apparently nobody else is having this problem. The in game "ping site" setting under Options, then EA Account simply doesn't work! I have mine set to US, Virginia since i'm in North Carolina and that's the closest data center. It shows that with that data center I should have 52ms ping which I have confirmed on speedtest.net but when I play a game on any mode I get horrible hit detection and constantly die around walls and cover. After getting frustrated with it I checked Resource Monitor to see what the ping was for the SWBF2's active TCP connection and what do you know, 150-180ms every game... It always connects me to the exact same IP 159.153.38.49 which is a data center in Redwood California although it's suppose to be connecting me to Virginia. I've tried changing the "ping site" to multiple different locations but the IP it connects me to and the ping are always the same. Upon restarting the game it also defaults back to the US, Virginia site but still connects me to California. Obviously support was no help, as they never are. The only advice he gave was to open ports although I explained to him that my issue was which data center it was sending me to and not whether I had ports closed or not... Anyway, at this point the game is completely unplayable and is just a * experience because the game only registers around half of my shots. Any help would be appreciated as i've already checked the settings files for the game and none of them seem to have the data center within them although it keeps defaulting back. Thanks.

 

As a side note: Yes i've checked other games and they are running just fine as i'd expect them to with around 60-80ms at the most.

Message 1 of 2 (177 Views)

Re: In game Ping Setting doesn't work, unplayable until I can find a fix

★★★★★ Novice

Despite the game set to connect to a server in Ohio. The Ohio server is 67ms. Guess what my ping to the Calif server is. It's not 67. It's much much much higher. It's not 120, it's not 240. 846ms. That's right! Sure it drops down to 160 at minimum. But most of the time it's above that.

I cannot play like this. This is the only IP I'm connecting to. Whether it's the game server or not, which I am confident it's not, being routed there is really really really bad.

I'm not the only one being routed there. Many others are being routed to 159.153.38.49. This can be found with Windows Resource Monitor. Everyone being routed to this IP, are experiencing the intense amount of lag. Unplayable lag.

Message 2 of 2 (92 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help