Help us improve Answers HQ! Take Survey No, Thanks

Great new gaminglaptop.... Very bad performance multiplayer.....

by Sausdispenser
Reply

Original Post

Highlighted

Great new gaminglaptop.... Very bad performance multiplayer.....

[ Edited ]
★★ Novice

Hello battlefield fans,

 

I have already made a post regarding this issue but for some weird reason it has been marked as spam? That is why i am making a new inquiry.

 

I have been having very bad framerates in multiplayer (both 32 and 64 player matches). And with bad  I mean BAD > Always sub 40 hitting 30 and even 20 sometimes. I have a gaming laptop with an i7 7700HQ (8 threads @ 3.8ghz) gtx 1060 6GB and 8 GB ram. I have tried numerous fixes i saw on this forum but i still have this issue. Singleplayer works perfectly fine on ultra with > 60fps. Same goes for older battlefield titles including BF1 for the multiplayer which ran perfectly fine. lowering resolution or graphics quality doesnt seem to fix this issue indicating something wrong with my CPU utilization (or a bottleneck as my CPU is at a constant 100% and my gpu 50 ish) game is installed on ssd.

 

- I have clean installed new drivers NVIDIA

- installed 1809 windows

- set NVIDIA control panel to performance mode

- Tried FFR on and of in dx 12 and 11

- Tried every other setting and combination of settings in graphics menu (fullscreen, vsync mesh quality etc etc etc) 

- Have done a clean boot of windows as sugegsted in other threads

- disabled all background programs including origin.

- tried safe boot

- have unparked my cores

- forced multithreading

- Ran cc cleaner

 

I hope some of you guys know anything i can try so this game will at least run at 60 fps. Im even ready to just lock my fps at something like 45 …...thats how desperate i am :')   but even that is not possible…... this hitching and fps drops are killing me Frown

 

plz halp.

 

yours truly.

 

Message 1 of 4 (100 Views)
Highlighted

Re: Great new gaminglaptop.... Very bad performance multiplayer.....

★★★★ Novice

The one change which fixed my fps and stuttering was to disable NVIDIA Overlay through GFE (previously Shadowplay). Hope it helps.

Message 2 of 4 (87 Views)
Highlighted

Re: Great new gaminglaptop.... Very bad performance multiplayer.....

★★ Novice

Thanks! Will try it when i get back home from uni.

 

Message 3 of 4 (82 Views)
Highlighted

Re: Great new gaminglaptop.... Very bad performance multiplayer.....

★★ Novice
nope. didnt do it.... i did just realise that while lowering clock speeds to 2.8GHZ lowers cpu usage to around 95%. and it DOES NOT LOWER PERFORMANCE. which is weird. and my GPU is used only for 5%. I am gonna make a new thread referencing this one because this is some very weird problem…..
Message 4 of 4 (71 Views)
Twitter Stream