Help us improve Answers HQ! Take Survey No, Thanks

Game will not launch, no error

by tomstian123

Original Post


Game will not launch, no error

★★★★ Novice

So, i bought myself Origin premier to try out this new Star Wars game, but the darn thing wont even start. 

I press the "play" button in origin, and the Banner for the game appears on the desktop, and there it stays, nothing happens. 

I fount out that my GPU needed new drivers, so I updated to the latest drivers, restarted the computer, and still the same thing happens when I press play in origin, a banner for the game appears, and nothing more. 

I cant shut down the banner either, as it doesnt appear in task manager, its just "there" on my desktop, doing nothing. 

I tried running the .exe as admin, still the same happens. 

I added my DXdiag notes and a snippet img of the screen. 

Never have I EVER had to download and reinstall a game before, so I hope i dont have to this time, as the current internet only gives me 5 mbps download speed. 

Message 1 of 5 (248 Views)

Re: Game will not launch, no error


Have you tried disabling antivirus software? If that solves it, make exceptions for the game and Origin folders in your antivirus settings.

I don't work for EA.

Message 2 of 5 (244 Views)

Re: Game will not launch, no error

★★★★ Novice

Yea, i just put an exception on the whole origin folder and origingames folder in the anti virus, and allowed the game in firewall settings. Still the same thing happens, the banner pops up, and thats it. Does not appear in the task manager either. 

Imma go visit my sisters house real quick, gonna let it stay like this until im back, hopefully its just a slow start the first time. 

Message 3 of 5 (227 Views)

Re: Game will not launch, no error

★★★★ Novice

Yeah so its still just the games banner showing on the desktop, nothing else, nothing in task manager. 

Message 4 of 5 (195 Views)

Re: Game will not launch, no error

★★★★ Novice


I went to its installfolder, went into properties on the .exe file, and marked it to run as admin. 

It was not enough to just sideclick / run as admin, i actually had to go into the properties and mark it that way. 

Message 5 of 5 (174 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help