Help us improve Answers HQ! Take Survey No, Thanks

Fifa 20 No Commentary

by Joelooo_A
Reply

Original Post

Re: Fifa 20 No Commentary

★★★★ Novice
@EA_Arrenai : I have the same problem on PC.
My sound settings (PC and game) are on stereo, like it should be.
Speakers : Logitech (Realtec high definition audio).
Driver is up to date.
Message 21 of 33 (1,426 Views)

Re: Fifa 20 No Commentary

Community Manager (retired)

Hey there, @sjaradona.

 

If it is set to the correct setting for your speaker or headphone type, and that you have the correct output set on the computer for the type, then let's see if it may be a setting.

 

In your volume mixer program, can you ensure that that 'voice cancellation' is not checked?

 

You'll also want to make sure in Windows that your speakers are set to stereo 2.1 if you have two speakers rather than 5.1.

 

Arrenai Cat


Did you receive an awesome, helpful response? Thumbs up +XP!

Was your issue resolved by a great post?  Accept as Solution

ASK. ANSWER. LEVEL UP.

Message 22 of 33 (1,413 Views)

Re: No Commentary on games

★★★ Newbie

Same exact issue!!

Message 23 of 33 (1,356 Views)

Re: Fifa 20 No Commentary

★★★ Newbie

Didn't work at alll 

Message 24 of 33 (1,351 Views)

Re: Fifa 20 No Commentary

★★★★★ Newbie
@EA_Arrenai Thanks so much I’ve gone days without hearing the commentators voice and wondered what was up and it seemed to work Thanks a lot
Message 25 of 33 (1,240 Views)

Re: Fifa 20 No Commentary

★ Novice

Are u referring to an in game setting or a tv setting?

Message 26 of 33 (1,128 Views)

Re: Fifa 20 No Commentary

★★★ Newbie

Hello, I'm having the issue and there's no stereo uncompressed on my TV. Pls help

Message 27 of 33 (1,096 Views)

Re: Fifa 20 No Commentary

★★★ Newbie

Me have the same problem on the ps4  what can i do?

Message 28 of 33 (1,022 Views)

Re: Fifa 20 No Commentary

Community Manager (retired)

Hey there, @snir2467.

 

Depending on how your TV and audio system is set up, you want to make sure that your TV/audio is not set up for more channels than your system has available. For example, if you only have TV audio, or just two speakers, make sure you're not on 5.1 or other multi-channel stereo. In those cases where it is, the commentary is being sent to a speaker that doesn't exist, which is why it's silent.

 

Where those settings are and what exactly to set it to are very dependent on your TV make/model and actual audio set-up. It may take some tweaking of the settings to have the best audio experience for your set-up.

 

I hope that helps!

 

Arrenai Cat


Did you receive an awesome, helpful response? Thumbs up +XP!

Was your issue resolved by a great post?  Accept as Solution

ASK. ANSWER. LEVEL UP.

Message 29 of 33 (1,013 Views)

Re: Fifa 20 No Commentary

★ Novice

Thanks that worked 

Message 30 of 33 (771 Views)
Twitter Stream