Help us improve Answers HQ! Take Survey No, Thanks

Re: Eero Router Compatibility

by Gutbutton

Original Post

Eero Router Compatibility

★ Novice

I've been having pretty significant issues with Anthem since the VIP demo. I get the same errors on both my desktop and laptop which led me to believe that it was a network issue of some sort.


  1. 95% Loading screen bug
  2. After salvaging a couple items in the forge, the salvage command is greyed out. If I exit the forge and immediately return to it - my character shows lvl 3 and all my gear is gone.
  3. Once i'm actually in a mission, things run pretty smooth. Once the mission ends I often times get a connection error and lose the loot I obtained.
  4. When I log into the game my character level in the upper left shows as lvl 1

Here is what i've tried so far


  • Uninstalling/reinstalling
  • Port forwarding (You can't set a range of ports with the eero, you have to enter them one by one)
  • Turning off firewall

I found a  thread on reddit where people with a eero are having the exact same issues that i'm describing. All my other EA games work perfectly fine - Apex, Battlefield, Madden, etc...


I hope there is a fix soon, i've grinded to lvl30 despite these issues but they seem to be getting worse, making the game virtually unplayable. 

Message 1 of 9 (199 Views)

Re: Eero Router Compatibility

★★★ Novice

I have an Eero and Anthem crashes a lot.  It has nothing to do with the Eero though.   It's the same "Error retrieving pilot data" that a lot of people are getting. Just check the previous post in this forum and you will find them.  It something server side that the Devs have to fix.

Message 2 of 9 (194 Views)

Re: Eero Router Compatibility

★ Novice

Okay great, thank you! I've never actually seen an error like that pop up, but yeah, sounds about right. I'll just sit back and wait for a fix. Thank you for the info kind sir. 

Message 3 of 9 (191 Views)

Re: Eero Router Compatibility

[ Edited ]
★ Novice

I have the exact same issues as you described and I have an eero and am sure it's the problem and I think you can set range on eero I put the the first port on external and the the second on internal but not sure that's how it's done.
but still same issue the solution I did is just by playing from my iPhone wifi Hotspot since I have unlimited data package but it's sucks I want to be able to play normally with my Lan Cable cause it's faster  

Message 4 of 9 (176 Views)

Re: Eero Router Compatibility

★ Novice

Okay yeah, I think you're right. Took my laptop to Starbucks, worked just fine. Tried the hotspot from my phone, also worked. 

Message 5 of 9 (166 Views)

Re: Eero Router Compatibility

★ Novice

Any known solutions yet?  I have worked around my eero routers for the time being, but I really don't want to replace my whole network setup over the issue.

Message 6 of 9 (142 Views)

Re: Eero Router Compatibility

★★★★★ Apprentice

I don’t have an eero router and I am having ridiculous connectivity issues. So I don’t think it is eero, but it may be something to do with routers. I’m running an asus

Message 7 of 9 (137 Views)

Re: Eero Router Compatibility

★★ Novice

Same exact issues although i have bad cell service in my house so tethering doesnt even work 

Message 8 of 9 (116 Views)

Re: Eero Router Compatibility

★ Novice

On PS4 and I too can’t play the game when connected to my eero router. If I plug directly into the AT&T U-verse router, the game’s network connection is quite stable. Both are type 2 NAT. 

Message 9 of 9 (111 Views)
Twitter Stream


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help