Help us improve Answers HQ! Take Survey No, Thanks

Re: 0x887A0005-DXGI_ERROR_DEVICE_REMOVED error

by ClapMyAssExodus
Reply

Original Post

Highlighted

Re: 0x887A0005-DXGI_ERROR_DEVICE_REMOVED error

[ Edited ]
★★★★ Novice

**FIX**

 

https://answers.ea.com/t5/Technical-Issues/0x887A0005-DXGI-ERROR-DEVICE-REMOVED/m-p/7455118#M9175

 

Since your AMD roll back a couple drivers and try.... Most likely will fix it..

Message 21 of 74 (1,896 Views)

Apex Legends crash and connection issues on PC

[ Edited ]
★★★ Novice

Apex crash PC.
0x887A0005 - DXGI_ERROR_DEVICE_REMOVED crash every game.. rtx 2080ti, i9-9900k, z390-.. etc..
Tried everything.
Also getting "disconnected" after every match and then unable to connect to EA servers for 20-30 min before getting in again, this has been going on all day (first day playing the game). 
None of my stats/wins have counted all day either. (doesn't really matter though) 
I have no issues in any other games or applications, never had any issues before. 

Message 22 of 74 (1,572 Views)

0x887A0005 - DXGI_ERROR_DEVICE_REMOVED

★★★ Novice

I keep crashing mid game with one of these two errors every time:

this:

CreateTexture2d failed for Gfx_Textureasset_RezizeAndCopy on '(no debug name)' with HRESULT 0x887a0005 width: 1024 height 1024 mips: 11 imgFormat: 0x00000050

or this: 

0x887A0005 - DXGI_ERROR_DEVICE_REMOVED

It also takes me 20-30min between each game to connect to the EA servers. When i do finally get to actually finish a game, it crashes straight out and won't reconnect. 

Tried every solution i could find on these forums and online, i have no issues in ANY other game or application than in Apex Legends. It's not a Origin issue either, cuz i run BFV just fine without any issues ever. 

Message 23 of 74 (1,766 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

★★ Novice

me to

 

dxgi_error_device_hung

 

dxgi_error_device_removed

 

Only Apex Legends !!!!! Shitt !!!!

 

 

My System 9900k RTX 2080 Ti

Message 24 of 74 (1,975 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

★★★★ Novice

i just posted a fix. please read the other replies 😐

Message 25 of 74 (1,967 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

★ Novice

I somehow fixed the problem by puting my texture filtering from anisotropic 16x to 2x at first I thought it was my drivers but no.. Thought that it could help.

Message 26 of 74 (1,964 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

★★★★ Novice

@lpjProd wrote:

I somehow fixed the problem by puting my texture filtering from anisotropic 16x to 2x at first I thought it was my drivers but no.. Thought that it could help.


thats just graphics overload on your part. lmfaoo. 

Message 27 of 74 (1,956 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

[ Edited ]
★ Apprentice

delete

Message 28 of 74 (1,900 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

★★★★ Novice

@jamezz233 wrote:

The exact same 2 errors I get too brother... I am also on the 9900k 2080ti. New build for me but I’ve played about 3 hours of overwatch with no issues, I have only played about 6 games of apex, completed about 2 of them

 

I really hope they get this figured out before this weekend... 


none of you guys ever read the replys. just read the replys. i already found a fix

Message 29 of 74 (1,896 Views)

Re: DXGI_ERROR_DEVICE_REMOVED.

★★★★ Novice

I am also getting that error on a 2080 TI with the driver 418.91 and the one before that.

 

Temporary solution that worked for me:

Going back to 417.71 fixed the problem for now, although that means I wont get the optimizations for Anthem.

 

Heres to hope Respawn/nvidia fix this soon.

Message 30 of 74 (1,883 Views)
Twitter Stream