Help us improve Answers HQ! Take Survey No, Thanks

Cutscene freezes / Background loader stops working

by beepzen
Reply

Original Post

Highlighted
Accepted Solution

Cutscene freezes / Background loader stops working

★★★★ Novice

Product: Mass Effect Andromeda
Platform:PC
What edition do you have? Deluxe Edition
Physical Disc or Digital version? Digital Based Install
Summarize your bug Some cutscenes freeze / stutter. After that, the background loader fails to load assets (sound/textures). Immediate result: Cutscenes will not play out properly (no one talking, thus halting). If skipable, game can be played past that moment but textures and sound do not continue to load. Saving and reloading fixes this. (Happened after Eos vault completion) However, if the dialogue is not skipable, the game gets stuck waiting for the sound to play. Can not choose any dialoge option. Can not progress the game further. (Happened after Eos outpost deployment) Reloading/restarting does not fix the problem. This did not happen before the patch, all of it. No stuttering cutscenes, no sounds/textures not loaded.
How often does the bug occur? Every time (100%)
How long has this issue been happening? Happening since the last patch
Please select your region Europe
Run the www.speedtest.net network benchmark and post your upload and download speeds.
What company provides your internet service?
Steps: How can we find the bug ourselves? Investigate background loading, check if there are failsaves for stalled background loader.
What is the AMD or Nvidia Model Number of your graphics card? GTX 780
Please enter memory size in GB. 8

Some cutscenes freeze / stutter. After that, the background loader fails to load assets (sound/textures). Immediate result: Cutscenes will not play out properly (no one talking, thus halting). If skipable, game can be played past that moment but textures and sound do not continue to load. Saving and reloading fixes this.
(Happened after Eos vault completion)


However, if the dialogue is not skipable, the game gets stuck waiting for the sound to play. Can not choose any dialoge option. Can not progress the game further.
(Happened after Eos outpost deployment)

Reloading/restarting does not fix the problem.

This did not happen before the patch, all of it. No stuttering cutscenes, no sounds/textures not loaded.

Message 1 of 7 (3,097 Views)

Accepted Solution
Highlighted

Re: Cutscene freezes / Background loader stops working

★★★★ Novice

Soooo... I found the root of the problem.

 

The background loader fails to load some speech files, because, well, they're not there. The reason for them being missing seems to be the following. I play the game with english voices, but this was set ingame, not in the origin launcher. Upon changing the language in the launcher and not ingame, Origin proceeds to download an additional 35 MB of ... voice files I guess. After downloading and installing is complete all the freezes I saw (both on Eos) stopped freezing, had voices again, textures loaded, could continue the game. Seems the patch broke those files for other languages than the one set in Origin itself.

 

@IGuerilla_Phil Let me know if that helps you, too.

 

That is some crappy exception handling on your part, @Bioware :/

View in thread

Message 4 of 7 (3,748 Views)

All Replies
Highlighted

Re: Cutscene freezes / Background loader stops working

[ Edited ]
★★ Novice

My game freezes:

 

1) during the cutscene after the prologue (the introduction of the archon / landing of the hyperion on the nexus) but loading a prior save fixed it.

2) during the cutscene after finishing the vault on Eos, loading a prior save doesn't fix it so I'm stuck and can't continue the playthrough.

 

Didn't have any issues like that prior to the patch. Also repairing the game via Origin didn't fix it.

Message 2 of 7 (3,075 Views)
Highlighted

Re: Cutscene freezes / Background loader stops working

★★★★ Novice

I have recognized that MEA creates crashdump files at the exact time this occurs. They're located at the User\Documents\BioWare\Mass Effect Andromeda\Temp directory. Can't get a lot out of it, all seem to refer to some memory access violation.

 

FAULTING_IP: 
MassEffectAndromeda+34da69
00000001`4034da69 8b480c          mov     ecx,dword ptr [rax+0Ch]

EXCEPTION_RECORD:  ffffffffffffffff -- (.exr 0xffffffffffffffff)
ExceptionAddress: 000000014034da69 (MassEffectAndromeda+0x000000000034da69)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 000000000000000c
Attempt to read from address 000000000000000c

PROCESS_NAME:  MassEffectAndromeda.exe

ADDITIONAL_DEBUG_TEXT:  

Use '!findthebuild' command to search for the target build information.

If the build information is available, run '!findthebuild -s ; .reload' to set symbol path and load symbols.

FAULTING_MODULE: 00007fff3ef20000 ntdll

DEBUG_FLR_IMAGE_TIMESTAMP:  58dd607e

ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  000000000000000c

READ_ADDRESS:  000000000000000c 

FOLLOWUP_IP: 
MassEffectAndromeda+34da69
00000001`4034da69 8b480c          mov     ecx,dword ptr [rax+0Ch]

FAULTING_THREAD:  000000000000ac6c

DEFAULT_BUCKET_ID:  WRONG_SYMBOLS

PRIMARY_PROBLEM_CLASS:  WRONG_SYMBOLS

BUGCHECK_STR:  APPLICATION_FAULT_WRONG_SYMBOLS_NULL_CLASS_PTR_READ

IP_ON_HEAP:  0000000023da7280
The fault address in not in any loaded module, please check your build's rebase
log at \bin\build_logs\timebuild\ntrebase.log for module which may
contain the address if it were loaded.

FRAME_ONE_INVALID: 1

LAST_CONTROL_TRANSFER:  from 0000000023da7280 to 000000014034da69

STACK_TEXT:  
00000000`4dacf900 00000000`23da7280 : 00000000`1ed81398 00000000`4dacf988 00000000`23da7280 00000036`00000003 : MassEffectAndromeda+0x34da69
00000000`4dacf908 00000000`1ed81398 : 00000000`4dacf988 00000000`23da7280 00000036`00000003 00000000`00000000 : 0x23da7280
00000000`4dacf910 00000000`4dacf988 : 00000000`23da7280 00000036`00000003 00000000`00000000 00000001`42c41e08 : 0x1ed81398
00000000`4dacf918 00000000`23da7280 : 00000036`00000003 00000000`00000000 00000001`42c41e08 00000001`00000001 : 0x4dacf988
00000000`4dacf920 00000036`00000003 : 00000000`00000000 00000001`42c41e08 00000001`00000001 00000001`44369128 : 0x23da7280
00000000`4dacf928 00000000`00000000 : 00000001`42c41e08 00000001`00000001 00000001`44369128 00000000`00000000 : 0x36`00000003


SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  MassEffectAndromeda+34da69

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: MassEffectAndromeda

IMAGE_NAME:  MassEffectAndromeda.exe

STACK_COMMAND:  ~35s; .ecxr ; kb

BUCKET_ID:  WRONG_SYMBOLS

FAILURE_BUCKET_ID:  WRONG_SYMBOLS_c0000005_MassEffectAndromeda.exe!Unknown

WATSON_STAGEONE_URL:  http://watson.microsoft.com/StageOne/MassEffectAndromeda_exe/1_0_0_0/58dd607e/MassEffectAndromeda_exe/1_0_0_0/58dd607e/c0000005/0034da69.htm?Retriage=1 

 This shows some part of the game crashes, may be it helps to further locate the problem.

 

Also I have tried repairing the game in the meantime, switched settings to low, turned on VSync - no changes. 

Message 3 of 7 (3,067 Views)
Highlighted

Re: Cutscene freezes / Background loader stops working

★★★★ Novice

Soooo... I found the root of the problem.

 

The background loader fails to load some speech files, because, well, they're not there. The reason for them being missing seems to be the following. I play the game with english voices, but this was set ingame, not in the origin launcher. Upon changing the language in the launcher and not ingame, Origin proceeds to download an additional 35 MB of ... voice files I guess. After downloading and installing is complete all the freezes I saw (both on Eos) stopped freezing, had voices again, textures loaded, could continue the game. Seems the patch broke those files for other languages than the one set in Origin itself.

 

@IGuerilla_Phil Let me know if that helps you, too.

 

That is some crappy exception handling on your part, @Bioware :/

Message 4 of 7 (3,749 Views)
Highlighted

Re: Cutscene freezes / Background loader stops working

★★ Novice

Didn't work for me at first.

What actually worked for me was deleting the patch folder in the main directory and then repair the game via Origin, then setting the language in the launcher.

 

Thanks! I hope we can continue our playthroughs without more gamebreaking bugs.

Message 5 of 7 (3,000 Views)
Highlighted

Re: Cutscene freezes / Background loader stops working

★★★★ Novice

Great to hear!

 

I hope so too, have fun in space!

Message 6 of 7 (2,975 Views)
Highlighted

Re: Cutscene freezes / Background loader stops working

★★★ Novice

meh mine is on ENglish for origin and still stuck on loading screen when leaving EOS 

 

Message 7 of 7 (2,744 Views)
Twitter Stream