Help us improve Answers HQ! Take Survey No, Thanks

Re: Anthem Turns Purple in Full Screen

by Xeos-Noceo
Reply

Original Post

Re: Need Option To Disable HDR Or I Can't Play

★★★★★ Apprentice
Same issue here b6 oled
Message 41 of 68 (649 Views)

Re: Anthem Turns Purple in Full Screen

[ Edited ]
★★★★ Apprentice

Having the same issue.  Tried everything suggested here to no avail. Really hoping they get this purple nightmare figured out.  

Running it with...

i5 9600k, 1080 x2 sli, 32gb ram, on a Sony x900f.  

Message 42 of 68 (669 Views)

Re: Anthem Turns Purple in Full Screen

★★★ Novice

I'm having a similar issue that the screen is going black when the game triggers Dolby Vision and nothing fixes it. The game is unplayable in it's current state on my LG C8 tv.

Message 43 of 68 (651 Views)

Re: Need Option To Disable HDR Or I Can't Play

[ Edited ]
★★★★ Novice

Try to disable HDR in Windows and change resolution to 1080p in game.  

Message 44 of 68 (647 Views)

Re: Need Option To Disable HDR Or I Can't Play

★★★ Novice
So after I posted my fix that worked for me... It just stopped working today when I tried it

What is going on.
Message 45 of 68 (639 Views)

Re: Anthem Turns Purple in Full Screen

★★ Novice

LG C7 here same issue. 

Message 46 of 68 (627 Views)

Re: Anthem Turns Purple in Full Screen

★★★ Newbie

Same issue here since the VIP. Still happening in release version.

 

TCL 55P605 as my third monitor. GTX 1080. Through Pioneer Elite receiver (don't recall the specific model but one with full 4k, HDR, and Dolby Vision support)

 

Can't run the game fullscreen at 1440 or any variation of 4k (not that my card could even handle it if i wanted) without the pink artifacted visuals as it attempts to trigger HDR.

I can run 1080p fullscreen and it clicks over to Dolby Vision. Works in a pinch but I'd rather not be limited to that. Dolby Vision's implementation in this game, frankly, looks awful. With overly bright/contrasted and oversaturated hotspots wherever there are bright light sources, especially in otherwise well-lit areas.

 

I've tried just about everything I'm willing to do to address it. Disabled Windows' HDR features, changed output color settings and dynamic range in NVIDIA Control Panel, tried every combination of tabbing, maximizing, plugging and unplugging, shifting screens around my monitors, etc. I'm not digging through config files (though if there's a simple line I can change, I'm all ears) or trying to disable it on my TV for this one game. Especially considering upon further research it appears to be an ongoing issue with Frostbite games.

 

And I've seen the official BioWare response that a toggle is coming on the 22nd. A couple of thoughts about that:

  • A toggle is not a solution. It's the absence of one. I would actually like to play this game in HDR like the console versions, not just turn it off. I have a hard time believing a world-class AAA dev in 2019 can't figure out PC HDR. If Bungie figured it out two years ago in their first PC release since 2004, you can too.
  • Why is this or any other fix scheduled for the 22nd not already in the game? You can't tell me this patch was still in the process of finalization or passing cert or whatever. If so, this whole thing was even more rushed than I thought. It feels like this subscriber early access and the VIP demo were complete afterthoughts.
Message 47 of 68 (600 Views)

Re: Anthem Turns Purple in Full Screen

★★★★★ Newbie

I have a GTX 1080 and a Samsung 4k monitor, and here's how I get around the purple screen:

 

I default to Borderless Window.

Set resolution to 1920x1080.

Switch from Borderless window to Fullscreen and accept changes...for me this changes the colors to a washed out, low contrast version of the proper colors.

Switch back to Borderless Window and accept changes...for whatever reason this returns the colors and sharpness to what they should be.

Its a bit of a pain, but it only takes a few seconds...for me at least it'll do until a proper fix is implemented.  Hope this helps!


Message 48 of 68 (524 Views)

Re: Anthem Turns Purple in Full Screen

[ Edited ]
★★★ Novice

Ok so I definitely solved it for myself. However it is tedious.

My solution: (I am not at my PC so this is by memory)

BEFORE YOU DO THIS!!! Make sure you set all your graphic options, keybinds etc to how you want them.

Go to "My documents/bioware/anthem/settings"
Copy "profile_options"
Edit the copied file
In the file change all fullscreen options (except the first one which I cannot recall the name) to 1 not 0 (especially "fullscreenscreen")
Set Borderless window to 0

Save your copy. Now delete the profile_options and make an ADDITIONAL copy of the file you just edited naming it "profile_options" DO NOT USE THE FILE YOU EDITED! No matter if you set the file to read-only the game will change it. You always want a backup of the file so you can simply delete the game edited version and replace it with yours because it is quicker than editing all the values each time.

Now launch the game and enjoy. However each time you exit or if you alt-tab out the game will reset your options. Meaning you will need to copy your file and replace the system updared one EVERY time... It is a tedious pain for sure.

Message 49 of 68 (515 Views)

Re: Pink and purple screen when switching to full screen, please help!

★★★ Apprentice
Thank you @EA_Cade.
Message 50 of 68 (434 Views)
Twitter Stream