Help us improve Answers HQ! Take Survey No, Thanks

Re: Venues Not Loading Properly

by DoofenshmirtzH
Reply

Original Post

Venues Not Loading Properly

★★★★ Novice

I'm having an issue with venues not loading properly when I place them.

 

The example below is just one of the issues. This is what I get when I place my Lucky Simoleons Casino. Not just in Lucky Palms, but in other worlds as well. As you can see all of the windows are wrong, as is the fountain, and the signs are completely gone. Inside everything is wrong as well.

 

It's not just the casino. All of my venues are doing something similar. The Stone's Throw Greenhouse doesn't have any of the greenhouse windows, the Plants vs. Zombies sunflowers are all replaced with something else. None of the canals come up in The Last Venue of Amore. None of the windows load for The Skylight Studio for the Performing Arts.

 

They all used to work. This is something that has just happened in I would say the last 2 - 3 months. Does anybody have any ideas on what might have happened to cause this? I'm going to try deleting them and re-downloading/re-installing them all, but if that doesn't work, are there any other suggestions?

 

Screenshot.jpg

Message 1 of 4 (270 Views)

Re: Venues Not Loading Properly

@DoofenshmirtzH  It does sound like some of your content has uninstalled itself, or maybe more accurately, the files into which the content was installed have been corrupted.  What you've described is not uncommon at all.  If a simple uninstall and reinstall of the store venues doesn't help, let me know, and I'll write out the steps for a more thorough intervention.

 

It would help to know whether you have a lot of store content overall, as in, whether it would be a hassle to uninstall and reinstall everything.  There's a way around it having to do it, but if you only have a few items, starting fresh is the more straightforward option.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 4 (258 Views)

Re: Venues Not Loading Properly

★★★★ Novice

I do have a lot of store content now. My purchase history is 25 pages long. A lot of it is stuff I bought individually and have since completed sets, but a lot of it is still just pieces here and there of incomplete sets. To sort it out would probably be a bit of a chore, so with any luck I won't have to go down that road.

 

I'm just in the process of downloading and re-installing all of the venues. It's a little late for me to test tonight once everything is installed again, so I'll give it a run tomorrow evening sometime and see if it got me anywhere.

 

I also started having the issue others have reported too about having to do the hokey pokey to designate lots to have the correct settings to place venues. I guess that also started around the same time I noticed my problems with the venues. I'm guessing it was around the time I bought a couple of expansion packs, but I can't say for sure because I didn't start any of the new worlds as soon as I got them. I was still playing old saves where I wasn't editing the towns.

Message 3 of 4 (256 Views)

Re: Venues Not Loading Properly

★★★★ Novice

Uninstalling and reinstalling seems to have done the trick. I haven't tried all of the venues, but I tested (well, permanently placed in my new world) the casino and the greenhouse and they both worked the way they're supposed to.

 

Hopefully this problem won't happen again, and if it does hopefully this is all I need to do to fix it again. At worst doing it is a mild inconvenience if it doesn't happen frequently. I've definitely had to deal with worse things in life.

 

Thanks for taking the time to check this out and offer some assistance.

Message 4 of 4 (215 Views)
Twitter Stream