Help us improve Answers HQ! Take Survey No, Thanks

Unable to make a pet in CAS

by adriballer
Reply

Original Post

Unable to make a pet in CAS

[ Edited ]
★★★★ Newbie

Every time I try to create a pet in CAS it glitches and gives me a blank white screen. I’ve tried restarting my computer and updating the game but it still doesn’t change it. I bought this game maybe at Easter and it still won’t work. Does anyone have any other ideas I just want to play the game I payed for. 

Message 1 of 2 (71 Views)

Re: Unable to make a pet in CAS

★ Pro
@adriballer

The reasons may be

1. Outdated mods and CC,
Do you have any mods and CC?
If yes:
Move the mods folder to the desktop.
Delete localthumbcache.package file in the game folder
Fix the game in Origin.
Origin/Library -right click on TS4 - option "Repair game"
You have to wait until Origin will fix all packs, not only the base game.
Turn on the game to create a new, empty mods folder and to check if a game is working now without mods and CC.
Check if there are new updated versions of the mods and CC you are using.
Then copy from desktop your mods and CC and paste it in the new mods folder. First, paste script mods one by one every time checking if the game is OK. Do the same with CC but if you have a lot of this, try the 50/50 method.

2. Computer problem - for example, too weak graphics card for this add-on.

Could you post your Computer's DxDiag?
To gather a DxDiag on your computer, please follow the steps here: https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/
You can attach the txt file to your post directly in option "Reply" - not Quick Reply

I don't work for EA
Message 2 of 2 (54 Views)
sims-four-characters

The Sims 4 Patch Notes

Check out the latest updates and bug fixes

View more on EA Help
white-sims-bg

Restore a previous saved game

Choose from an automatically stored save point in The Sims 4 if your data's corrupted or you want to revert anyway.

View more on EA Help

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help