Help us improve Answers HQ! Take Survey No, Thanks

Re: The Sims 3 will not launch through Steam

by puzzlezaddict

Original Post

The Sims 3 will not launch through Steam

★★★ Newbie

I play and installed my games through Steam. Just recently I tried to play it, but the game would not start past the launcher. I am not a computer savvy person, so excuse all of my ignorance. I feel as though I've tried everything: I tried to start the game through its files and bypass the launcher, I've followed instructions online and deleted files that caused others' issues, I've uninstalled and reinstalled both steam and Sims(1.67, by the way). I cannot really list everything I have done because I feel like I've sat for hours trying to solve it, doing various different things, to no avail. I even had help from others, and we cannot solve this.


I have seen this issue in many places where Sims 3 will say "running in tray" and will not begin past the launcher(I don't think the game is even opening up... i think it's just the launcher, but the game will not open when I try to open it through The Sims Files, either). I have no clue how to solve this, and I am pretty desperate at this point considering that  I'm reaching out for help here. I feel like I've gone through just about every post on different sites about this issue and tried all of the solutions, but nothing has worked. My computer so totally capable to run the game too, considering it runs every other game and has never had an issue with Sims until a few days ago.



Message 1 of 2 (142 Views)

Re: The Sims 3 will not launch through Steam

[ Edited ]

@victorlemorte  The launcher running in the tray issue doesn't normally prevent TS3 from opening at all, although it can be annoying.  (It's easy enough to fix, but there's no point until the game is actually working.)  First, please make sure that .NET framework 3.5 is enabled on your computer.  Hit Windows key-R and type "appwiz.cpl" without quotes into the box, and enter.  In the File Explorer window that appears, click "Turn Windows features on and off," and you'll see this:


Windows features (+.NET).png


The .NET frameworks are in the first red box, and your configuration should look like it does in the screenshot.


If this isn't the issue, try temporarily disabling your antivirus/firewall, just long enough to test.  If that's the issue, you can set an exception for TS3W.exe (with the W), and perhaps Sims3LauncherW.exe as well, although the second one usually isn't necessary.


If that doesn't work either, try launching the game while completely disconnected from the internet, as in, turn off wifi and/or pull the ethernet cable.  You shouldn't need to be signed into Steam—just launch directly from TS3W.exe inside the game's program files.  The path should look something like this:


Program Files (x86)\Steam\steamapps\common\The Sims 3\Game\Bin


If none of this helps, please run a dxdiag and attach the results to a post here.  It will cover not only hardware but things like drivers and disc space, as well as list the last 10 Windows errors, hopefully with some information about why TS3 didn't launch.


I don't work for EA. I'm just trying to help fellow players with their games.
Message 2 of 2 (129 Views)

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help