Help us improve Answers HQ! Take Survey No, Thanks

Re: Stuck on Mapview!

by crinrict
Reply

Original Post

Stuck on Mapview!

[ Edited ]
★★★★ Novice

During  gameplay , I wanted to switch households . I clicked on the family I wanted to play , but then when I tried to enter the house, the arrow turned gray and was stuck on mapview. I tried restarting my computer and my game , but no luck. I have a feeling that I have to delete all my Sims , but I really don't want to ! Is there any way to fix this without deleting all my Sims ?

 

-This problem applies to all my households in the town I mainly use, but doesn't apply to the other towns that I have

-I only have the sims 3 base game and it was recently bought

-I have custom content downloaded in my game

-I recently downloaded the newest update for the game

 

Message 1 of 2 (469 Views)
Highlighted

Re: Stuck on Mapview!

Hero

So when you restart your game, your stuck on mapview now or does it only happen when you try to switch active households ?

 

If you're stuck: Do you have a backup you could load ? The game usually makes one itself, if you save with save and not save as.

 

To restore a savegame made by EA follow this steps (credits to ModTheSims)

 

  1. Open Documents/Electronic Arts/The Sims 3/Saves.
  2. Locate the folders relating to the save you want to restore - there should be two, and they will have the name that you gave your save. For example, if the save being restored is called Sunset Valley, there will be two folders called Sunset Valley.sims3, and Sunset Valley.sims3.backup. 
  3. Rename the xxxx.sims3 folder to xxxx.sims3.old. 
  4. Rename the xxxx.sims3.backup folder to xxxx.sims3. If you get an error along the lines of "A file with the name you specified already exists.", look for a file called xxxx.sims3 - this is an old file, and you can move it somewhere else, or rename it to something like xxxx.sims3.basegame. You should then be able to rename the folder properly. 
  5. You should now be able to load your save as normal ingame. You will lose any progress since the last time the game was backed up.

If you're not stuck but can't switch:

 

1. Do you have the World Adventures EP ?

2. Do you have a Pangu's Axe in your home ? If so, make sure to move it to the family inventory.

Happy Gaming
Crin


Trennlinie


I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.

Please only contact me via PM when asked to do so.


Important Threads


Message 2 of 2 (452 Views)
sims-four-characters

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help