Help us improve Answers HQ! Take Survey No, Thanks

Re: Slow loading and lags

by kreatora
Reply

Original Post

Highlighted

Slow loading and lags

[ Edited ]
★ Novice

Hi, I've been having very similar issues, they began after the latest patch. I can launch the game, I can eventually launch a save from the welcome screen (the icons don't appear for quite some time). When I get to world view and hover over a household the icons really don't want to load but will eventually, it then takes around 15 minutes to actually launch any save I want to play. When it gets to the game it is ridiculous, can barely pause the game, let alone click on anything nor play, I've resorted to task managering my way out of the game.

 

When I started having the issues, I repaired game via origin about three times. So after some research I saved files to desktop, and the game launched brilliantly, even after I put save files back, so I downloaded Island Living, had two great days of gaming finally, and then the issues started again but much worse than before.

So I removed any gallery saves that I thought might be causing issues, backed up all I could to the gallery and completely emptied the tray folder, as well as deleting two game saves. Nothing seems to touch the issues, I've got a brand new laptop battery, so my laptop is in better health than it has been in a while, and I have no trouble with any other games I play through steam. I don't play with mods or cc so if any is present it has not been put there by me knowingly.

From what I've read I'm running 64 bit on a laptop that can handle it too and windows should be completely up to date.

 

I'm at the end of my knowledge and tether, can anyone please help?

Message 1 of 7 (164 Views)
Highlighted

Re: Slow loading and lags

[ Edited ]
★ Expert

@Gingerjuggernaut 

Probable reasons:
1.Cause - damaged files inside the game folder/ Documents.
Delete localthumbcache.package file in the game folder and fix the game in Origin.
If it will not work try doing a factory reset as is described here
http://answers.ea.com/t5/The-Sims-4/FAQ-Troubleshooting-Steps-amp-Known-Issues/m-p/3621199
2. Cause -outdated mods or CC
If you have any mods
Move the mods folder to the desktop.
Delete localthumbcache.package file in the game folder
Fix the game in Origin.
Turn on the game to create a new, empty mods folder. Check if a game is working now without mods.
Then copy from desktop your mods and CC and paste it in the new mods folder. First, paste script mods every time checking if the game is OK. Do the same with CC but if you have a lot of this, try the 50/50 method
3. Cause - connection with the internet.
Unknown program in the background that connects to the internet lowers FPS rate. It is so low, that to play is near impossible
Disconnect your internet completely and try without this.
4. Cause - problems with the computer (The computer does not meet the requirements of the game, failure Windows updates. week graphic card, outdated graphics card drivers, software failures, the ventilation system is dirty and the computer overheats when it is working hard)
Could you post your Computer's DxDiag?
To gather a DxDiag on your computer, please follow the steps here: https://help.ea.com/en-us/help/pc/how-to-gather-dxdiag-information/
You can attach the text file to your post directly in option "Reply" - not Quick Reply

I don't work for EA

Message 2 of 7 (149 Views)
Highlighted

Re: Slow loading and lags

[ Edited ]
★ Novice

Hi thankyou for your response, I'm going to try some of your other notes next but I thought I could do this quickly for you now.

 

So edit: I had already reset the game to factory settings which is what seemed to fix it for two days. Then I think when I tried to play an old save the game broke again so it could be one of the saves? However when I initially went back on to test the game folder by folder, my old save worked perfectly. But two days later it broke on the same save, which is when I emptied the tray folder because I thought that might be causing a lag.

Message 3 of 7 (139 Views)
Highlighted

Re: Slow loading and lags

[ Edited ]
★ Novice

@kreatoraMy apologies, I'm not meaning to be such a pain.
Just did another factory reset and there is still major lag and long loading screens, it did not fix it as before.

Message 4 of 7 (128 Views)
Highlighted

Re: Slow loading and lags

★ Expert
@Gingerjuggernaut

The basic problem is a bit to weak the graphics card that "borrows" memory from the system. It has 32MB dedicated memory. Requirements The Sims4 for the card is 128 MB of dedicated memory
I can suggest that you switch off all running programs in the background that you do not need during the game. In the first place turn off graphical programs and reduce the graphics requirements in the game options.
It doesn't help also that you have really old graphics card drivers - 8/27/2015. You need to download new drivers and install them
https://downloadcenter.intel.com/
You also have a problem with either the Apple iTunes application or with your Net framework - itw_scrobbler.dll file is missing or corrupted. If a simple computer restart will not remove this error the best way to fix it is to reinstall this application
I don't know how it affects the game, but if you want to check whether your net framework has no errors here is the Windows tool for it. (I wouldn't want to use this Apple application on Windows but this is just my private opinion.)
https://www.microsoft.com/en-gb/download/details.aspx?id=30135
One more question. Do you use CC and mods? And if so, after the reset of the game, did you put your old mods or CC back into the game?
Message 5 of 7 (100 Views)
Highlighted

Re: Slow loading and lags

★ Novice
@kreatora Hi sorry about the delayed reply, work took over. No I don't use any CC or mods.
Also what is Net framework? Once again, thanks!
Message 6 of 7 (72 Views)
Highlighted

Re: Slow loading and lags

★ Expert
@Gingerjuggernaut

.NET Framework, in short .NET - a development platform developed by Microsoft, including a runtime environment and class libraries that provide standard functionality for applications. But it isn't your basic problem.
Your basic problem is too weak graphics card and no too much RAM memory when your card is using it too.
I'm sorry to say, but your computer does not meet the game requirements anymore.
https://answers.ea.com/t5/Technical-Issues-PC/READ-FIRST-Make-sure-you-meet-minimum-requirements-PC-...
You can try the lowest graphics setting in the game option if you will able open the game menu. It may work because your computer is not much below these requirements, but you will never know when it will stop working again.
Message 7 of 7 (59 Views)
Twitter Stream