Sims 3 won't open: Alder Lake (Intel 12th-gen) CPU

by Fuchie
Reply

Original Post

Re: Sims 3 crashing after launcher

★★★ Novice

Okay so Good news and kind of Bad news-

 

Good news, the PowerShell script got my game to launch and although my card isn't recognised it still runs smoothly and so far no errors. Huge step forward as at least now I can get the launcher to actually LAUNCH.

 

Kind of bad news: My mods aren't working. Two of the mods I have is the NoIntro and NoBuildSparkles mods and the intro plays when I launch the game. I have tried deleting caches, replacing the mods, restarting the computer but nothing seemed to work. One that I haven't replaced though is the recourse cfg file because I don't know if there's a newer one or if I have to do something with the PowerShell thing to recognise the mods.

 

Any advice?

Message 81 of 571 (2,535 Views)

Re: Sims 3 crashing after launcher

@lozzomatic  The resource.cfg that comes with the Mods Framework you downloaded, i.e. the one with nointro and NoBuildSparkles, works just fine on any current (and most not-current) versions of Sims 3.  I haven't heard anything about people who use the PowerShell script not being able to use mods, or needing a workaround to get them to load, and given what percentage of Sims 3 players do use mods, it seems unlikely that none of the ones in this thread would have tried to add any.  Nor do I see any reason mods wouldn't work when the script was used.  So I'm guessing that mods do work with the script and you have a different issue.

 

It's still worth downloading a fresh copy of resource.cfg, on the off chance that helps.  Otherwise, one common reason mods wouldn't load is that they're in the wrong location, for example the Documents directory in OneDrive rather than the one stored locally on your computer.  You can right-click on a file or folder and select Properties > General to see its location.  Please make sure the full path is this:

 

C:\Users\[your username]\Documents\Electronic Arts\The Sims 3\Mods\Packages

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 82 of 571 (2,520 Views)

Re: Sims 3 crashing after launcher

[ Edited ]
★★★ Novice

I did as you said and the path is empty.

 

I got as far as C:\Users\[your username]\Documents but there's no Electronic Arts folder. The only other EA path under C: is through Programe Files 86 for BioWare and SWTOR. The only path I can get past it is through This PC - Documents- Electronic Arts-Sims 3. The mods folder was one I transferred from my old computer very recently and last time I played the mods all worked without a problem, in fact I thought they were all up to date from when I last checked just before the transfer. Perhaps the resource is the issue in which case do you have a link to the latest version of it?

Message 83 of 571 (2,511 Views)

Re: Sims 3 crashing after launcher

@lozzomatic  That's a bit odd, but it's not really anything to worry about if your saves and other content are showing up.  If you create a save in-game, does it show in This PC > Documents > Electronic Arts > The Sims 3 > Saves?  If so, that's the correct folder to use.

 

For the mods, it's definitely a good idea to download a new framework and test—it's always possible that your Mods folder was corrupted during the transfer process.  You can get a new copy of the framework here:

 

https://modthesims.info/wiki.php?title=Game_Help:Installing_Sims_3_Package_Files/Setup_and_Files

 

If nointro and nobuildsparkles work, you may need to redownload your other mods.  Alternately, you can try transferring the Mods folder from your old computer again, except this time, zip it beforehand: right-click and select Send to > Compressed (Zip) file.  Extract it once it's on your new computer and see whether it works this time.  But if not, you'll need to redownload the mods.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 84 of 571 (2,495 Views)

Re: Sims 3 crashing after launcher

★★★ Novice

Re-downloading fresh mods did the trick, I think it was the resource file that was acting up or something. Either way, now the intro is gone and the pop up for the mods show upon the main menu.

At least in my experience the PowerShell method worked. I think the mods was more a separate thing, as you said, they probably got corrupted or something.

 

Finally I can play the damn game! Thank you all for the help

Message 85 of 571 (2,472 Views)

Re: The Sims 3 Launcher not working

★ Novice

I just got an i9 12900k and also having the same issue this guy is having, no matter what I do, wont start, through origin. I also am running DDR4 ram sticks

Message 86 of 571 (2,464 Views)

Re: The Sims 3 Launcher not working

@Wolfseystorm  Did you try using the script posted here:

 

https://answers.ea.com/t5/Technical-Issues-PC/Sims-3-won-t-open-Alder-Lake-Intel-12th-gen-CPU/m-p/11...

 

or using Process Lasso to limit the game to one core while it's loading, as described on the previous page?

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 87 of 571 (2,457 Views)

Re: sims 3 doesn't start

★★ Novice

Hi Miaa245! Thank you for making this wonderful script! I'm so glad to see its helping so many people! Unfortunately I can't seem to get it to work with my computer. I keep getting red text citing that same error with CPU affinity and access denied. I've tried granting more permissions to the script, lessening permissions on my Sims 3 files, and restarting my computer several times. I'm not quite sure what else to do. Any tips? Please and thank you.

Message 88 of 571 (2,415 Views)

Re: sims 3 doesn't start

@nikoarby  Please post a screenshot of the error you're seeing.  Please also run a dxdiag and attach it to a post.

 

https://help.ea.com/en/help/pc/how-to-gather-dxdiag-information/

 

I'm not sure I'll be able to help, but perhaps @Miaa245 will have an idea.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 89 of 571 (2,407 Views)

Re: sims 3 doesn't start

★★ Novice

Another "victim" of this bug is the Create-A-World tool, i.e. the In-Game Editor of it. The powershell script doesn't work for this, sadly. CAW starts as supposed too, and seems to work as usual. But the EIG Editor calls TS3.exe/TS3W.exe and that doesn't work at all, not even if I start the powershell script first.

Message 90 of 571 (2,259 Views)
Twitter Stream