Sims 3 won't open: Alder Lake (Intel 12th-gen) CPU

by Fuchie
Reply

Original Post

Re: Sims 3 crashing after launcher

★★★★ Novice
@Miaa245 Hi Mia, your solution worked great for me. I was able to run the game and everything!
But today I tried to launch the game and it's started to crash to origin again, and I've been doing what you said every time. I'm not sure what changed, or what I should do now.
Message 61 of 469 (1,908 Views)

Re: Sims 3 crashing after launcher

★★★★ Novice
@ImThatKateGirI an update to this!!
I just downloaded the updated version of project lasso and it worked!!
Message 62 of 469 (1,903 Views)

Re: Sims 3 Not Launching with Origin

@chiara0911  To make sure you're having the same issue, please run a dxdiag and attach it to a post so we can see your hardware.

 

https://help.ea.com/en/help/pc/how-to-gather-dxdiag-information/

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 63 of 469 (1,894 Views)

Re: Sims 3 crashing after launcher

★ Apprentice

@ImThatKateGirI

 

I'm glad you got it to work! You might want to use the script I made instead, it would make your life a lot easier. Standard smile

 

You don't need Process Lasso at all, just to run the script before you open the game. Do make sure that you uninstall Process Lasso first, or at least make sure it's not running in the background.

 

https://answers.ea.com/t5/Technical-Issues-PC/Sims-3-won-t-open-Alder-Lake-Intel-12th-gen-CPU/m-p/11...

Message 64 of 469 (1,878 Views)

Re: Sims 3 crashing after launcher

★★★★ Novice
@Miaa245 ooh! i didnt realize that the script alone would work. ill definitely try that out. thanks!
Message 65 of 469 (1,874 Views)

sims 3 doesn't start

★ Novice

Contacted EA about The Sims 3 not starting from origin, when starting the launcher and clicking play the launcher closes and sends me back to origin. I've tried reinstalling, repairing files, disabling firewall and more but nothing has worked. They wanted me to post this problem here to here we go.

Message 66 of 469 (1,823 Views)

Re: sims 3 doesn't start

@armorguy1234  The issue is that Sims 3 doesn't run properly on Intel 12th-gen (Alder Lake) processors.  I've merged your post with the master thread for this issue.

 

If you like, you can try running the PowerShell script posted here:

 

https://answers.ea.com/t5/Technical-Issues-PC/Sims-3-won-t-open-Alder-Lake-Intel-12th-gen-CPU/m-p/11...

 

Or you can use a tool like Process Lasso to limit the game to one core.  The setting can be undone after the game launches.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 67 of 469 (1,795 Views)

Re: sims 3 doesn't start

[ Edited ]
★ Novice

@puzzlezaddict Hmmm, well I tried the PowerShell script thing and it didn't work or maybe just did it wrong. I also downloaded process lasso but I have no idea how to use it lol.

Message 68 of 469 (1,747 Views)

Re: sims 3 doesn't start

@armorguy1234  I didn't write the script, so I can't really help troubleshoot any errors with it.  But it's worth trying again—so far, the other users who've reported back say it works.  Perhaps @Miaa245 might have some insights.

 

The point of Process Lasso is to use it to limit TS3.exe (Origin install) or TS3W.exe (disc or Steam install) to using one CPU core while it's loading.  A google search brought up plenty of guides on how to set it up.

——————————————————————————————————————————

I don't work for EA. I'm just trying to help fellow players with their games.
Message 69 of 469 (1,717 Views)

Sims 3 launcher opens Origin

[ Edited ]
★★★ Novice

I just got a new PC and I am trying to play TS3 on it. When I press play in Origin, the launcher opens. When I press play in the launcher, the game does not open. After pressing play though, the launcher disappears and Origin opens. I Installed all of my graphics card and motherboard drivers, so I don't think they are the problem. I've also tried reinstalling the game, sometimes deleting all old game files and folders to get a clean reinstall. I also tried repairing the game files in Origin. None of it is working. I ran a DxDiag.

Message 70 of 469 (1,729 Views)
Twitter Stream